| 9981 | Resource Public Key Infrastructure (RPKI) Manifest Number HandlingT. Harrison, G. Michaelson, J. Snijders | Proposed Standard | May 2026 |
| 9977 | Publishing End-Site Prefix LengthsO. Gasser, R. Bush, M. Candela, R. Housley | Proposed Standard | May 2026 |
| 9829 | Handling of Resource Public Key Infrastructure (RPKI) Certificate Revocation List (CRL) Number ExtensionsJ. Snijders, B. Maddison, T. Buehler | Proposed Standard | July 2025 |
| 9691 | A Profile for Resource Public Key Infrastructure (RPKI) Trust Anchor Keys (TAKs)C. Martinez, G. Michaelson, T. Harrison, T. Bruijnzeels, R. Austein | Proposed Standard | December 2024 |
| 9632 | Finding and Using Geofeed DataR. Bush, M. Candela, W. Kumari, R. Housley | Proposed Standard | August 2024 |
| 9582 | A Profile for Route Origin Authorizations (ROAs)J. Snijders, B. Maddison, M. Lepinski, D. Kong, S. Kent | Proposed Standard | May 2024 |
| 9323 | A Profile for RPKI Signed Checklists (RSCs)J. Snijders, T. Harrison, B. Maddison | Proposed Standard | November 2022 |
| 9286 | Manifests for the Resource Public Key Infrastructure (RPKI)R. Austein, G. Huston, S. Kent, M. Lepinski | Proposed Standard | June 2022 |
| 8897 | Requirements for Resource Public Key Infrastructure (RPKI) Relying PartiesD. Ma, S. Kent | Informational | September 2020 |
| 8630 | Resource Public Key Infrastructure (RPKI) Trust Anchor LocatorG. Huston, S. Weiler, G. Michaelson, S. Kent, T. Bruijnzeels | Proposed Standard | August 2019 |
| 8488 | RIPE NCC's Implementation of Resource Public Key Infrastructure (RPKI) Certificate Tree ValidationO. Muravskiy, T. Bruijnzeels | Informational | December 2018 |
| 8416 | Simplified Local Internet Number Resource Management with the RPKI (SLURM)D. Ma, D. Mandelberg, T. Bruijnzeels | Proposed Standard | August 2018 |
| 8374 | BGPsec Design Choices and Summary of Supporting DiscussionsK. Sriram, Ed. | Informational | April 2018 |
| 8360 | Resource Public Key Infrastructure (RPKI) Validation ReconsideredG. Huston, G. Michaelson, C. Martinez, T. Bruijnzeels, A. Newton, D. Shaw | Proposed Standard | April 2018 |
| 8211 | Adverse Actions by a Certification Authority (CA) or Repository Manager in the Resource Public Key Infrastructure (RPKI)S. Kent, D. Ma | Informational | September 2017 |
| 8210 | The Resource Public Key Infrastructure (RPKI) to Router Protocol, Version 1R. Bush, R. Austein | Proposed Standard | September 2017 |
| 8209 | A Profile for BGPsec Router Certificates, Certificate Revocation Lists, and Certification RequestsM. Reynolds, S. Turner, S. Kent | Proposed Standard | September 2017 |
| 8205 | BGPsec Protocol SpecificationM. Lepinski, Ed., K. Sriram, Ed. | Proposed Standard | September 2017 |
| 8182 | The RPKI Repository Delta Protocol (RRDP)T. Bruijnzeels, O. Muravskiy, B. Weber, R. Austein | Proposed Standard | July 2017 |
| 7935 | The Profile for Algorithms and Key Sizes for Use in the Resource Public Key InfrastructureG. Huston, G. Michaelson, Ed. | Proposed Standard | August 2016 |
| 7909 | Securing Routing Policy Specification Language (RPSL) Objects with Resource Public Key Infrastructure (RPKI) SignaturesR. Kisteleki, B. Haberman | Proposed Standard | June 2016 |
| 7730 | Resource Public Key Infrastructure (RPKI) Trust Anchor LocatorG. Huston, S. Weiler, G. Michaelson, S. Kent · obsoleted by RFC 8630 | Proposed Standard | January 2016 |
| 7382 | Template for a Certification Practice Statement (CPS) for the Resource PKI (RPKI)S. Kent, D. Kong, K. Seo | Best Current Practice | April 2015 |
| 7318 | Policy Qualifiers in Resource Public Key Infrastructure (RPKI) CertificatesA. Newton, G. Huston | Proposed Standard | July 2014 |
| 7299 | Object Identifier Registry for the PKIX Working GroupR. Housley | Informational | July 2014 |
| 7132 | Threat Model for BGP Path SecurityS. Kent, A. Chi | Informational | February 2014 |
| 7115 | Origin Validation Operation Based on the Resource Public Key Infrastructure (RPKI)R. Bush | Best Current Practice | January 2014 |
| 6907 | Use Cases and Interpretations of Resource Public Key Infrastructure (RPKI) Objects for Issuers and Relying PartiesT. Manderson, K. Sriram, R. White | Informational | March 2013 |
| 6495 | Subject Key Identifier (SKI) SEcure Neighbor Discovery (SEND) Name Type FieldsR. Gagliano, S. Krishnan, A. Kukec | Proposed Standard | February 2012 |
| 6494 | Certificate Profile and Certificate Management for SEcure Neighbor Discovery (SEND)R. Gagliano, S. Krishnan, A. Kukec | Proposed Standard | February 2012 |
| 6492 | A Protocol for Provisioning Resource CertificatesG. Huston, R. Loomans, B. Ellacott, R. Austein | Proposed Standard | February 2012 |
| 6491 | Resource Public Key Infrastructure (RPKI) Objects Issued by IANAT. Manderson, L. Vegoda, S. Kent | Proposed Standard | February 2012 |
| 6490 | Resource Public Key Infrastructure (RPKI) Trust Anchor LocatorG. Huston, S. Weiler, G. Michaelson, S. Kent · obsoleted by RFC 7730 | Proposed Standard | February 2012 |
| 6489 | Certification Authority (CA) Key Rollover in the Resource Public Key Infrastructure (RPKI)G. Huston, G. Michaelson, S. Kent | Best Current Practice | February 2012 |
| 6488 | Signed Object Template for the Resource Public Key Infrastructure (RPKI)M. Lepinski, A. Chi, S. Kent | Proposed Standard | February 2012 |
| 6486 | Manifests for the Resource Public Key Infrastructure (RPKI)R. Austein, G. Huston, S. Kent, M. Lepinski · obsoleted by RFC 9286 | Proposed Standard | February 2012 |
| 6485 | The Profile for Algorithms and Key Sizes for Use in the Resource Public Key Infrastructure (RPKI)G. Huston · obsoleted by RFC 7935 | Proposed Standard | February 2012 |
| 6484 | Certificate Policy (CP) for the Resource Public Key Infrastructure (RPKI)S. Kent, D. Kong, K. Seo, R. Watro | Best Current Practice | February 2012 |
| 6482 | A Profile for Route Origin Authorizations (ROAs)M. Lepinski, S. Kent, D. Kong · obsoleted by RFC 9582 | Proposed Standard | February 2012 |
| 6481 | A Profile for Resource Certificate Repository StructureG. Huston, R. Loomans, G. Michaelson | Proposed Standard | February 2012 |
| 6480 | An Infrastructure to Support Secure Internet RoutingM. Lepinski, S. Kent | Informational | February 2012 |