| 9977 | Publishing End-Site Prefix LengthsO. Gasser, R. Bush, M. Candela, R. Housley | Proposed Standard | May 2026 |
| 9829 | Handling of Resource Public Key Infrastructure (RPKI) Certificate Revocation List (CRL) Number ExtensionsJ. Snijders, B. Maddison, T. Buehler | Proposed Standard | July 2025 |
| 9774 | Deprecation of AS_SET and AS_CONFED_SET in BGPW. Kumari, K. Sriram, L. Hannachi, J. Haas | Proposed Standard | May 2025 |
| 9691 | A Profile for Resource Public Key Infrastructure (RPKI) Trust Anchor Keys (TAKs)C. Martinez, G. Michaelson, T. Harrison, T. Bruijnzeels, R. Austein | Proposed Standard | December 2024 |
| 9632 | Finding and Using Geofeed DataR. Bush, M. Candela, W. Kumari, R. Housley | Proposed Standard | August 2024 |
| 9582 | A Profile for Route Origin Authorizations (ROAs)J. Snijders, B. Maddison, M. Lepinski, D. Kong, S. Kent | Proposed Standard | May 2024 |
| 9455 | Avoiding Route Origin Authorizations (ROAs) Containing Multiple IP PrefixesZ. Yan, R. Bush, G. Geng, T. de Kock, J. Yao | Best Current Practice | August 2023 |
| 9323 | A Profile for RPKI Signed Checklists (RSCs)J. Snijders, T. Harrison, B. Maddison | Proposed Standard | November 2022 |
| 9286 | Manifests for the Resource Public Key Infrastructure (RPKI)R. Austein, G. Huston, S. Kent, M. Lepinski | Proposed Standard | June 2022 |
| 9092 | Finding and Using Geofeed DataR. Bush, M. Candela, W. Kumari, R. Housley · obsoleted by RFC 9632 | Proposed Standard | July 2021 |
| 8910 | Captive-Portal Identification in DHCP and Router Advertisements (RAs)W. Kumari, E. Kline | Proposed Standard | September 2020 |
| 8897 | Requirements for Resource Public Key Infrastructure (RPKI) Relying PartiesD. Ma, S. Kent | Informational | September 2020 |
| 8630 | Resource Public Key Infrastructure (RPKI) Trust Anchor LocatorG. Huston, S. Weiler, G. Michaelson, S. Kent, T. Bruijnzeels | Proposed Standard | August 2019 |
| 8360 | Resource Public Key Infrastructure (RPKI) Validation ReconsideredG. Huston, G. Michaelson, C. Martinez, T. Bruijnzeels, A. Newton, D. Shaw | Proposed Standard | April 2018 |
| 8211 | Adverse Actions by a Certification Authority (CA) or Repository Manager in the Resource Public Key Infrastructure (RPKI)S. Kent, D. Ma | Informational | September 2017 |
| 8209 | A Profile for BGPsec Router Certificates, Certificate Revocation Lists, and Certification RequestsM. Reynolds, S. Turner, S. Kent | Proposed Standard | September 2017 |
| 8183 | An Out-of-Band Setup Protocol for Resource Public Key Infrastructure (RPKI) Production ServicesR. Austein | Proposed Standard | July 2017 |
| 7909 | Securing Routing Policy Specification Language (RPSL) Objects with Resource Public Key Infrastructure (RPKI) SignaturesR. Kisteleki, B. Haberman | Proposed Standard | June 2016 |
| 7730 | Resource Public Key Infrastructure (RPKI) Trust Anchor LocatorG. Huston, S. Weiler, G. Michaelson, S. Kent · obsoleted by RFC 8630 | Proposed Standard | January 2016 |
| 7382 | Template for a Certification Practice Statement (CPS) for the Resource PKI (RPKI)S. Kent, D. Kong, K. Seo | Best Current Practice | April 2015 |
| 7299 | Object Identifier Registry for the PKIX Working GroupR. Housley | Informational | July 2014 |
| 7132 | Threat Model for BGP Path SecurityS. Kent, A. Chi | Informational | February 2014 |
| 6916 | Algorithm Agility Procedure for the Resource Public Key Infrastructure (RPKI)R. Gagliano, S. Kent, S. Turner | Best Current Practice | April 2013 |
| 6907 | Use Cases and Interpretations of Resource Public Key Infrastructure (RPKI) Objects for Issuers and Relying PartiesT. Manderson, K. Sriram, R. White | Informational | March 2013 |
| 6811 | BGP Prefix Origin ValidationP. Mohapatra, J. Scudder, D. Ward, R. Bush, R. Austein | Proposed Standard | January 2013 |
| 6495 | Subject Key Identifier (SKI) SEcure Neighbor Discovery (SEND) Name Type FieldsR. Gagliano, S. Krishnan, A. Kukec | Proposed Standard | February 2012 |
| 6494 | Certificate Profile and Certificate Management for SEcure Neighbor Discovery (SEND)R. Gagliano, S. Krishnan, A. Kukec | Proposed Standard | February 2012 |
| 6493 | The Resource Public Key Infrastructure (RPKI) Ghostbusters RecordR. Bush | Historic | February 2012 |
| 6492 | A Protocol for Provisioning Resource CertificatesG. Huston, R. Loomans, B. Ellacott, R. Austein | Proposed Standard | February 2012 |
| 6491 | Resource Public Key Infrastructure (RPKI) Objects Issued by IANAT. Manderson, L. Vegoda, S. Kent | Proposed Standard | February 2012 |
| 6490 | Resource Public Key Infrastructure (RPKI) Trust Anchor LocatorG. Huston, S. Weiler, G. Michaelson, S. Kent · obsoleted by RFC 7730 | Proposed Standard | February 2012 |
| 6489 | Certification Authority (CA) Key Rollover in the Resource Public Key Infrastructure (RPKI)G. Huston, G. Michaelson, S. Kent | Best Current Practice | February 2012 |
| 6488 | Signed Object Template for the Resource Public Key Infrastructure (RPKI)M. Lepinski, A. Chi, S. Kent | Proposed Standard | February 2012 |
| 6487 | A Profile for X.509 PKIX Resource CertificatesG. Huston, G. Michaelson, R. Loomans | Proposed Standard | February 2012 |
| 6486 | Manifests for the Resource Public Key Infrastructure (RPKI)R. Austein, G. Huston, S. Kent, M. Lepinski · obsoleted by RFC 9286 | Proposed Standard | February 2012 |
| 6484 | Certificate Policy (CP) for the Resource Public Key Infrastructure (RPKI)S. Kent, D. Kong, K. Seo, R. Watro | Best Current Practice | February 2012 |
| 6483 | Validation of Route Origination Using the Resource Certificate Public Key Infrastructure (PKI) and Route Origin Authorizations (ROAs)G. Huston, G. Michaelson | Informational | February 2012 |
| 6482 | A Profile for Route Origin Authorizations (ROAs)M. Lepinski, S. Kent, D. Kong · obsoleted by RFC 9582 | Proposed Standard | February 2012 |
| 6481 | A Profile for Resource Certificate Repository StructureG. Huston, R. Loomans, G. Michaelson | Proposed Standard | February 2012 |
| 6480 | An Infrastructure to Support Secure Internet RoutingM. Lepinski, S. Kent | Informational | February 2012 |
| 6472 | Recommendation for Not Using AS_SET and AS_CONFED_SET in BGPW. Kumari, K. Sriram · obsoleted by RFC 9774 | Best Current Practice | December 2011 |
| 6268 | Additional New ASN.1 Modules for the Cryptographic Message Syntax (CMS) and the Public Key Infrastructure Using X.509 (PKIX)J. Schaad, S. Turner | Informational | July 2011 |
| 4945 | The Internet IP Security PKI Profile of IKEv1/ISAKMP, IKEv2, and PKIXB. Korver | Proposed Standard | August 2007 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |