| 9915 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)T. Mrugalski, B. Volz, M. Richardson, S. Jiang, T. Winters | Internet Standard | January 2026 |
| 9777 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6B. Haberman, Ed. | Internet Standard | March 2025 |
| 9776 | Internet Group Management Protocol, Version 3B. Haberman, Ed. | Internet Standard | March 2025 |
| 9338 | CBOR Object Signing and Encryption (COSE): CountersignaturesJ. Schaad | Internet Standard | December 2022 |
| 9293 | Transmission Control Protocol (TCP)W. Eddy, Ed. | Internet Standard | August 2022 |
| 9224 | Finding the Authoritative Registration Data Access Protocol (RDAP) ServiceM. Blanchet | Internet Standard | March 2022 |
| 9112 | HTTP/1.1R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9111 | HTTP CachingR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9083 | JSON Responses for the Registration Data Access Protocol (RDAP)S. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9082 | Registration Data Access Protocol (RDAP) Query FormatS. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9052 | CBOR Object Signing and Encryption (COSE): Structures and ProcessJ. Schaad | Internet Standard | August 2022 |
| 8949 | Concise Binary Object Representation (CBOR)C. Bormann, P. Hoffman | Internet Standard | December 2020 |
| 8945 | Secret Key Transaction Authentication for DNS (TSIG)F. Dupont, S. Morris, P. Vixie, D. Eastlake 3rd, O. Gudmundsson, B. Wellington | Internet Standard | November 2020 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8259 | The JavaScript Object Notation (JSON) Data Interchange FormatT. Bray, Ed. | Internet Standard | December 2017 |
| 8201 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul, R. Hinden, Ed. | Internet Standard | July 2017 |
| 8200 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden | Internet Standard | July 2017 |
| 8098 | Message Disposition NotificationT. Hansen, Ed., A. Melnikov, Ed. | Internet Standard | February 2017 |
| 8077 | Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)L. Martini, Ed., G. Heron, Ed. | Internet Standard | February 2017 |
| 8011 | Internet Printing Protocol/1.1: Model and SemanticsM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 8010 | Internet Printing Protocol/1.1: Encoding and TransportM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 7761 | Protocol Independent Multicast - Sparse Mode (PIM-SM): Protocol Specification (Revised)B. Fenner, M. Handley, H. Holbrook, I. Kouvelas, R. Parekh, Z. Zhang, L. Zheng | Internet Standard | March 2016 |
| 7757 | Explicit Address Mappings for Stateless IP/ICMP TranslationT. Anderson, A. Leiva Popper | Internet Standard | February 2016 |
| 7680 | A One-Way Loss Metric for IP Performance Metrics (IPPM)G. Almes, S. Kalidindi, M. Zekauskas, A. Morton, Ed. | Internet Standard | January 2016 |
| 7679 | A One-Way Delay Metric for IP Performance Metrics (IPPM)G. Almes, S. Kalidindi, M. Zekauskas, A. Morton, Ed. | Internet Standard | January 2016 |
| 7481 | Security Services for the Registration Data Access Protocol (RDAP)S. Hollenbeck, N. Kong | Internet Standard | March 2015 |
| 7480 | HTTP Usage in the Registration Data Access Protocol (RDAP)A. Newton, B. Ellacott, N. Kong | Internet Standard | March 2015 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |
| 7011 | Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow InformationB. Claise, Ed., B. Trammell, Ed., P. Aitken | Internet Standard | September 2013 |
| 6891 | Extension Mechanisms for DNS (EDNS(0))J. Damas, M. Graff, P. Vixie | Internet Standard | April 2013 |
| 6522 | The Multipart/Report Media Type for the Reporting of Mail System Administrative MessagesM. Kucherawy, Ed. | Internet Standard | January 2012 |
| 6409 | Message Submission for MailR. Gellens, J. Klensin | Internet Standard | November 2011 |
| 6376 | DomainKeys Identified Mail (DKIM) SignaturesD. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed. | Internet Standard | September 2011 |
| 6353 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)W. Hardaker | Internet Standard | July 2011 |
| 6152 | SMTP Service Extension for 8-bit MIME TransportJ. Klensin, N. Freed, M. Rose, D. Crocker, Ed. | Internet Standard | March 2011 |
| 5734 | Extensible Provisioning Protocol (EPP) Transport over TCPS. Hollenbeck | Internet Standard | August 2009 |
| 5733 | Extensible Provisioning Protocol (EPP) Contact MappingS. Hollenbeck | Internet Standard | August 2009 |
| 5732 | Extensible Provisioning Protocol (EPP) Host MappingS. Hollenbeck | Internet Standard | August 2009 |
| 5731 | Extensible Provisioning Protocol (EPP) Domain Name MappingS. Hollenbeck | Internet Standard | August 2009 |
| 5730 | Extensible Provisioning Protocol (EPP)S. Hollenbeck | Internet Standard | August 2009 |
| 5652 | Cryptographic Message Syntax (CMS)R. Housley | Internet Standard | September 2009 |
| 5591 | Transport Security Model for the Simple Network Management Protocol (SNMP)D. Harrington, W. Hardaker | Internet Standard | June 2009 |
| 5590 | Transport Subsystem for the Simple Network Management Protocol (SNMP)D. Harrington, J. Schoenwaelder | Internet Standard | June 2009 |
| 5343 | Simple Network Management Protocol (SNMP) Context EngineID DiscoveryJ. Schoenwaelder | Internet Standard | September 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5011 | Automated Updates of DNS Security (DNSSEC) Trust AnchorsM. StJohns | Internet Standard | September 2007 |
| 4506 | XDR: External Data Representation StandardM. Eisler, Ed. | Internet Standard | May 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3596 | DNS Extensions to Support IP Version 6S. Thomson, C. Huitema, V. Ksinant, M. Souissi | Internet Standard | October 2003 |
| 3551 | RTP Profile for Audio and Video Conferences with Minimal ControlH. Schulzrinne, S. Casner | Internet Standard | July 2003 |
| 3550 | RTP: A Transport Protocol for Real-Time ApplicationsH. Schulzrinne, S. Casner, R. Frederick, V. Jacobson | Internet Standard | July 2003 |
| 3418 | Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)R. Presuhn, Ed. | Internet Standard | December 2002 |
| 3417 | Transport Mappings for the Simple Network Management Protocol (SNMP)R. Presuhn, Ed. | Internet Standard | December 2002 |
| 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)R. Presuhn, Ed. | Internet Standard | December 2002 |
| 3415 | View-based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)B. Wijnen, R. Presuhn, K. McCloghrie | Internet Standard | December 2002 |
| 3414 | User-based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)U. Blumenthal, B. Wijnen | Internet Standard | December 2002 |
| 3413 | Simple Network Management Protocol (SNMP) ApplicationsD. Levi, P. Meyer, B. Stewart | Internet Standard | December 2002 |
| 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)J. Case, D. Harrington, R. Presuhn, B. Wijnen | Internet Standard | December 2002 |
| 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksD. Harrington, R. Presuhn, B. Wijnen | Internet Standard | December 2002 |
| 2920 | SMTP Service Extension for Command PipeliningN. Freed | Internet Standard | September 2000 |
| 2819 | Remote Network Monitoring Management Information BaseS. Waldbusser | Internet Standard | May 2000 |
| 2580 | Conformance Statements for SMIv2K. McCloghrie, Ed., D. Perkins, Ed., J. Schoenwaelder, Ed. | Internet Standard | April 1999 |
| 2579 | Textual Conventions for SMIv2K. McCloghrie, Ed., D. Perkins, Ed., J. Schoenwaelder, Ed. | Internet Standard | April 1999 |
| 2578 | Structure of Management Information Version 2 (SMIv2)K. McCloghrie, Ed., D. Perkins, Ed., J. Schoenwaelder, Ed. | Internet Standard | April 1999 |
| 2453 | RIP Version 2G. Malkin | Internet Standard | November 1998 |
| 2427 | Multiprotocol Interconnect over Frame RelayC. Brown, A. Malis | Internet Standard | September 1998 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 2289 | A One-Time Password SystemN. Haller, C. Metz, P. Nesser, M. Straw | Internet Standard | February 1998 |
| 1939 | Post Office Protocol - Version 3J. Myers, M. Rose | Internet Standard | May 1996 |
| 1870 | SMTP Service Extension for Message Size DeclarationJ. Klensin, N. Freed, K. Moore | Internet Standard | November 1995 |
| 1869 | SMTP Service ExtensionsJ. Klensin, N. Freed, M. Rose, E. Stefferud, D. Crocker · obsoleted by RFC 2821 | Internet Standard | November 1995 |
| 1725 | Post Office Protocol - Version 3J. Myers, M. Rose · obsoleted by RFC 1939 | Internet Standard | November 1994 |
| 1723 | RIP Version 2 - Carrying Additional InformationG. Malkin · obsoleted by RFC 2453 | Internet Standard | November 1994 |
| 1722 | RIP Version 2 Protocol Applicability StatementG. Malkin | Internet Standard | November 1994 |
| 1662 | PPP in HDLC-like FramingW. Simpson, Ed. | Internet Standard | July 1994 |
| 1661 | The Point-to-Point Protocol (PPP)W. Simpson, Ed. | Internet Standard | July 1994 |
| 1390 | Transmission of IP and ARP over FDDI NetworksD. Katz | Internet Standard | January 1993 |
| 1350 | The TFTP Protocol (Revision 2)K. Sollins | Internet Standard | July 1992 |
| 1213 | Management Information Base for Network Management of TCP/IP-based internets: MIB-IIK. McCloghrie, M. Rose | Internet Standard | March 1991 |
| 1212 | Concise MIB definitionsM.T. Rose, K. McCloghrie | Internet Standard | March 1991 |
| 1209 | The Transmission of IP Datagrams over the SMDS ServiceD. Piscitello, J. Lawrence | Internet Standard | March 1991 |
| 1201 | Transmitting IP traffic over ARCNET networksD. Provan | Internet Standard | February 1991 |
| 1155 | Structure and identification of management information for TCP/IP-based internetsM.T. Rose, K. McCloghrie | Internet Standard | May 1990 |
| 1132 | Standard for the transmission of 802.2 packets over IPX networksL.J. McLaughlin | Internet Standard | November 1989 |
| 1123 | Requirements for Internet Hosts - Application and SupportR. Braden, Ed. | Internet Standard | October 1989 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1112 | Host extensions for IP multicastingS.E. Deering | Internet Standard | August 1989 |
| 1088 | Standard for the transmission of IP datagrams over NetBIOS networksL.J. McLaughlin | Internet Standard | February 1989 |
| 1065 | Structure and identification of management information for TCP/IP-based internetsK. McCloghrie, M.T. Rose · obsoleted by RFC 1155 | Internet Standard | August 1988 |
| 1055 | Nonstandard for transmission of IP datagrams over serial lines: SLIPJ.L. Romkey | Internet Standard | June 1988 |
| 1044 | Internet Protocol on Network System's HYPERchannel: Protocol SpecificationK. Hardwick, J. Lekashman | Internet Standard | February 1988 |
| 1042 | Standard for the transmission of IP datagrams over IEEE 802 networksJ. Postel, J.K. Reynolds | Internet Standard | February 1988 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1006 | ISO Transport Service on top of the TCP Version: 3M.T. Rose, D.E. Cass | Internet Standard | May 1987 |
| 1002 | Protocol standard for a NetBIOS service on a TCP/UDP transport: Detailed specificationsNetBIOS Working Group in the Defense Advanced Research Projects Agency, Internet Activities Board, End-to-End Services Task Force | Internet Standard | March 1987 |
| 1001 | Protocol standard for a NetBIOS service on a TCP/UDP transport: Concepts and methodsNetBIOS Working Group in the Defense Advanced Research Projects Agency, Internet Activities Board, End-to-End Services Task Force | Internet Standard | March 1987 |
| 959 | File Transfer ProtocolJ. Postel, J. Reynolds | Internet Standard | October 1985 |
| 950 | Internet Standard Subnetting ProcedureJ.C. Mogul, J. Postel | Internet Standard | August 1985 |
| 922 | Broadcasting Internet datagrams in the presence of subnetsJ.C. Mogul | Internet Standard | October 1984 |
| 919 | Broadcasting Internet DatagramsJ.C. Mogul | Internet Standard | October 1984 |
| 907 | Host Access Protocol specificationBolt Beranek and Newman Laboratories | Internet Standard | July 1984 |
| 903 | A Reverse Address Resolution ProtocolR. Finlayson, T. Mann, J.C. Mogul, M. Theimer | Internet Standard | June 1984 |
| 895 | Standard for the transmission of IP datagrams over experimental Ethernet networksJ. Postel | Internet Standard | April 1984 |
| 894 | A Standard for the Transmission of IP Datagrams over Ethernet NetworksC. Hornig | Internet Standard | April 1984 |
| 891 | DCN Local-Network ProtocolsD.L. Mills | Internet Standard | December 1983 |
| 868 | Time ProtocolJ. Postel, K. Harrenstien | Internet Standard | May 1983 |
| 867 | Daytime ProtocolJ. Postel | Internet Standard | May 1983 |
| 866 | Active usersJ. Postel | Internet Standard | May 1983 |
| 865 | Quote of the Day ProtocolJ. Postel | Internet Standard | May 1983 |
| 864 | Character Generator ProtocolJ. Postel | Internet Standard | May 1983 |
| 863 | Discard ProtocolJ. Postel | Internet Standard | May 1983 |
| 862 | Echo ProtocolJ. Postel | Internet Standard | May 1983 |
| 861 | Telnet Extended Options: List OptionJ. Postel, J. Reynolds | Internet Standard | May 1983 |
| 860 | Telnet Timing Mark OptionJ. Postel, J. Reynolds | Internet Standard | May 1983 |
| 859 | Telnet Status OptionJ. Postel, J. Reynolds | Internet Standard | May 1983 |
| 858 | Telnet Suppress Go Ahead OptionJ. Postel, J. Reynolds | Internet Standard | May 1983 |
| 857 | Telnet Echo OptionJ. Postel, J. Reynolds | Internet Standard | May 1983 |
| 856 | Telnet Binary TransmissionJ. Postel, J. Reynolds | Internet Standard | May 1983 |
| 855 | Telnet Option SpecificationsJ. Postel, J.K. Reynolds | Internet Standard | May 1983 |
| 854 | Telnet Protocol SpecificationJ. Postel, J.K. Reynolds | Internet Standard | May 1983 |
| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 822 | STANDARD FOR THE FORMAT OF ARPA INTERNET TEXT MESSAGESD. Crocker · obsoleted by RFC 2822 | Internet Standard | August 1982 |
| 821 | Simple Mail Transfer ProtocolJ. Postel · obsoleted by RFC 2821 | Internet Standard | August 1982 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 792 | Internet Control Message ProtocolJ. Postel | Internet Standard | September 1981 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 20 | ASCII format for network interchangeV.G. Cerf | Internet Standard | October 1969 |