| 12 | IMP-Host interface flow diagramsM. Wingfield | Unknown | August 1969 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 3279 | Algorithms and Identifiers for the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileL. Bassham, W. Polk, R. Housley | Proposed Standard | May 2002 |
| 3280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileR. Housley, W. Polk, W. Ford, D. Solo · obsoleted by RFC 5280 | Proposed Standard | May 2002 |
| 3552 | Guidelines for Writing RFC Text on Security ConsiderationsE. Rescorla, B. Korver | Best Current Practice | July 2003 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4346 | The Transport Layer Security (TLS) Protocol Version 1.1T. Dierks, E. Rescorla · obsoleted by RFC 5246 | Historic | April 2006 |
| 4366 | Transport Layer Security (TLS) ExtensionsS. Blake-Wilson, M. Nystrom, D. Hopwood, J. Mikkelsen, T. Wright · obsoleted by RFC 5246, RFC 6066 | Proposed Standard | April 2006 |
| 4492 | Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)S. Blake-Wilson, N. Bolyard, V. Gupta, C. Hawk, B. Moeller · obsoleted by RFC 8422 | Informational | May 2006 |
| 5077 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | January 2008 |
| 5116 | An Interface and Algorithms for Authenticated EncryptionD. McGrew | Proposed Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5705 | Keying Material Exporters for Transport Layer Security (TLS)E. Rescorla | Proposed Standard | March 2010 |
| 5756 | Updates for RSAES-OAEP and RSASSA-PSS Algorithm ParametersS. Turner, D. Brown, K. Yiu, R. Housley, T. Polk | Proposed Standard | January 2010 |
| 5763 | Framework for Establishing a Secure Real-time Transport Protocol (SRTP) Security Context Using Datagram Transport Layer Security (DTLS)J. Fischl, H. Tschofenig, E. Rescorla | Proposed Standard | May 2010 |
| 5764 | Datagram Transport Layer Security (DTLS) Extension to Establish Keys for the Secure Real-time Transport Protocol (SRTP)D. McGrew, E. Rescorla | Proposed Standard | May 2010 |
| 5869 | HMAC-based Extract-and-Expand Key Derivation Function (HKDF)H. Krawczyk, P. Eronen | Informational | May 2010 |
| 5929 | Channel Bindings for TLSJ. Altman, N. Williams, L. Zhu | Proposed Standard | July 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6091 | Using OpenPGP Keys for Transport Layer Security (TLS) AuthenticationN. Mavrogiannopoulos, D. Gillmor | Informational | February 2011 |
| 6101 | The Secure Sockets Layer (SSL) Protocol Version 3.0A. Freier, P. Karlton, P. Kocher | Historic | August 2011 |
| 6176 | Prohibiting Secure Sockets Layer (SSL) Version 2.0S. Turner, T. Polk | Proposed Standard | March 2011 |
| 6520 | Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat ExtensionR. Seggelmann, M. Tuexen, M. Williams | Proposed Standard | February 2012 |
| 6655 | AES-CCM Cipher Suites for Transport Layer Security (TLS)D. McGrew, D. Bailey | Proposed Standard | July 2012 |
| 6960 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPS. Santesson, M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams | Proposed Standard | June 2013 |
| 6961 | The Transport Layer Security (TLS) Multiple Certificate Status Request ExtensionY. Pettersen · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | June 2013 |
| 6962 | Certificate TransparencyB. Laurie, A. Langley, E. Kasper · obsoleted by RFC 9162 | Experimental | June 2013 |
| 6979 | Deterministic Usage of the Digital Signature Algorithm (DSA) and Elliptic Curve Digital Signature Algorithm (ECDSA)T. Pornin | Informational | August 2013 |
| 7250 | Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Wouters, Ed., H. Tschofenig, Ed., J. Gilmore, S. Weiler, T. Kivinen | Proposed Standard | June 2014 |
| 7301 | Transport Layer Security (TLS) Application-Layer Protocol Negotiation ExtensionS. Friedl, A. Popov, A. Langley, E. Stephan | Proposed Standard | July 2014 |
| 7465 | Prohibiting RC4 Cipher SuitesA. Popov | Proposed Standard | February 2015 |
| 7507 | TLS Fallback Signaling Cipher Suite Value (SCSV) for Preventing Protocol Downgrade AttacksB. Moeller, A. Langley · obsoleted by RFC 8996 | Proposed Standard | April 2015 |
| 7568 | Deprecating Secure Sockets Layer Version 3.0R. Barnes, M. Thomson, A. Pironti, A. Langley | Proposed Standard | June 2015 |
| 7624 | Confidentiality in the Face of Pervasive Surveillance: A Threat Model and Problem StatementR. Barnes, B. Schneier, C. Jennings, T. Hardie, B. Trammell, C. Huitema, D. Borkmann | Informational | August 2015 |
| 7627 | Transport Layer Security (TLS) Session Hash and Extended Master Secret ExtensionK. Bhargavan, Ed., A. Delignat-Lavaud, A. Pironti, A. Langley, M. Ray · obsoleted by RFC 9846 | Proposed Standard | September 2015 |
| 7685 | A Transport Layer Security (TLS) ClientHello Padding ExtensionA. Langley | Proposed Standard | October 2015 |
| 7748 | Elliptic Curves for SecurityA. Langley, M. Hamburg, S. Turner | Informational | January 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7919 | Negotiated Finite Field Diffie-Hellman Ephemeral Parameters for Transport Layer Security (TLS)D. Gillmor | Proposed Standard | August 2016 |
| 7924 | Transport Layer Security (TLS) Cached Information ExtensionS. Santesson, H. Tschofenig | Proposed Standard | July 2016 |
| 8017 | PKCS #1: RSA Cryptography Specifications Version 2.2K. Moriarty, Ed., B. Kaliski, J. Jonsson, A. Rusch | Informational | November 2016 |
| 8032 | Edwards-Curve Digital Signature Algorithm (EdDSA)S. Josefsson, I. Liusvaara | Informational | January 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8305 | Happy Eyeballs Version 2: Better Connectivity Using ConcurrencyD. Schinazi, T. Pauly | Proposed Standard | December 2017 |
| 8422 | Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and EarlierY. Nir, S. Josefsson, M. Pegourie-Gonnard · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8439 | ChaCha20 and Poly1305 for IETF ProtocolsY. Nir, A. Langley | Informational | June 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8447 | IANA Registry Updates for TLS and DTLSJ. Salowey, S. Turner | Proposed Standard | August 2018 |
| 8448 | Example Handshake Traces for TLS 1.3M. Thomson | Informational | January 2019 |
| 8449 | Record Size Limit Extension for TLSM. Thomson | Proposed Standard | August 2018 |
| 8470 | Using Early Data in HTTPM. Thomson, M. Nottingham, W. Tarreau | Proposed Standard | September 2018 |
| 8701 | Applying Generate Random Extensions And Sustain Extensibility (GREASE) to TLS ExtensibilityD. Benjamin | Informational | January 2020 |
| 8773 | TLS 1.3 Extension for Certificate-Based Authentication with an External Pre-Shared KeyR. Housley · obsoleted by RFC 9973 | Experimental | March 2020 |
| 8844 | Unknown Key-Share Attacks on Uses of TLS with the Session Description Protocol (SDP)M. Thomson, E. Rescorla | Proposed Standard | January 2021 |
| 8870 | Encrypted Key Transport for DTLS and Secure RTPC. Jennings, J. Mattsson, D. McGrew, D. Wing, F. Andreasen | Proposed Standard | January 2021 |
| 8879 | TLS Certificate CompressionA. Ghedini, V. Vasiliev | Proposed Standard | December 2020 |
| 8937 | Randomness Improvements for Security ProtocolsC. Cremers, L. Garratt, S. Smyshlyaev, N. Sullivan, C. Wood | Informational | October 2020 |
| 8996 | Deprecating TLS 1.0 and TLS 1.1K. Moriarty, S. Farrell | Best Current Practice | March 2021 |
| 9001 | Using TLS to Secure QUICM. Thomson, Ed., S. Turner, Ed. | Proposed Standard | May 2021 |
| 9112 | HTTP/1.1R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9147 | The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. Modadugu | Proposed Standard | April 2022 |
| 9149 | TLS Ticket RequestsT. Pauly, D. Schinazi, C.A. Wood | Proposed Standard | April 2022 |
| 9162 | Certificate Transparency Version 2.0B. Laurie, E. Messeri, R. Stradling | Experimental | December 2021 |
| 9257 | Guidance for External Pre-Shared Key (PSK) Usage in TLSR. Housley, J. Hoyland, M. Sethi, C. A. Wood | Informational | July 2022 |
| 9258 | Importing External Pre-Shared Keys (PSKs) for TLS 1.3D. Benjamin, C. A. Wood | Proposed Standard | July 2022 |
| 9261 | Exported Authenticators in TLSN. Sullivan | Proposed Standard | July 2022 |
| 9345 | Delegated Credentials for TLS and DTLSR. Barnes, S. Iyengar, N. Sullivan, E. Rescorla | Proposed Standard | July 2023 |
| 9525 | Service Identity in TLSP. Saint-Andre, R. Salz | Proposed Standard | November 2023 |
| 9847 | IANA Registry Updates for TLS and DTLSJ. Salowey, S. Turner | Proposed Standard | December 2025 |
| 9849 | TLS Encrypted Client HelloE. Rescorla, K. Oku, N. Sullivan, C. A. Wood | Proposed Standard | March 2026 |
| 9963 | Legacy RSASSA-PKCS1-v1_5 Code Points for TLS 1.3D. Benjamin, A. Popov | Proposed Standard | April 2026 |