| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 3101 | The OSPF Not-So-Stubby Area (NSSA) OptionP. Murphy | Proposed Standard | January 2003 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 4252 | The Secure Shell (SSH) Authentication ProtocolT. Ylonen, C. Lonvick, Ed. | Proposed Standard | January 2006 |
| 4271 | A Border Gateway Protocol 4 (BGP-4)Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed. | Draft Standard | January 2006 |
| 5130 | A Policy Control Mechanism in IS-IS Using Administrative TagsS. Previdi, M. Shand, Ed., C. Martin | Proposed Standard | February 2008 |
| 5340 | OSPF for IPv6R. Coltun, D. Ferguson, J. Moy, A. Lindem | Proposed Standard | July 2008 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7684 | OSPFv2 Prefix/Link Attribute AdvertisementP. Psenak, H. Gredler, R. Shakir, W. Henderickx, J. Tantsura, A. Lindem | Proposed Standard | November 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8340 | YANG Tree DiagramsM. Bjorklund, L. Berger, Ed. | Best Current Practice | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8342 | Network Management Datastore Architecture (NMDA)M. Bjorklund, J. Schoenwaelder, P. Shafer, K. Watsen, R. Wilton | Proposed Standard | March 2018 |
| 8349 | A YANG Data Model for Routing Management (NMDA Version)L. Lhotka, A. Lindem, Y. Qu | Proposed Standard | March 2018 |
| 8362 | OSPFv3 Link State Advertisement (LSA) ExtensibilityA. Lindem, A. Roy, D. Goethals, V. Reddy Vallem, F. Baker | Proposed Standard | April 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |
| 9129 | YANG Data Model for the OSPF ProtocolD. Yeung, Y. Qu, Z. Zhang, I. Chen, A. Lindem | Proposed Standard | October 2022 |
| 9513 | OSPFv3 Extensions for Segment Routing over IPv6 (SRv6)Z. Li, Z. Hu, K. Talaulikar, Ed., P. Psenak | Proposed Standard | December 2023 |
| 9552 | Distribution of Link-State and Traffic Engineering Information Using BGPK. Talaulikar, Ed. | Proposed Standard | December 2023 |
| 9587 | YANG Data Model for OSPFv3 Extended Link State Advertisements (LSAs)A. Lindem, S. Palani, Y. Qu | Proposed Standard | June 2024 |