| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 2045 | Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message BodiesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2047 | MIME (Multipurpose Internet Mail Extensions) Part Three: Message Header Extensions for Non-ASCII TextK. Moore | Draft Standard | November 1996 |
| 2049 | Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance Criteria and ExamplesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3156 | MIME Security with OpenPGPM. Elkins, D. Del Torto, R. Levien, T. Roessler | Proposed Standard | August 2001 |
| 3851 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 5751 | Proposed Standard | July 2004 |
| 3864 | Registration Procedures for Message Header FieldsG. Klyne, M. Nottingham, J. Mogul | Best Current Practice | September 2004 |
| 4021 | Registration of Mail and MIME Header FieldsG. Klyne, J. Palme | Proposed Standard | March 2005 |
| 5083 | Cryptographic Message Syntax (CMS) Authenticated-Enveloped-Data Content TypeR. Housley | Proposed Standard | November 2007 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5322 | Internet Message FormatP. Resnick, Ed. | Draft Standard | October 2008 |
| 5652 | Cryptographic Message Syntax (CMS)R. Housley | Internet Standard | September 2009 |
| 5751 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message SpecificationB. Ramsdell, S. Turner · obsoleted by RFC 8551 | Proposed Standard | January 2010 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5891 | Internationalized Domain Names in Applications (IDNA): ProtocolJ. Klensin | Proposed Standard | August 2010 |
| 6376 | DomainKeys Identified Mail (DKIM) SignaturesD. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed. | Internet Standard | September 2011 |
| 7489 | Domain-based Message Authentication, Reporting, and Conformance (DMARC)M. Kucherawy, Ed., E. Zwicky, Ed. · obsoleted by RFC 9989, RFC 9990, RFC 9991 | Informational | March 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7929 | DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGPP. Wouters | Experimental | August 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8162 | Using Secure DNS to Associate Certificates with Domain Names for S/MIMEP. Hoffman, J. Schlyter | Experimental | May 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8551 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message SpecificationJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |
| 8617 | The Authenticated Received Chain (ARC) ProtocolK. Andersen, B. Long, Ed., S. Blank, Ed., M. Kucherawy, Ed. | Experimental | July 2019 |
| 9216 | S/MIME Example Keys and CertificatesD. K. Gillmor, Ed. | Informational | April 2022 |
| 9580 | OpenPGPP. Wouters, Ed., D. Huigens, J. Winter, Y. Niibe | Proposed Standard | July 2024 |
| 9787 | Guidance on End-to-End Email SecurityD. K. Gillmor, Ed., A. Melnikov, Ed., B. Hoeneisen, Ed. | Informational | August 2025 |