| 1321 | The MD5 Message-Digest AlgorithmR. Rivest | Informational | April 1992 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2548 | Microsoft Vendor-specific RADIUS AttributesG. Zorn | Informational | March 1999 |
| 2865 | Remote Authentication Dial In User Service (RADIUS)C. Rigney, S. Willens, A. Rubens, W. Simpson | Draft Standard | June 2000 |
| 2866 | RADIUS AccountingC. Rigney | Informational | June 2000 |
| 2868 | RADIUS Attributes for Tunnel Protocol SupportG. Zorn, D. Leifer, A. Rubens, J. Shriver, M. Holdrege, I. Goyret | Informational | June 2000 |
| 3539 | Authentication, Authorization and Accounting (AAA) Transport ProfileB. Aboba, J. Wood | Proposed Standard | June 2003 |
| 3579 | RADIUS (Remote Authentication Dial In User Service) Support For Extensible Authentication Protocol (EAP)B. Aboba, P. Calhoun | Informational | September 2003 |
| 5077 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | January 2008 |
| 5080 | Common Remote Authentication Dial In User Service (RADIUS) Implementation Issues and Suggested FixesD. Nelson, A. DeKok | Proposed Standard | December 2007 |
| 5176 | Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)M. Chiba, G. Dommety, M. Eklund, D. Mitton, B. Aboba | Informational | January 2008 |
| 5281 | Extensible Authentication Protocol Tunneled Transport Layer Security Authenticated Protocol Version 0 (EAP-TTLSv0)P. Funk, S. Blake-Wilson | Informational | August 2008 |
| 5931 | Extensible Authentication Protocol (EAP) Authentication Using Only a PasswordD. Harkins, G. Zorn | Informational | August 2010 |
| 6151 | Updated Security Considerations for the MD5 Message-Digest and the HMAC-MD5 AlgorithmsS. Turner, L. Chen | Informational | March 2011 |
| 6218 | Cisco Vendor-Specific RADIUS Attributes for the Delivery of Keying MaterialG. Zorn, T. Zhang, J. Walker, J. Salowey | Informational | April 2011 |
| 6421 | Crypto-Agility Requirements for Remote Authentication Dial-In User Service (RADIUS)D. Nelson, Ed. | Informational | November 2011 |
| 6613 | RADIUS over TCPA. DeKok | Experimental | May 2012 |
| 6614 | Transport Layer Security (TLS) Encryption for RADIUSS. Winter, M. McCauley, S. Venaas, K. Wierenga | Experimental | May 2012 |
| 6929 | Remote Authentication Dial In User Service (RADIUS) Protocol ExtensionsA. DeKok, A. Lior | Proposed Standard | April 2013 |
| 7301 | Transport Layer Security (TLS) Application-Layer Protocol Negotiation ExtensionS. Friedl, A. Popov, A. Langley, E. Stephan | Proposed Standard | July 2014 |
| 7360 | Datagram Transport Layer Security (DTLS) as a Transport Layer for RADIUSA. DeKok | Experimental | September 2014 |
| 7585 | Dynamic Peer Discovery for RADIUS/TLS and RADIUS/DTLS Based on the Network Access Identifier (NAI)S. Winter, M. McCauley | Experimental | October 2015 |
| 7593 | The eduroam Architecture for Network RoamingK. Wierenga, S. Winter, T. Wolniewicz | Informational | September 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7930 | Larger Packets for RADIUS over TCPS. Hartman | Experimental | August 2016 |
| 8044 | Data Types in RADIUSA. DeKok | Proposed Standard | January 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |