| 1112 | Host extensions for IP multicastingS.E. Deering | Internet Standard | August 1989 |
| 1661 | The Point-to-Point Protocol (PPP)W. Simpson, Ed. | Internet Standard | July 1994 |
| 2153 | PPP Vendor ExtensionsW. Simpson | Informational | May 1997 |
| 2332 | NBMA Next Hop Resolution Protocol (NHRP)J. Luciani, D. Katz, D. Piscitello, B. Cole, N. Doraswamy | Proposed Standard | April 1998 |
| 2464 | Transmission of IPv6 Packets over Ethernet NetworksM. Crawford | Proposed Standard | December 1998 |
| 2606 | Reserved Top Level DNS NamesD. Eastlake 3rd, A. Panitz | Best Current Practice | June 1999 |
| 2784 | Generic Routing Encapsulation (GRE)D. Farinacci, T. Li, S. Hanks, D. Meyer, P. Traina | Proposed Standard | March 2000 |
| 3092 | Etymology of "Foo"D. Eastlake 3rd, C. Manros, E. Raymond | Informational | 1 April 2001 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4760 | Multiprotocol Extensions for BGP-4T. Bates, R. Chandra, D. Katz, Y. Rekhter | Draft Standard | January 2007 |
| 5214 | Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)F. Templin, T. Gleeson, D. Thaler | Informational | March 2008 |
| 5332 | MPLS Multicast EncapsulationsT. Eckert, E. Rosen, Ed., R. Aggarwal, Y. Rekhter | Proposed Standard | August 2008 |
| 5342 | IANA Considerations and IETF Protocol Usage for IEEE 802 ParametersD. Eastlake 3rd · obsoleted by RFC 7042 | Best Current Practice | September 2008 |
| 5737 | IPv4 Address Blocks Reserved for DocumentationJ. Arkko, M. Cotton, L. Vegoda | Informational | January 2010 |
| 5798 | Virtual Router Redundancy Protocol (VRRP) Version 3 for IPv4 and IPv6S. Nadas, Ed. · obsoleted by RFC 9568 | Proposed Standard | March 2010 |
| 6034 | Unicast-Prefix-Based IPv4 Multicast AddressesD. Thaler | Proposed Standard | October 2010 |
| 6328 | IANA Considerations for Network Layer Protocol IdentifiersD. Eastlake 3rd | Best Current Practice | July 2011 |
| 6895 | Domain Name System (DNS) IANA ConsiderationsD. Eastlake 3rd | Best Current Practice | April 2013 |
| 7042 | IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 ParametersD. Eastlake 3rd, J. Abley · obsoleted by RFC 9542 | Best Current Practice | October 2013 |
| 7043 | Resource Records for EUI-48 and EUI-64 Addresses in the DNSJ. Abley | Informational | October 2013 |
| 7319 | IANA Considerations for Connectivity Fault Management (CFM) Code PointsD. Eastlake 3rd | Best Current Practice | July 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7961 | Transparent Interconnection of Lots of Links (TRILL): Interface Addresses APPsub-TLVD. Eastlake 3rd, L. Yizhou | Proposed Standard | August 2016 |
| 8064 | Recommendation on Stable IPv6 Interface IdentifiersF. Gont, A. Cooper, D. Thaler, W. Liu | Proposed Standard | February 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8415 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)T. Mrugalski, M. Siodelski, B. Volz, A. Yourtchenko, M. Richardson, S. Jiang, T. Lemon, T. Winters · obsoleted by RFC 9915 | Proposed Standard | November 2018 |
| 8520 | Manufacturer Usage Description SpecificationE. Lear, R. Droms, D. Romascanu | Proposed Standard | March 2019 |
| 8926 | Geneve: Generic Network Virtualization EncapsulationJ. Gross, Ed., I. Ganga, Ed., T. Sridhar, Ed. | Proposed Standard | November 2020 |
| 8947 | Link-Layer Address Assignment Mechanism for DHCPv6B. Volz, T. Mrugalski, CJ. Bernardos | Proposed Standard | December 2020 |
| 8948 | Structured Local Address Plan (SLAP) Quadrant Selection Option for DHCPv6CJ. Bernardos, A. Mourad | Proposed Standard | December 2020 |
| 8949 | Concise Binary Object Representation (CBOR)C. Bormann, P. Hoffman | Internet Standard | December 2020 |