| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 1996 | A Mechanism for Prompt Notification of Zone Changes (DNS NOTIFY)P. Vixie | Proposed Standard | August 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)P. Vixie, Ed., S. Thomson, Y. Rekhter, J. Bound | Proposed Standard | April 1997 |
| 3007 | Secure Domain Name System (DNS) Dynamic UpdateB. Wellington | Proposed Standard | November 2000 |
| 3587 | IPv6 Global Unicast Address FormatR. Hinden, S. Deering, E. Nordmark | Informational | August 2003 |
| 3927 | Dynamic Configuration of IPv4 Link-Local AddressesS. Cheshire, B. Aboba, E. Guttman | Proposed Standard | May 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4192 | Procedures for Renumbering an IPv6 Network without a Flag DayF. Baker, E. Lear, R. Droms | Informational | September 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 5011 | Automated Updates of DNS Security (DNSSEC) Trust AnchorsM. StJohns | Internet Standard | September 2007 |
| 5155 | DNS Security (DNSSEC) Hashed Authenticated Denial of ExistenceB. Laurie, G. Sisson, R. Arends, D. Blacka | Proposed Standard | March 2008 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6749 | The OAuth 2.0 Authorization FrameworkD. Hardt, Ed. | Proposed Standard | October 2012 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 7010 | IPv6 Site Renumbering Gap AnalysisB. Liu, S. Jiang, B. Carpenter, S. Venaas, W. George | Informational | September 2013 |
| 7084 | Basic Requirements for IPv6 Customer Edge RoutersH. Singh, W. Beebee, C. Donley, B. Stark | Informational | November 2013 |
| 7344 | Automating DNSSEC Delegation Trust MaintenanceW. Kumari, O. Gudmundsson, G. Barwood | Proposed Standard | September 2014 |
| 7368 | IPv6 Home Networking Architecture PrinciplesT. Chown, Ed., J. Arkko, A. Brandt, O. Troan, J. Weil | Informational | October 2014 |
| 7404 | Using Only Link-Local Addressing inside an IPv6 NetworkM. Behringer, E. Vyncke | Informational | November 2014 |
| 7707 | Network Reconnaissance in IPv6 NetworksF. Gont, T. Chown | Informational | March 2016 |
| 7788 | Home Networking Control ProtocolM. Stenberg, S. Barth, P. Pfister | Proposed Standard | April 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7858 | Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. Hoffman | Proposed Standard | May 2016 |
| 8094 | DNS over Datagram Transport Layer Security (DTLS)T. Reddy, D. Wing, P. Patil | Experimental | February 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8375 | Special-Use Domain 'home.arpa.'P. Pfister, T. Lemon | Proposed Standard | May 2018 |
| 8415 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)T. Mrugalski, M. Siodelski, B. Volz, A. Yourtchenko, M. Richardson, S. Jiang, T. Lemon, T. Winters · obsoleted by RFC 9915 | Proposed Standard | November 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8484 | DNS Queries over HTTPS (DoH)P. Hoffman, P. McManus | Proposed Standard | October 2018 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8501 | Reverse DNS in IPv6 for Internet Service ProvidersL. Howard | Informational | November 2018 |
| 8555 | Automatic Certificate Management Environment (ACME)R. Barnes, J. Hoffman-Andrews, D. McCarney, J. Kasten | Proposed Standard | March 2019 |
| 8610 | Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data StructuresH. Birkholz, C. Vigano, C. Bormann | Proposed Standard | June 2019 |
| 8672 | TLS Server Identity Pinning with TicketsY. Sheffer, D. Migault | Experimental | October 2019 |
| 8978 | Reaction of IPv6 Stateless Address Autoconfiguration (SLAAC) to Flash-Renumbering EventsF. Gont, J. Žorž, R. Patterson | Informational | March 2021 |
| 8981 | Temporary Address Extensions for Stateless Address Autoconfiguration in IPv6F. Gont, S. Krishnan, T. Narten, R. Draves | Proposed Standard | February 2021 |
| 9103 | DNS Zone Transfer over TLSW. Toorop, S. Dickinson, S. Sahib, P. Aras, A. Mankin | Proposed Standard | August 2021 |
| 9250 | DNS over Dedicated QUIC ConnectionsC. Huitema, S. Dickinson, A. Mankin | Proposed Standard | May 2022 |
| 9276 | Guidance for NSEC3 Parameter SettingsW. Hardaker, V. Dukhovni | Best Current Practice | August 2022 |
| 9525 | Service Identity in TLSP. Saint-Andre, R. Salz | Proposed Standard | November 2023 |
| 9527 | DHCPv6 Options for the Homenet Naming AuthorityD. Migault, R. Weber, T. Mrugalski | Proposed Standard | January 2024 |