| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2986 | PKCS #10: Certification Request Syntax Specification Version 1.7M. Nystrom, B. Kaliski | Informational | November 2000 |
| 3647 | Internet X.509 Public Key Infrastructure Certificate Policy and Certification Practices FrameworkS. Chokhani, W. Ford, R. Sabett, C. Merrill, S. Wu | Informational | November 2003 |
| 4210 | Internet X.509 Public Key Infrastructure Certificate Management Protocol (CMP)C. Adams, S. Farrell, T. Kause, T. Mononen · obsoleted by RFC 9810 | Proposed Standard | September 2005 |
| 4211 | Internet X.509 Public Key Infrastructure Certificate Request Message Format (CRMF)J. Schaad | Proposed Standard | September 2005 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5652 | Cryptographic Message Syntax (CMS)R. Housley | Internet Standard | September 2009 |
| 5753 | Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS)S. Turner, D. Brown | Informational | January 2010 |
| 5958 | Asymmetric Key PackagesS. Turner | Proposed Standard | August 2010 |
| 6712 | Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate Management Protocol (CMP)T. Kause, M. Peylo · obsoleted by RFC 9811 | Proposed Standard | September 2012 |
| 7030 | Enrollment over Secure TransportM. Pritikin, Ed., P. Yee, Ed., D. Harkins, Ed. | Proposed Standard | October 2013 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8366 | A Voucher Artifact for Bootstrapping ProtocolsK. Watsen, M. Richardson, M. Pritikin, T. Eckert | Proposed Standard | May 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8551 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message SpecificationJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |
| 8572 | Secure Zero Touch Provisioning (SZTP)K. Watsen, I. Farrer, M. Abrahamsson | Proposed Standard | April 2019 |
| 8615 | Well-Known Uniform Resource Identifiers (URIs)M. Nottingham | Proposed Standard | May 2019 |
| 8649 | Hash Of Root Key Certificate ExtensionR. Housley | Informational | August 2019 |
| 8933 | Update to the Cryptographic Message Syntax (CMS) for Algorithm Identifier ProtectionR. Housley | Proposed Standard | October 2020 |
| 8995 | Bootstrapping Remote Secure Key Infrastructure (BRSKI)M. Pritikin, M. Richardson, T. Eckert, M. Behringer, K. Watsen | Proposed Standard | May 2021 |
| 9045 | Algorithm Requirements Update to the Internet X.509 Public Key Infrastructure Certificate Request Message Format (CRMF)R. Housley | Proposed Standard | June 2021 |
| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9325 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, P. Saint-Andre, T. Fossati | Best Current Practice | November 2022 |
| 9480 | Certificate Management Protocol (CMP) UpdatesH. Brockhaus, D. von Oheimb, J. Gray · obsoleted by RFC 9810, RFC 9811 | Proposed Standard | November 2023 |
| 9481 | Certificate Management Protocol (CMP) AlgorithmsH. Brockhaus, H. Aschauer, M. Ounsworth, J. Gray | Proposed Standard | November 2023 |
| 9482 | Constrained Application Protocol (CoAP) Transfer for the Certificate Management ProtocolM. Sahni, Ed., S. Tripathi, Ed. | Proposed Standard | November 2023 |