| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 6585 | Additional HTTP Status CodesM. Nottingham, R. Fielding | Proposed Standard | April 2012 |
| 7239 | Forwarded HTTP ExtensionA. Petersson, M. Nilsson | Proposed Standard | June 2014 |
| 7468 | Textual Encodings of PKIX, PKCS, and CMS StructuresS. Josefsson, S. Leonard | Proposed Standard | April 2015 |
| 7541 | HPACK: Header Compression for HTTP/2R. Peon, H. Ruellan | Proposed Standard | May 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8705 | OAuth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access TokensB. Campbell, J. Bradley, N. Sakimura, T. Lodderstedt | Proposed Standard | February 2020 |
| 8941 | Structured Field Values for HTTPM. Nottingham, P-H. Kamp · obsoleted by RFC 9651 | Proposed Standard | February 2021 |
| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9112 | HTTP/1.1R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9113 | HTTP/2M. Thomson, Ed., C. Benfield, Ed. | Proposed Standard | June 2022 |
| 9114 | HTTP/3M. Bishop, Ed. | Proposed Standard | June 2022 |
| 9204 | QPACK: Field Compression for HTTP/3C. Krasic, M. Bishop, A. Frindell, Ed. | Proposed Standard | June 2022 |