rfc.dk

Cited in: RFC 9429

61 RFCs mentioned in the text of RFC 9429 (JavaScript Session Establishment Protocol (JSEP))

RFCTitleStatusDate
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
3261SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. SchoolerProposed StandardJuly 2002
3264An Offer/Answer Model with Session Description Protocol (SDP)J. Rosenberg, H. SchulzrinneProposed StandardJuly 2002
3389Real-time Transport Protocol (RTP) Payload for Comfort Noise (CN)R. ZopfProposed StandardOctober 2002
3552Guidelines for Writing RFC Text on Security ConsiderationsE. Rescorla, B. KorverBest Current PracticeJuly 2003
3556Session Description Protocol (SDP) Bandwidth Modifiers for RTP Control Protocol (RTCP) BandwidthS. CasnerProposed StandardJuly 2003
3605Real Time Control Protocol (RTCP) attribute in Session Description Protocol (SDP)C. HuitemaProposed StandardOctober 2003
3711The Secure Real-time Transport Protocol (SRTP)M. Baugher, D. McGrew, M. Naslund, E. Carrara, K. NorrmanProposed StandardMarch 2004
3890A Transport Independent Bandwidth Modifier for the Session Description Protocol (SDP)M. WesterlundProposed StandardSeptember 2004
3960Early Media and Ringing Tone Generation in the Session Initiation Protocol (SIP)G. Camarillo, H. SchulzrinneInformationalDecember 2004
4145TCP-Based Media Transport in the Session Description Protocol (SDP)D. Yon, G. CamarilloProposed StandardSeptember 2005
4566SDP: Session Description ProtocolM. Handley, V. Jacobson, C. Perkins · obsoleted by RFC 8866Proposed StandardJuly 2006
4568Session Description Protocol (SDP) Security Descriptions for Media StreamsF. Andreasen, M. Baugher, D. WingProposed StandardJuly 2006
4585Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF)J. Ott, S. Wenger, N. Sato, C. Burmeister, J. ReyProposed StandardJuly 2006
4588RTP Retransmission Payload FormatJ. Rey, D. Leon, A. Miyazaki, V. Varsa, R. HakenbergProposed StandardJuly 2006
4733RTP Payload for DTMF Digits, Telephony Tones, and Telephony SignalsH. Schulzrinne, T. TaylorProposed StandardDecember 2006
5124Extended Secure RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/SAVPF)J. Ott, E. CarraraProposed StandardFebruary 2008
5245Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer ProtocolsJ. Rosenberg · obsoleted by RFC 8445, RFC 8839Proposed StandardApril 2010
5285A General Mechanism for RTP Header ExtensionsD. Singer, H. Desineni · obsoleted by RFC 8285Proposed StandardJuly 2008
5506Support for Reduced-Size Real-Time Transport Control Protocol (RTCP): Opportunities and ConsequencesI. Johansson, M. WesterlundProposed StandardApril 2009
5576Source-Specific Media Attributes in the Session Description Protocol (SDP)J. Lennox, J. Ott, T. SchierlProposed StandardJune 2009
5761Multiplexing RTP Data and Control Packets on a Single PortC. Perkins, M. WesterlundProposed StandardApril 2010
5763Framework for Establishing a Secure Real-time Transport Protocol (SRTP) Security Context Using Datagram Transport Layer Security (DTLS)J. Fischl, H. Tschofenig, E. RescorlaProposed StandardMay 2010
5764Datagram Transport Layer Security (DTLS) Extension to Establish Keys for the Secure Real-time Transport Protocol (SRTP)D. McGrew, E. RescorlaProposed StandardMay 2010
5888The Session Description Protocol (SDP) Grouping FrameworkG. Camarillo, H. SchulzrinneProposed StandardJune 2010
6120Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-AndreProposed StandardMarch 2011
6236Negotiation of Generic Image Attributes in the Session Description Protocol (SDP)I. Johansson, K. JungProposed StandardMay 2011
6347Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147Proposed StandardJanuary 2012
6464A Real-time Transport Protocol (RTP) Header Extension for Client-to-Mixer Audio Level IndicationJ. Lennox, Ed., E. Ivov, E. MaroccoProposed StandardDecember 2011
6716Definition of the Opus Audio CodecJM. Valin, K. Vos, T. TerriberryProposed StandardSeptember 2012
6904Encryption of Header Extensions in the Secure Real-time Transport Protocol (SRTP)J. LennoxProposed StandardApril 2013
7160Support for Multiple Clock Rates in an RTP SessionM. Petit-Huguenin, G. Zorn, Ed.Proposed StandardApril 2014
7587RTP Payload Format for the Opus Speech and Audio CodecJ. Spittka, K. Vos, JM. ValinProposed StandardJune 2015
7742WebRTC Video Processing and Codec RequirementsA.B. RoachProposed StandardMarch 2016
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7850Registering Values of the SDP 'proto' Field for Transporting RTP Media over TCP under Various RTP ProfilesS. NandakumarProposed StandardApril 2016
7874WebRTC Audio Codec and Processing RequirementsJM. Valin, C. BranProposed StandardMay 2016
8108Sending Multiple RTP Streams in a Single RTP SessionJ. Lennox, M. Westerlund, Q. Wu, C. PerkinsProposed StandardMarch 2017
8122Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)J. Lennox, C. HolmbergProposed StandardMarch 2017
8174Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. LeibaBest Current PracticeMay 2017
8445Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) TraversalA. Keranen, C. Holmberg, J. RosenbergProposed StandardJuly 2018
8826Security Considerations for WebRTCE. RescorlaProposed StandardJanuary 2021
8827WebRTC Security ArchitectureE. RescorlaProposed StandardJanuary 2021
8828WebRTC IP Address Handling RequirementsJ. Uberti, G. ShiehProposed StandardJanuary 2021
8829JavaScript Session Establishment Protocol (JSEP)J. Uberti, C. Jennings, E. Rescorla, Ed. · obsoleted by RFC 9429Proposed StandardJanuary 2021
8830WebRTC MediaStream Identification in the Session Description ProtocolH. AlvestrandProposed StandardJanuary 2021
8834Media Transport and Use of RTP in WebRTCC. Perkins, M. Westerlund, J. OttProposed StandardJanuary 2021
8838Trickle ICE: Incremental Provisioning of Candidates for the Interactive Connectivity Establishment (ICE) ProtocolE. Ivov, J. Uberti, P. Saint-AndreProposed StandardJanuary 2021
8839Session Description Protocol (SDP) Offer/Answer Procedures for Interactive Connectivity Establishment (ICE)M. Petit-Huguenin, S. Nandakumar, C. Holmberg, A. Keränen, R. ShpountProposed StandardJanuary 2021
8840A Session Initiation Protocol (SIP) Usage for Incremental Provisioning of Candidates for the Interactive Connectivity Establishment (Trickle ICE)E. Ivov, T. Stach, E. Marocco, C. HolmbergProposed StandardJanuary 2021
8841Session Description Protocol (SDP) Offer/Answer Procedures for Stream Control Transmission Protocol (SCTP) over Datagram Transport Layer Security (DTLS) TransportC. Holmberg, R. Shpount, S. Loreto, G. CamarilloProposed StandardJanuary 2021
8842Session Description Protocol (SDP) Offer/Answer Considerations for Datagram Transport Layer Security (DTLS) and Transport Layer Security (TLS)C. Holmberg, R. ShpountProposed StandardJanuary 2021
8843Negotiating Media Multiplexing Using the Session Description Protocol (SDP)C. Holmberg, H. Alvestrand, C. Jennings · obsoleted by RFC 9143Proposed StandardJanuary 2021
8851RTP Payload Format RestrictionsA.B. Roach, Ed.Proposed StandardJanuary 2021
8852RTP Stream Identifier Source Description (SDES)A.B. Roach, S. Nandakumar, P. ThatcherProposed StandardJanuary 2021
8853Using Simulcast in Session Description Protocol (SDP) and RTP SessionsB. Burman, M. Westerlund, S. Nandakumar, M. ZanatyProposed StandardJanuary 2021
8854WebRTC Forward Error Correction RequirementsJ. UbertiProposed StandardJanuary 2021
8858Indicating Exclusive Support of RTP and RTP Control Protocol (RTCP) Multiplexing Using the Session Description Protocol (SDP)C. HolmbergProposed StandardJanuary 2021
8859A Framework for Session Description Protocol (SDP) Attributes When MultiplexingS. NandakumarProposed StandardJanuary 2021
9143Negotiating Media Multiplexing Using the Session Description Protocol (SDP)C. Holmberg, H. Alvestrand, C. JenningsProposed StandardFebruary 2022
9147The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. ModaduguProposed StandardApril 2022