| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1321 | The MD5 Message-Digest AlgorithmR. Rivest | Informational | April 1992 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4953 | Defending TCP Against Spoofing AttacksJ. Touch | Informational | July 2007 |
| 4963 | IPv4 Reassembly Errors at High Data RatesJ. Heffner, M. Mathis, B. Chandler | Informational | July 2007 |
| 5722 | Handling of Overlapping IPv6 FragmentsS. Krishnan | Proposed Standard | December 2009 |
| 5905 | Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. Kasch | Proposed Standard | June 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 5927 | ICMP Attacks against TCPF. Gont | Informational | July 2010 |
| 6056 | Recommendations for Transport-Protocol Port RandomizationM. Larsen, F. Gont | Best Current Practice | January 2011 |
| 6151 | Updated Security Considerations for the MD5 Message-Digest and the HMAC-MD5 AlgorithmsS. Turner, L. Chen | Informational | March 2011 |
| 6191 | Reducing the TIME-WAIT State Using TCP TimestampsF. Gont | Best Current Practice | April 2011 |
| 6194 | Security Considerations for the SHA-0 and SHA-1 Message-Digest AlgorithmsT. Polk, L. Chen, S. Turner, P. Hoffman | Informational | March 2011 |
| 6274 | Security Assessment of the Internet Protocol Version 4F. Gont | Informational | July 2011 |
| 6437 | IPv6 Flow Label SpecificationS. Amante, B. Carpenter, S. Jiang, J. Rajahalme | Proposed Standard | November 2011 |
| 6528 | Defending against Sequence Number AttacksF. Gont, S. Bellovin · obsoleted by RFC 9293 | Proposed Standard | February 2012 |
| 6973 | Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. Smith | Informational | July 2013 |
| 6980 | Security Implications of IPv6 Fragmentation with IPv6 Neighbor DiscoveryF. Gont | Proposed Standard | August 2013 |
| 7098 | Using the IPv6 Flow Label for Load Balancing in Server FarmsB. Carpenter, S. Jiang, W. Tarreau | Informational | January 2014 |
| 7217 | A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC)F. Gont | Proposed Standard | April 2014 |
| 7258 | Pervasive Monitoring Is an AttackS. Farrell, H. Tschofenig | Best Current Practice | May 2014 |
| 7323 | TCP Extensions for High PerformanceD. Borman, B. Braden, V. Jacobson, R. Scheffenegger, Ed. | Proposed Standard | September 2014 |
| 7707 | Network Reconnaissance in IPv6 NetworksF. Gont, T. Chown | Informational | March 2016 |
| 7721 | Security and Privacy Considerations for IPv6 Address Generation MechanismsA. Cooper, F. Gont, D. Thaler | Informational | March 2016 |
| 7739 | Security Implications of Predictable Fragment Identification ValuesF. Gont | Informational | February 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8064 | Recommendation on Stable IPv6 Interface IdentifiersF. Gont, A. Cooper, D. Thaler, W. Liu | Proposed Standard | February 2017 |
| 8200 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden | Internet Standard | July 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8937 | Randomness Improvements for Security ProtocolsC. Cremers, L. Garratt, S. Smyshlyaev, N. Sullivan, C. Wood | Informational | October 2020 |
| 8981 | Temporary Address Extensions for Stateless Address Autoconfiguration in IPv6F. Gont, S. Krishnan, T. Narten, R. Draves | Proposed Standard | February 2021 |
| 9293 | Transmission Control Protocol (TCP)W. Eddy, Ed. | Internet Standard | August 2022 |
| 9414 | Unfortunate History of Transient Numeric IdentifiersF. Gont, I. Arce | Informational | July 2023 |
| 9416 | Security Considerations for Transient Numeric Identifiers Employed in Network ProtocolsF. Gont, I. Arce | Best Current Practice | July 2023 |