rfc.dk

Cited in: RFC 9364

37 RFCs mentioned in the text of RFC 9364 (DNS Security Extensions (DNSSEC))

RFCTitleStatusDate
2065Domain Name System Security ExtensionsD. Eastlake 3rd, C. Kaufman · obsoleted by RFC 2535Proposed StandardJanuary 1997
2535Domain Name System Security ExtensionsD. Eastlake 3rd · obsoleted by RFC 4033, RFC 4034, RFC 4035Proposed StandardMarch 1999
2536DSA KEYs and SIGs in the Domain Name System (DNS)D. Eastlake 3rdProposed StandardMarch 1999
3110RSA/SHA-1 SIGs and RSA KEYs in the Domain Name System (DNS)D. Eastlake 3rdProposed StandardMay 2001
4033DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. RoseProposed StandardMarch 2005
4034Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. RoseProposed StandardMarch 2005
4035Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. RoseProposed StandardMarch 2005
4470Minimally Covering NSEC Records and DNSSEC On-line SigningS. Weiler, J. IhrenProposed StandardApril 2006
4509Use of SHA-256 in DNSSEC Delegation Signer (DS) Resource Records (RRs)W. HardakerProposed StandardMay 2006
5011Automated Updates of DNS Security (DNSSEC) Trust AnchorsM. StJohnsInternet StandardSeptember 2007
5155DNS Security (DNSSEC) Hashed Authenticated Denial of ExistenceB. Laurie, G. Sisson, R. Arends, D. BlackaProposed StandardMarch 2008
5702Use of SHA-2 Algorithms with RSA in DNSKEY and RRSIG Resource Records for DNSSECJ. JansenProposed StandardOctober 2009
6014Cryptographic Algorithm Identifier Allocation for DNSSECP. HoffmanProposed StandardNovember 2010
6605Elliptic Curve Digital Signature Algorithm (DSA) for DNSSECP. Hoffman, W.C.A. WijngaardsProposed StandardApril 2012
6698The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. SchlyterProposed StandardAugust 2012
6725DNS Security (DNSSEC) DNSKEY Algorithm IANA Registry UpdatesS. RoseProposed StandardAugust 2012
6781DNSSEC Operational Practices, Version 2O. Kolkman, W. Mekking, R. GiebenInformationalDecember 2012
6840Clarifications and Implementation Notes for DNS Security (DNSSEC)S. Weiler, Ed., D. Blacka, Ed.Proposed StandardFebruary 2013
6975Signaling Cryptographic Algorithm Understanding in DNS Security Extensions (DNSSEC)S. Crocker, S. RoseProposed StandardJuly 2013
7129Authenticated Denial of Existence in the DNSR. Gieben, W. MekkingInformationalFebruary 2014
7344Automating DNSSEC Delegation Trust MaintenanceW. Kumari, O. Gudmundsson, G. BarwoodProposed StandardSeptember 2014
7583DNSSEC Key Rollover Timing ConsiderationsS. Morris, J. Ihren, J. Dickinson, W. MekkingInformationalOctober 2015
7646Definition and Use of DNSSEC Negative Trust AnchorsP. Ebersman, W. Kumari, C. Griffiths, J. Livingood, R. WeberInformationalSeptember 2015
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7958DNSSEC Trust Anchor Publication for the Root ZoneJ. Abley, J. Schlyter, G. Bailey, P. Hoffman · obsoleted by RFC 9718InformationalAugust 2016
8027DNSSEC Roadblock AvoidanceW. Hardaker, O. Gudmundsson, S. KrishnaswamyBest Current PracticeNovember 2016
8078Managing DS Records from the Parent via CDS/CDNSKEYO. Gudmundsson, P. WoutersProposed StandardMarch 2017
8080Edwards-Curve Digital Security Algorithm (EdDSA) for DNSSECO. Sury, R. EdmondsProposed StandardFebruary 2017
8145Signaling Trust Anchor Knowledge in DNS Security Extensions (DNSSEC)D. Wessels, W. Kumari, P. HoffmanProposed StandardApril 2017
8198Aggressive Use of DNSSEC-Validated CacheK. Fujiwara, A. Kato, W. KumariProposed StandardJuly 2017
8499DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499Best Current PracticeJanuary 2019
8509A Root Key Trust Anchor Sentinel for DNSSECG. Huston, J. Damas, W. KumariProposed StandardDecember 2018
8624Algorithm Implementation Requirements and Usage Guidance for DNSSECP. Wouters, O. Sury · obsoleted by RFC 9904Proposed StandardJune 2019
8901Multi-Signer DNSSEC ModelsS. Huque, P. Aras, J. Dickinson, J. Vcelak, D. BlackaInformationalSeptember 2020
9077NSEC and NSEC3: TTLs and Aggressive UseP. van DijkProposed StandardJuly 2021
9157Revised IANA Considerations for DNSSECP. HoffmanProposed StandardDecember 2021
9276Guidance for NSEC3 Parameter SettingsW. Hardaker, V. DukhovniBest Current PracticeAugust 2022