{
  "number": 9350,
  "title": "IGP Flexible Algorithm",
  "authors": [
    "P. Psenak, Ed.",
    "S. Hegde",
    "C. Filsfils",
    "K. Talaulikar",
    "A. Gulko"
  ],
  "published": "2023-02",
  "status": "Proposed Standard",
  "stream": "IETF",
  "area": "rtg",
  "working_group": "lsr",
  "pages": 42,
  "formats": [
    "HTML",
    "TXT",
    "PDF",
    "XML"
  ],
  "abstract": "IGP protocols historically compute the best paths over the network based on the IGP metric assigned to the links. Many network deployments use RSVP-TE or Segment Routing - Traffic Engineering (SR-TE) to steer traffic over a path that is computed using different metrics or constraints than the shortest IGP path. This document specifies a solution that allows IGPs themselves to compute constraint-based paths over the network. This document also specifies a way of using Segment Routing (SR) Prefix-SIDs and SRv6 locators to steer packets along the constraint-based paths.",
  "draft": "draft-ietf-lsr-flex-algo-26",
  "doi": "10.17487/RFC9350",
  "errata_url": "https://www.rfc-editor.org/errata/rfc9350",
  "updated_by": [
    "RFC9843",
    "RFC9917"
  ],
  "urls": {
    "html": "https://rfc.dk/rfc9350/",
    "text": "https://rfc.dk/rfc9350.txt",
    "rfc_editor": "https://www.rfc-editor.org/rfc/rfc9350",
    "datatracker": "https://datatracker.ietf.org/doc/rfc9350/"
  },
  "text_modified": "2023-02-22T19:12:20.071376039Z"
}
