| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3246 | An Expedited Forwarding PHB (Per-Hop Behavior)B. Davie, A. Charny, J.C.R. Bennet, K. Benson, J.Y. Le Boudec, W. Courtney, S. Davari, V. Firoiu, D. Stiliadis | Proposed Standard | March 2002 |
| 3540 | Robust Explicit Congestion Notification (ECN) Signaling with NoncesN. Spring, D. Wetherall, D. Ely | Historic | June 2003 |
| 3649 | HighSpeed TCP for Large Congestion WindowsS. Floyd | Experimental | December 2003 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4341 | Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 2: TCP-like Congestion ControlS. Floyd, E. Kohler | Proposed Standard | March 2006 |
| 4342 | Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 3: TCP-Friendly Rate Control (TFRC)S. Floyd, E. Kohler, J. Padhye | Proposed Standard | April 2006 |
| 4774 | Specifying Alternate Semantics for the Explicit Congestion Notification (ECN) FieldS. Floyd | Best Current Practice | November 2006 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 5033 | Specifying New Congestion Control AlgorithmsS. Floyd, M. Allman · obsoleted by RFC 9743 | Best Current Practice | August 2007 |
| 5129 | Explicit Congestion Marking in MPLSB. Davie, B. Briscoe, J. Tay | Proposed Standard | January 2008 |
| 5348 | TCP Friendly Rate Control (TFRC): Protocol SpecificationS. Floyd, M. Handley, J. Padhye, J. Widmer | Proposed Standard | September 2008 |
| 5562 | Adding Explicit Congestion Notification (ECN) Capability to TCP's SYN/ACK PacketsA. Kuzmanovic, A. Mondal, S. Floyd, K. Ramakrishnan | Experimental | June 2009 |
| 5622 | Profile for Datagram Congestion Control Protocol (DCCP) Congestion ID 4: TCP-Friendly Rate Control for Small Packets (TFRC-SP)S. Floyd, E. Kohler | Experimental | August 2009 |
| 5681 | TCP Congestion ControlM. Allman, V. Paxson, E. Blanton | Draft Standard | September 2009 |
| 5706 | Guidelines for Considering Operations and Management of New Protocols and Protocol ExtensionsD. Harrington | Informational | November 2009 |
| 5865 | A Differentiated Services Code Point (DSCP) for Capacity-Admitted TrafficF. Baker, J. Polk, M. Dolly | Proposed Standard | May 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 6040 | Tunnelling of Explicit Congestion NotificationB. Briscoe | Proposed Standard | November 2010 |
| 6077 | Open Research Issues in Internet Congestion ControlD. Papadimitriou, Ed., M. Welzl, M. Scharf, B. Briscoe | Informational | February 2011 |
| 6660 | Encoding Three Pre-Congestion Notification (PCN) States in the IP Header Using a Single Diffserv Codepoint (DSCP)B. Briscoe, T. Moncaster, M. Menth | Proposed Standard | July 2012 |
| 6675 | A Conservative Loss Recovery Algorithm Based on Selective Acknowledgment (SACK) for TCPE. Blanton, M. Allman, L. Wang, I. Jarvinen, M. Kojo, Y. Nishida | Proposed Standard | August 2012 |
| 6679 | Explicit Congestion Notification (ECN) for RTP over UDPM. Westerlund, I. Johansson, C. Perkins, P. O'Hanlon, K. Carlberg | Proposed Standard | August 2012 |
| 7560 | Problem Statement and Requirements for Increased Accuracy in Explicit Congestion Notification (ECN) FeedbackM. Kuehlewind, Ed., R. Scheffenegger, B. Briscoe | Informational | August 2015 |
| 7567 | IETF Recommendations Regarding Active Queue ManagementF. Baker, Ed., G. Fairhurst, Ed. | Best Current Practice | July 2015 |
| 7713 | Congestion Exposure (ConEx) Concepts, Abstract Mechanism, and RequirementsM. Mathis, B. Briscoe | Informational | December 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8033 | Proportional Integral Controller Enhanced (PIE): A Lightweight Control Scheme to Address the Bufferbloat ProblemR. Pan, P. Natarajan, F. Baker, G. White | Experimental | February 2017 |
| 8083 | Multimedia Congestion Control: Circuit Breakers for Unicast RTP SessionsC. Perkins, V. Singh | Proposed Standard | March 2017 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8257 | Data Center TCP (DCTCP): TCP Congestion Control for Data CentersS. Bensley, D. Thaler, P. Balasubramanian, L. Eggert, G. Judd | Informational | October 2017 |
| 8290 | The Flow Queue CoDel Packet Scheduler and Active Queue Management AlgorithmT. Hoeiland-Joergensen, P. McKenney, D. Taht, J. Gettys, E. Dumazet | Experimental | January 2018 |
| 8298 | Self-Clocked Rate Adaptation for MultimediaI. Johansson, Z. Sarker | Experimental | December 2017 |
| 8311 | Relaxing Restrictions on Explicit Congestion Notification (ECN) ExperimentationD. Black | Proposed Standard | January 2018 |
| 8312 | CUBIC for Fast Long-Distance NetworksI. Rhee, L. Xu, S. Ha, A. Zimmermann, L. Eggert, R. Scheffenegger · obsoleted by RFC 9438 | Informational | February 2018 |
| 8511 | TCP Alternative Backoff with ECN (ABE)N. Khademi, M. Welzl, G. Armitage, G. Fairhurst | Experimental | December 2018 |
| 8888 | RTP Control Protocol (RTCP) Feedback for Congestion ControlZ. Sarker, C. Perkins, V. Singh, M. Ramalho | Proposed Standard | January 2021 |
| 8985 | The RACK-TLP Loss Detection Algorithm for TCPY. Cheng, N. Cardwell, N. Dukkipati, P. Jha | Proposed Standard | February 2021 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |
| 9001 | Using TLS to Secure QUICM. Thomson, Ed., S. Turner, Ed. | Proposed Standard | May 2021 |
| 9147 | The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. Modadugu | Proposed Standard | April 2022 |
| 9330 | Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: ArchitectureB. Briscoe, Ed., K. De Schepper, M. Bagnulo, G. White | Informational | January 2023 |
| 9332 | Dual-Queue Coupled Active Queue Management (AQM) for Low Latency, Low Loss, and Scalable Throughput (L4S)K. De Schepper, B. Briscoe, Ed., G. White | Experimental | January 2023 |