| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2817 | Upgrading to TLS Within HTTP/1.1R. Khare, S. Lawrence | Proposed Standard | May 2000 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3948 | UDP Encapsulation of IPsec ESP PacketsA. Huttunen, B. Swander, V. Volpe, L. DiBurro, M. Stenberg | Proposed Standard | January 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4555 | IKEv2 Mobility and Multihoming Protocol (MOBIKE)P. Eronen | Proposed Standard | June 2006 |
| 4621 | Design of the IKEv2 Mobility and Multihoming (MOBIKE) ProtocolT. Kivinen, H. Tschofenig | Informational | August 2006 |
| 4953 | Defending TCP Against Spoofing AttacksJ. Touch | Informational | July 2007 |
| 4987 | TCP SYN Flooding Attacks and Common MitigationsW. Eddy | Informational | August 2007 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5685 | Redirect Mechanism for the Internet Key Exchange Protocol Version 2 (IKEv2)V. Devarapalli, K. Weniger | Proposed Standard | November 2009 |
| 5723 | Internet Key Exchange Protocol Version 2 (IKEv2) Session ResumptionY. Sheffer, H. Tschofenig | Proposed Standard | January 2010 |
| 5961 | Improving TCP's Robustness to Blind In-Window AttacksA. Ramaiah, R. Stewart, M. Dalal | Proposed Standard | August 2010 |
| 6040 | Tunnelling of Explicit Congestion NotificationB. Briscoe | Proposed Standard | November 2010 |
| 6311 | Protocol Support for High Availability of IKEv2/IPsecR. Singh, Ed., G. Kalyani, Y. Nir, Y. Sheffer, D. Zhang | Proposed Standard | July 2011 |
| 6520 | Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat ExtensionR. Seggelmann, M. Tuexen, M. Williams | Proposed Standard | February 2012 |
| 6528 | Defending against Sequence Number AttacksF. Gont, S. Bellovin · obsoleted by RFC 9293 | Proposed Standard | February 2012 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |
| 7383 | Internet Key Exchange Protocol Version 2 (IKEv2) Message FragmentationV. Smyslov | Proposed Standard | November 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8019 | Protecting Internet Key Exchange Protocol Version 2 (IKEv2) Implementations from Distributed Denial-of-Service AttacksY. Nir, V. Smyslov | Proposed Standard | November 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8229 | TCP Encapsulation of IKE and IPsec PacketsT. Pauly, S. Touati, R. Mantha · obsoleted by RFC 9329 | Proposed Standard | August 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 9293 | Transmission Control Protocol (TCP)W. Eddy, Ed. | Internet Standard | August 2022 |
| 9325 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, P. Saint-Andre, T. Fossati | Best Current Practice | November 2022 |