| 1195 | Use of OSI IS-IS for routing in TCP/IP and dual environmentsR. Callon | Proposed Standard | December 1990 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 3209 | RSVP-TE: Extensions to RSVP for LSP TunnelsD. Awduche, L. Berger, D. Gan, T. Li, V. Srinivasan, G. Swallow | Proposed Standard | December 2001 |
| 4202 | Routing Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 5286 | Basic Specification for IP Fast Reroute: Loop-Free AlternatesA. Atlas, Ed., A. Zinin, Ed. | Proposed Standard | September 2008 |
| 5340 | OSPF for IPv6R. Coltun, D. Ferguson, J. Moy, A. Lindem | Proposed Standard | July 2008 |
| 7752 | North-Bound Distribution of Link-State and Traffic Engineering (TE) Information Using BGPH. Gredler, Ed., J. Medved, S. Previdi, A. Farrel, S. Ray · obsoleted by RFC 9552 | Proposed Standard | March 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8402 | Segment Routing ArchitectureC. Filsfils, Ed., S. Previdi, Ed., L. Ginsberg, B. Decraene, S. Litkowski, R. Shakir | Proposed Standard | July 2018 |
| 8571 | BGP - Link State (BGP-LS) Advertisement of IGP Traffic Engineering Performance Metric ExtensionsL. Ginsberg, Ed., S. Previdi, Q. Wu, J. Tantsura, C. Filsfils | Proposed Standard | March 2019 |
| 8919 | IS-IS Application-Specific Link AttributesL. Ginsberg, P. Psenak, S. Previdi, W. Henderickx, J. Drake · obsoleted by RFC 9479 | Proposed Standard | October 2020 |
| 8920 | OSPF Application-Specific Link AttributesP. Psenak, Ed., L. Ginsberg, W. Henderickx, J. Tantsura, J. Drake · obsoleted by RFC 9492 | Proposed Standard | October 2020 |
| 9104 | Distribution of Traffic Engineering Extended Administrative Groups Using the Border Gateway Protocol - Link State (BGP-LS)J. Tantsura, Z. Wang, Q. Wu, K. Talaulikar | Proposed Standard | August 2021 |