| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 896 | Congestion Control in IP/TCP InternetworksJ. Nagle · obsoleted by RFC 7805 | Historic | January 1984 |
| 1011 | Official Internet protocolsJ.K. Reynolds, J. Postel | Unknown | May 1987 |
| 1038 | Draft revised IP security optionM. St. Johns · obsoleted by RFC 1108 | Unknown | January 1988 |
| 1108 | U.S. Department of Defense Security Options for the Internet ProtocolS. Kent | Historic | November 1991 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1349 | Type of Service in the Internet Protocol SuiteP. Almquist · obsoleted by RFC 2474 | Proposed Standard | July 1992 |
| 1644 | T/TCP -- TCP Extensions for Transactions Functional SpecificationR. Braden · obsoleted by RFC 6247 | Historic | July 1994 |
| 2018 | TCP Selective Acknowledgment OptionsM. Mathis, J. Mahdavi, S. Floyd, A. Romanow | Proposed Standard | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2525 | Known TCP Implementation ProblemsV. Paxson, M. Allman, S. Dawson, W. Fenner, J. Griner, I. Heavens, K. Lahey, J. Semke, B. Volz | Informational | March 1999 |
| 2581 | TCP Congestion ControlM. Allman, V. Paxson, W. Stevens · obsoleted by RFC 5681 | Proposed Standard | April 1999 |
| 2675 | IPv6 JumbogramsD. Borman, S. Deering, R. Hinden | Proposed Standard | August 1999 |
| 2873 | TCP Processing of the IPv4 Precedence FieldX. Xiao, A. Hannan, V. Paxson, E. Crabbe · obsoleted by RFC 9293 | Proposed Standard | June 2000 |
| 2883 | An Extension to the Selective Acknowledgement (SACK) Option for TCPS. Floyd, J. Mahdavi, M. Mathis, M. Podolsky | Proposed Standard | July 2000 |
| 2914 | Congestion Control PrinciplesS. Floyd | Best Current Practice | September 2000 |
| 2923 | TCP Problems with Path MTU DiscoveryK. Lahey | Informational | September 2000 |
| 2988 | Computing TCP's Retransmission TimerV. Paxson, M. Allman · obsoleted by RFC 6298 | Proposed Standard | November 2000 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3449 | TCP Performance Implications of Network Path AsymmetryH. Balakrishnan, V. Padmanabhan, G. Fairhurst, M. Sooriyabandara | Best Current Practice | December 2002 |
| 3465 | TCP Congestion Control with Appropriate Byte Counting (ABC)M. Allman | Experimental | February 2003 |
| 3540 | Robust Explicit Congestion Notification (ECN) Signaling with NoncesN. Spring, D. Wetherall, D. Ely | Historic | June 2003 |
| 4727 | Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP HeadersB. Fenner | Proposed Standard | November 2006 |
| 4821 | Packetization Layer Path MTU DiscoveryM. Mathis, J. Heffner | Proposed Standard | March 2007 |
| 4953 | Defending TCP Against Spoofing AttacksJ. Touch | Informational | July 2007 |
| 4987 | TCP SYN Flooding Attacks and Common MitigationsW. Eddy | Informational | August 2007 |
| 5033 | Specifying New Congestion Control AlgorithmsS. Floyd, M. Allman · obsoleted by RFC 9743 | Best Current Practice | August 2007 |
| 5044 | Marker PDU Aligned Framing for TCP SpecificationP. Culley, U. Elzur, R. Recio, S. Bailey, J. Carrier | Proposed Standard | October 2007 |
| 5461 | TCP's Reaction to Soft ErrorsF. Gont | Informational | February 2009 |
| 5570 | Common Architecture Label IPv6 Security Option (CALIPSO)M. StJohns, R. Atkinson, G. Thomas | Informational | July 2009 |
| 5681 | TCP Congestion ControlM. Allman, V. Paxson, E. Blanton | Draft Standard | September 2009 |
| 5795 | The RObust Header Compression (ROHC) FrameworkK. Sandlund, G. Pelletier, L-E. Jonsson | Proposed Standard | March 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 5927 | ICMP Attacks against TCPF. Gont | Informational | July 2010 |
| 5961 | Improving TCP's Robustness to Blind In-Window AttacksA. Ramaiah, R. Stewart, M. Dalal | Proposed Standard | August 2010 |
| 6093 | On the Implementation of the TCP Urgent MechanismF. Gont, A. Yourtchenko · obsoleted by RFC 9293 | Proposed Standard | January 2011 |
| 6191 | Reducing the TIME-WAIT State Using TCP TimestampsF. Gont | Best Current Practice | April 2011 |
| 6298 | Computing TCP's Retransmission TimerV. Paxson, M. Allman, J. Chu, M. Sargent | Proposed Standard | June 2011 |
| 6429 | TCP Sender Clarification for Persist ConditionM. Bashyam, M. Jethanandani, A. Ramaiah · obsoleted by RFC 9293 | Informational | December 2011 |
| 6528 | Defending against Sequence Number AttacksF. Gont, S. Bellovin · obsoleted by RFC 9293 | Proposed Standard | February 2012 |
| 6633 | Deprecation of ICMP Source Quench MessagesF. Gont | Proposed Standard | May 2012 |
| 6691 | TCP Options and Maximum Segment Size (MSS)D. Borman · obsoleted by RFC 9293 | Informational | July 2012 |
| 6864 | Updated Specification of the IPv4 ID FieldJ. Touch | Proposed Standard | February 2013 |
| 6994 | Shared Use of Experimental TCP OptionsJ. Touch | Proposed Standard | August 2013 |
| 7094 | Architectural Considerations of IP AnycastD. McPherson, D. Oran, D. Thaler, E. Osterweil | Informational | January 2014 |
| 7323 | TCP Extensions for High PerformanceD. Borman, B. Braden, V. Jacobson, R. Scheffenegger, Ed. | Proposed Standard | September 2014 |
| 7413 | TCP Fast OpenY. Cheng, J. Chu, S. Radhakrishnan, A. Jain | Experimental | December 2014 |
| 7414 | A Roadmap for Transmission Control Protocol (TCP) Specification DocumentsM. Duke, R. Braden, W. Eddy, E. Blanton, A. Zimmermann | Informational | February 2015 |
| 7657 | Differentiated Services (Diffserv) and Real-Time CommunicationD. Black, Ed., P. Jones | Informational | November 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8087 | The Benefits of Using Explicit Congestion Notification (ECN)G. Fairhurst, M. Welzl | Informational | March 2017 |
| 8095 | Services Provided by IETF Transport Protocols and Congestion Control MechanismsG. Fairhurst, Ed., B. Trammell, Ed., M. Kuehlewind, Ed. | Informational | March 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8200 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden | Internet Standard | July 2017 |
| 8201 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul, R. Hinden, Ed. | Internet Standard | July 2017 |
| 8303 | On the Usage of Transport Features Provided by IETF Transport ProtocolsM. Welzl, M. Tuexen, N. Khademi | Informational | February 2018 |
| 8311 | Relaxing Restrictions on Explicit Congestion Notification (ECN) ExperimentationD. Black | Proposed Standard | January 2018 |
| 8504 | IPv6 Node RequirementsT. Chown, J. Loughney, T. Winters | Best Current Practice | January 2019 |
| 8546 | The Wire Image of a Network ProtocolB. Trammell, M. Kuehlewind | Informational | April 2019 |
| 8548 | Cryptographic Protection of TCP Streams (tcpcrypt)A. Bittau, D. Giffin, M. Handley, D. Mazieres, Q. Slack, E. Smith | Experimental | May 2019 |
| 8558 | Transport Protocol Path SignalsT. Hardie, Ed. | Informational | April 2019 |
| 8684 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure, C. Paasch | Proposed Standard | March 2020 |
| 8961 | Requirements for Time-Based Loss DetectionM. Allman | Best Current Practice | November 2020 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |
| 9065 | Considerations around Transport Header Confidentiality, Network Operations, and the Evolution of Internet Transport ProtocolsG. Fairhurst, C. Perkins | Informational | July 2021 |
| 9170 | Long-Term Viability of Protocol Extension MechanismsM. Thomson, T. Pauly | Informational | December 2021 |