| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2392 | Content-ID and Message-ID Uniform Resource LocatorsE. Levinson | Proposed Standard | August 1998 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3263 | Session Initiation Protocol (SIP): Locating SIP ServersJ. Rosenberg, H. Schulzrinne | Proposed Standard | July 2002 |
| 3264 | An Offer/Answer Model with Session Description Protocol (SDP)J. Rosenberg, H. Schulzrinne | Proposed Standard | July 2002 |
| 3311 | The Session Initiation Protocol (SIP) UPDATE MethodJ. Rosenberg | Proposed Standard | October 2002 |
| 3323 | A Privacy Mechanism for the Session Initiation Protocol (SIP)J. Peterson | Proposed Standard | December 2002 |
| 3326 | The Reason Header Field for the Session Initiation Protocol (SIP)H. Schulzrinne, D. Oran, G. Camarillo | Proposed Standard | December 2002 |
| 3327 | Session Initiation Protocol (SIP) Extension Header Field for Registering Non-Adjacent ContactsD. Willis, B. Hoeneisen | Proposed Standard | December 2002 |
| 3458 | Message Context for Internet MailE. Burger, E. Candell, C. Eliot, G. Klyne | Proposed Standard | January 2003 |
| 3515 | The Session Initiation Protocol (SIP) Refer MethodR. Sparks | Proposed Standard | April 2003 |
| 3605 | Real Time Control Protocol (RTCP) attribute in Session Description Protocol (SDP)C. Huitema | Proposed Standard | October 2003 |
| 3665 | Session Initiation Protocol (SIP) Basic Call Flow ExamplesA. Johnston, S. Donovan, R. Sparks, C. Cunningham, K. Summers | Best Current Practice | January 2004 |
| 3840 | Indicating User Agent Capabilities in the Session Initiation Protocol (SIP)J. Rosenberg, H. Schulzrinne, P. Kyzivat | Proposed Standard | August 2004 |
| 3842 | A Message Summary and Message Waiting Indication Event Package for the Session Initiation Protocol (SIP)R. Mahy | Proposed Standard | August 2004 |
| 3891 | The Session Initiation Protocol (SIP) "Replaces" HeaderR. Mahy, B. Biggs, R. Dean | Proposed Standard | September 2004 |
| 3892 | The Session Initiation Protocol (SIP) Referred-By MechanismR. Sparks | Proposed Standard | September 2004 |
| 3960 | Early Media and Ringing Tone Generation in the Session Initiation Protocol (SIP)G. Camarillo, H. Schulzrinne | Informational | December 2004 |
| 3966 | The tel URI for Telephone NumbersH. Schulzrinne | Proposed Standard | December 2004 |
| 4102 | Registration of the text/red MIME Sub-TypeP. Jones | Proposed Standard | June 2005 |
| 4103 | RTP Payload for Text ConversationG. Hellstrom, P. Jones | Proposed Standard | June 2005 |
| 4488 | Suppression of Session Initiation Protocol (SIP) REFER Method Implicit SubscriptionO. Levin | Proposed Standard | May 2006 |
| 4585 | Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF)J. Ott, S. Wenger, N. Sato, C. Burmeister, J. Rey | Proposed Standard | July 2006 |
| 4733 | RTP Payload for DTMF Digits, Telephony Tones, and Telephony SignalsH. Schulzrinne, T. Taylor | Proposed Standard | December 2006 |
| 4967 | Dial String Parameter for the Session Initiation Protocol Uniform Resource IdentifierB. Rosen | Proposed Standard | July 2007 |
| 5104 | Codec Control Messages in the RTP Audio-Visual Profile with Feedback (AVPF)S. Wenger, U. Chandra, M. Westerlund, B. Burman | Proposed Standard | February 2008 |
| 5168 | XML Schema for Media ControlO. Levin, R. Even, P. Hagendorf | Informational | March 2008 |
| 5393 | Addressing an Amplification Vulnerability in Session Initiation Protocol (SIP) Forking ProxiesR. Sparks, Ed., S. Lawrence, A. Hawrylyshen, B. Campen | Proposed Standard | December 2008 |
| 5626 | Managing Client-Initiated Connections in the Session Initiation Protocol (SIP)C. Jennings, Ed., R. Mahy, Ed., F. Audet, Ed. | Proposed Standard | October 2009 |
| 5658 | Addressing Record-Route Issues in the Session Initiation Protocol (SIP)T. Froment, C. Lebel, B. Bonnaerens | Proposed Standard | October 2009 |
| 5954 | Essential Correction for IPv6 ABNF and URI Comparison in RFC 3261V. Gurbani, Ed., B. Carpenter, Ed., B. Tate, Ed. | Proposed Standard | August 2010 |
| 6263 | Application Mechanism for Keeping Alive the NAT Mappings Associated with RTP / RTP Control Protocol (RTCP) FlowsX. Marjou, A. Sollaud | Proposed Standard | June 2011 |
| 6351 | xCard: vCard XML RepresentationS. Perreault | Proposed Standard | August 2011 |
| 6352 | CardDAV: vCard Extensions to Web Distributed Authoring and Versioning (WebDAV)C. Daboo | Proposed Standard | August 2011 |
| 6442 | Location Conveyance for the Session Initiation ProtocolJ. Polk, B. Rosen, J. Peterson | Proposed Standard | December 2011 |
| 6665 | SIP-Specific Event NotificationA.B. Roach | Proposed Standard | July 2012 |
| 6764 | Locating Services for Calendaring Extensions to WebDAV (CalDAV) and vCard Extensions to WebDAV (CardDAV)C. Daboo | Proposed Standard | February 2013 |
| 6881 | Best Current Practice for Communications Services in Support of Emergency CallingB. Rosen, J. Polk | Best Current Practice | March 2013 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7647 | Clarifications for the Use of REFER with RFC 6665R. Sparks, A.B. Roach | Proposed Standard | September 2015 |
| 7742 | WebRTC Video Processing and Codec RequirementsA.B. Roach | Proposed Standard | March 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7852 | Additional Data Related to an Emergency CallR. Gellens, B. Rosen, H. Tschofenig, R. Marshall, J. Winterbottom | Proposed Standard | July 2016 |
| 7874 | WebRTC Audio Codec and Processing RequirementsJM. Valin, C. Bran | Proposed Standard | May 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8445 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) TraversalA. Keranen, C. Holmberg, J. Rosenberg | Proposed Standard | July 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8599 | Push Notification with the Session Initiation Protocol (SIP)C. Holmberg, M. Arnold | Proposed Standard | May 2019 |
| 8760 | The Session Initiation Protocol (SIP) Digest Access Authentication SchemeR. Shekh-Yusef | Proposed Standard | March 2020 |
| 8825 | Overview: Real-Time Protocols for Browser-Based ApplicationsH. Alvestrand | Proposed Standard | January 2021 |
| 8827 | WebRTC Security ArchitectureE. Rescorla | Proposed Standard | January 2021 |
| 8829 | JavaScript Session Establishment Protocol (JSEP)J. Uberti, C. Jennings, E. Rescorla, Ed. · obsoleted by RFC 9429 | Proposed Standard | January 2021 |
| 8834 | Media Transport and Use of RTP in WebRTCC. Perkins, M. Westerlund, J. Ott | Proposed Standard | January 2021 |
| 8835 | Transports for WebRTCH. Alvestrand | Proposed Standard | January 2021 |
| 8839 | Session Description Protocol (SDP) Offer/Answer Procedures for Interactive Connectivity Establishment (ICE)M. Petit-Huguenin, S. Nandakumar, C. Holmberg, A. Keränen, R. Shpount | Proposed Standard | January 2021 |
| 8865 | T.140 Real-Time Text Conversation over WebRTC Data ChannelsC. Holmberg, G. Hellström | Proposed Standard | January 2021 |
| 8866 | SDP: Session Description ProtocolA. Begen, P. Kyzivat, C. Perkins, M. Handley | Proposed Standard | January 2021 |
| 9071 | RTP-Mixer Formatting of Multiparty Real-Time TextG. Hellström | Proposed Standard | July 2021 |
| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9112 | HTTP/1.1R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |