| 1157 | Simple Network Management Protocol (SNMP)J.D. Case, M. Fedor, M.L. Schoffstall, J. Davin | Historic | May 1990 |
| 2578 | Structure of Management Information Version 2 (SMIv2)K. McCloghrie, Ed., D. Perkins, Ed., J. Schoenwaelder, Ed. | Internet Standard | April 1999 |
| 2981 | Event MIBR. Kavasseri, Ed. | Proposed Standard | October 2000 |
| 3176 | InMon Corporation's sFlow: A Method for Monitoring Traffic in Switched and Routed NetworksP. Phaal, S. Panchen, N. McKee | Informational | September 2001 |
| 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksD. Harrington, R. Presuhn, B. Wijnen | Internet Standard | December 2002 |
| 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)R. Presuhn, Ed. | Internet Standard | December 2002 |
| 3877 | Alarm Management Information Base (MIB)S. Chisholm, D. Romascanu | Proposed Standard | September 2004 |
| 3954 | Cisco Systems NetFlow Services Export Version 9B. Claise, Ed. | Informational | October 2004 |
| 4656 | A One-way Active Measurement Protocol (OWAMP)S. Shalunov, B. Teitelbaum, A. Karp, J. Boote, M. Zekauskas | Proposed Standard | September 2006 |
| 5085 | Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for PseudowiresT. Nadeau, Ed., C. Pignataro, Ed. | Proposed Standard | December 2007 |
| 5357 | A Two-Way Active Measurement Protocol (TWAMP)K. Hedayat, R. Krzanowski, A. Morton, K. Yum, J. Babiarz | Proposed Standard | October 2008 |
| 5424 | The Syslog ProtocolR. Gerhards | Proposed Standard | March 2009 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6812 | Cisco Service-Level Assurance ProtocolM. Chiba, A. Clemm, S. Medley, J. Salowey, S. Thombare, E. Yedavalli | Informational | January 2013 |
| 7011 | Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow InformationB. Claise, Ed., B. Trammell, Ed., P. Aitken | Internet Standard | September 2013 |
| 7258 | Pervasive Monitoring Is an AttackS. Farrell, H. Tschofenig | Best Current Practice | May 2014 |
| 7276 | An Overview of Operations, Administration, and Maintenance (OAM) ToolsT. Mizrahi, N. Sprecher, E. Bellagamba, Y. Weingarten | Informational | June 2014 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7575 | Autonomic Networking: Definitions and Design GoalsM. Behringer, M. Pritikin, S. Bjarnason, A. Clemm, B. Carpenter, S. Jiang, L. Ciavaglia | Informational | June 2015 |
| 7799 | Active and Passive Metrics and Methods (with Hybrid Types In-Between)A. Morton | Informational | May 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7854 | BGP Monitoring Protocol (BMP)J. Scudder, Ed., R. Fernando, S. Stuart | Proposed Standard | June 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8084 | Network Transport Circuit BreakersG. Fairhurst | Best Current Practice | March 2017 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 8259 | The JavaScript Object Notation (JSON) Data Interchange FormatT. Bray, Ed. | Internet Standard | December 2017 |
| 8321 | Alternate-Marking Method for Passive and Hybrid Performance MonitoringG. Fioccola, Ed., A. Capello, M. Cociglio, L. Castaldelli, M. Chen, L. Zheng, G. Mirsky, T. Mizrahi · obsoleted by RFC 9341 | Experimental | January 2018 |
| 8639 | Subscription to YANG NotificationsE. Voit, A. Clemm, A. Gonzalez Prieto, E. Nilsen-Nygaard, A. Tripathy | Proposed Standard | September 2019 |
| 8641 | Subscription to YANG Notifications for Datastore UpdatesA. Clemm, E. Voit | Proposed Standard | September 2019 |
| 8671 | Support for Adj-RIB-Out in the BGP Monitoring Protocol (BMP)T. Evens, S. Bayraktar, P. Lucente, P. Mi, S. Zhuang | Proposed Standard | November 2019 |
| 8762 | Simple Two-Way Active Measurement ProtocolG. Mirsky, G. Jun, H. Nydell, R. Foote | Proposed Standard | March 2020 |
| 8889 | Multipoint Alternate-Marking Method for Passive and Hybrid Performance MonitoringG. Fioccola, Ed., M. Cociglio, A. Sapio, R. Sisto · obsoleted by RFC 9342 | Experimental | August 2020 |
| 8924 | Service Function Chaining (SFC) Operations, Administration, and Maintenance (OAM) FrameworkS. Aldrin, C. Pignataro, Ed., N. Kumar, Ed., R. Krishnan, A. Ghanwani | Informational | October 2020 |
| 9069 | Support for Local RIB in the BGP Monitoring Protocol (BMP)T. Evens, S. Bayraktar, M. Bhardwaj, P. Lucente | Proposed Standard | February 2022 |
| 9197 | Data Fields for In Situ Operations, Administration, and Maintenance (IOAM)F. Brockners, Ed., S. Bhandari, Ed., T. Mizrahi, Ed. | Proposed Standard | May 2022 |