| 1321 | The MD5 Message-Digest AlgorithmR. Rivest | Informational | April 1992 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2315 | PKCS #7: Cryptographic Message Syntax Version 1.5B. Kaliski | Informational | March 1998 |
| 3075 | XML-Signature Syntax and ProcessingD. Eastlake 3rd, J. Reagle, D. Solo · obsoleted by RFC 3275 | Proposed Standard | March 2001 |
| 3076 | Canonical XML Version 1.0J. Boyer | Informational | March 2001 |
| 3092 | Etymology of "Foo"D. Eastlake 3rd, C. Manros, E. Raymond | Informational | 1 April 2001 |
| 3275 | (Extensible Markup Language) XML-Signature Syntax and ProcessingD. Eastlake 3rd, J. Reagle, D. Solo | Draft Standard | March 2002 |
| 3394 | Advanced Encryption Standard (AES) Key Wrap AlgorithmJ. Schaad, R. Housley | Informational | October 2002 |
| 3713 | A Description of the Camellia Encryption AlgorithmM. Matsui, J. Nakajima, S. Moriai | Informational | April 2004 |
| 3741 | Exclusive XML Canonicalization, Version 1.0J. Boyer, D. Eastlake 3rd, J. Reagle | Informational | March 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4010 | Use of the SEED Encryption Algorithm in Cryptographic Message Syntax (CMS)J. Park, S. Lee, J. Kim, J. Lee | Proposed Standard | February 2005 |
| 4050 | Using the Elliptic Curve Signature Algorithm (ECDSA) for XML Digital SignaturesS. Blake-Wilson, G. Karlinger, T. Kobayashi, Y. Wang | Informational | April 2005 |
| 4051 | Additional XML Security Uniform Resource Identifiers (URIs)D. Eastlake 3rd · obsoleted by RFC 6931 | Proposed Standard | April 2005 |
| 4055 | Additional Algorithms and Identifiers for RSA Cryptography for use in the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileJ. Schaad, B. Kaliski, R. Housley | Proposed Standard | June 2005 |
| 4269 | The SEED Encryption AlgorithmH.J. Lee, S.J. Lee, J.H. Yoon, D.H. Cheon, J.I. Lee | Informational | December 2005 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 5869 | HMAC-based Extract-and-Expand Key Derivation Function (HKDF)H. Krawczyk, P. Eronen | Informational | May 2010 |
| 6090 | Fundamental Elliptic Curve Cryptography AlgorithmsD. McGrew, K. Igoe, M. Salter | Informational | February 2011 |
| 6151 | Updated Security Considerations for the MD5 Message-Digest and the HMAC-MD5 AlgorithmsS. Turner, L. Chen | Informational | March 2011 |
| 6194 | Security Considerations for the SHA-0 and SHA-1 Message-Digest AlgorithmsT. Polk, L. Chen, S. Turner, P. Hoffman | Informational | March 2011 |
| 6234 | US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)D. Eastlake 3rd, T. Hansen | Informational | May 2011 |
| 6931 | Additional XML Security Uniform Resource Identifiers (URIs)D. Eastlake 3rd · obsoleted by RFC 9231 | Proposed Standard | April 2013 |
| 7465 | Prohibiting RC4 Cipher SuitesA. Popov | Proposed Standard | February 2015 |
| 7696 | Guidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement AlgorithmsR. Housley | Best Current Practice | November 2015 |
| 7748 | Elliptic Curves for SecurityA. Langley, M. Hamburg, S. Turner | Informational | January 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8017 | PKCS #1: RSA Cryptography Specifications Version 2.2K. Moriarty, Ed., B. Kaliski, J. Jonsson, A. Rusch | Informational | November 2016 |
| 8032 | Edwards-Curve Digital Signature Algorithm (EdDSA)S. Josefsson, I. Liusvaara | Informational | January 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8391 | XMSS: eXtended Merkle Signature SchemeA. Huelsing, D. Butin, S. Gazdag, J. Rijneveld, A. Mohaisen | Informational | May 2018 |
| 8439 | ChaCha20 and Poly1305 for IETF ProtocolsY. Nir, A. Langley | Informational | June 2018 |