rfc.dk

Cited in: RFC 9202

25 RFCs mentioned in the text of RFC 9202 (Datagram Transport Layer Security (DTLS) Profile for Authentication and Authorization for Constrained Environments (ACE))

RFCTitleStatusDate
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
4279Pre-Shared Key Ciphersuites for Transport Layer Security (TLS)P. Eronen, Ed., H. Tschofenig, Ed.Proposed StandardDecember 2005
5869HMAC-based Extract-and-Expand Key Derivation Function (HKDF)H. Krawczyk, P. EronenInformationalMay 2010
6347Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147Proposed StandardJanuary 2012
6655AES-CCM Cipher Suites for Transport Layer Security (TLS)D. McGrew, D. BaileyProposed StandardJuly 2012
6749The OAuth 2.0 Authorization FrameworkD. Hardt, Ed.Proposed StandardOctober 2012
7250Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Wouters, Ed., H. Tschofenig, Ed., J. Gilmore, S. Weiler, T. KivinenProposed StandardJune 2014
7251AES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLSD. McGrew, D. Bailey, M. Campagna, R. DugalInformationalJune 2014
7252The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. BormannProposed StandardJune 2014
7662OAuth 2.0 Token IntrospectionJ. Richer, Ed.Proposed StandardOctober 2015
7748Elliptic Curves for SecurityA. Langley, M. Hamburg, S. TurnerInformationalJanuary 2016
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7925Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. FossatiProposed StandardJuly 2016
8032Edwards-Curve Digital Signature Algorithm (EdDSA)S. Josefsson, I. LiusvaaraInformationalJanuary 2017
8152CBOR Object Signing and Encryption (COSE)J. Schaad · obsoleted by RFC 9052, RFC 9053Proposed StandardJuly 2017
8174Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. LeibaBest Current PracticeMay 2017
8392CBOR Web Token (CWT)M. Jones, E. Wahlstroem, S. Erdtman, H. TschofenigProposed StandardMay 2018
8422Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and EarlierY. Nir, S. Josefsson, M. Pegourie-Gonnard · obsoleted by RFC 9846Proposed StandardAugust 2018
8446The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846Proposed StandardAugust 2018
8610Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data StructuresH. Birkholz, C. Vigano, C. BormannProposed StandardJune 2019
8747Proof-of-Possession Key Semantics for CBOR Web Tokens (CWTs)M. Jones, L. Seitz, G. Selander, S. Erdtman, H. TschofenigProposed StandardMarch 2020
8949Concise Binary Object Representation (CBOR)C. Bormann, P. HoffmanInternet StandardDecember 2020
9147The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. ModaduguProposed StandardApril 2022
9200Authentication and Authorization for Constrained Environments Using the OAuth 2.0 Framework (ACE-OAuth)L. Seitz, G. Selander, E. Wahlstroem, S. Erdtman, H. TschofenigProposed StandardAugust 2022
9201Additional OAuth Parameters for Authentication and Authorization for Constrained Environments (ACE)L. SeitzProposed StandardAugust 2022