| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2865 | Remote Authentication Dial In User Service (RADIUS)C. Rigney, S. Willens, A. Rubens, W. Simpson | Draft Standard | June 2000 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 4851 | The Flexible Authentication via Secure Tunneling Extensible Authentication Protocol Method (EAP-FAST)N. Cam-Winget, D. McGrew, J. Salowey, H. Zhou | Informational | May 2007 |
| 5216 | The EAP-TLS Authentication ProtocolD. Simon, B. Aboba, R. Hurst | Proposed Standard | March 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5281 | Extensible Authentication Protocol Tunneled Transport Layer Security Authenticated Protocol Version 0 (EAP-TTLSv0)P. Funk, S. Blake-Wilson | Informational | August 2008 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6090 | Fundamental Elliptic Curve Cryptography AlgorithmsD. McGrew, K. Igoe, M. Salter | Informational | February 2011 |
| 7170 | Tunnel Extensible Authentication Protocol (TEAP) Version 1H. Zhou, N. Cam-Winget, J. Salowey, S. Hanna · obsoleted by RFC 9930 | Proposed Standard | May 2014 |
| 7250 | Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Wouters, Ed., H. Tschofenig, Ed., J. Gilmore, S. Weiler, T. Kivinen | Proposed Standard | June 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7924 | Transport Layer Security (TLS) Cached Information ExtensionS. Santesson, H. Tschofenig | Proposed Standard | July 2016 |
| 8032 | Edwards-Curve Digital Signature Algorithm (EdDSA)S. Josefsson, I. Liusvaara | Informational | January 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8392 | CBOR Web Token (CWT)M. Jones, E. Wahlstroem, S. Erdtman, H. Tschofenig | Proposed Standard | May 2018 |
| 8422 | Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and EarlierY. Nir, S. Josefsson, M. Pegourie-Gonnard · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8879 | TLS Certificate CompressionA. Ghedini, V. Vasiliev | Proposed Standard | December 2020 |
| 8949 | Concise Binary Object Representation (CBOR)C. Bormann, P. Hoffman | Internet Standard | December 2020 |
| 9190 | EAP-TLS 1.3: Using the Extensible Authentication Protocol with TLS 1.3J. Preuß Mattsson, M. Sethi | Proposed Standard | February 2022 |