| 1661 | The Point-to-Point Protocol (PPP)W. Simpson, Ed. | Internet Standard | July 1994 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2560 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPM. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams · obsoleted by RFC 6960 | Proposed Standard | June 1999 |
| 2865 | Remote Authentication Dial In User Service (RADIUS)C. Rigney, S. Willens, A. Rubens, W. Simpson | Draft Standard | June 2000 |
| 3280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileR. Housley, W. Polk, W. Ford, D. Solo · obsoleted by RFC 5280 | Proposed Standard | May 2002 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 4137 | State Machines for Extensible Authentication Protocol (EAP) Peer and AuthenticatorJ. Vollbrecht, P. Eronen, N. Petroni, Y. Ohba | Informational | August 2005 |
| 4282 | The Network Access IdentifierB. Aboba, M. Beadles, J. Arkko, P. Eronen · obsoleted by RFC 7542 | Proposed Standard | December 2005 |
| 4346 | The Transport Layer Security (TLS) Protocol Version 1.1T. Dierks, E. Rescorla · obsoleted by RFC 5246 | Historic | April 2006 |
| 4851 | The Flexible Authentication via Secure Tunneling Extensible Authentication Protocol Method (EAP-FAST)N. Cam-Winget, D. McGrew, J. Salowey, H. Zhou | Informational | May 2007 |
| 5077 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | January 2008 |
| 5191 | Protocol for Carrying Authentication for Network Access (PANA)D. Forsberg, Y. Ohba, Ed., B. Patil, H. Tschofenig, A. Yegin | Proposed Standard | May 2008 |
| 5216 | The EAP-TLS Authentication ProtocolD. Simon, B. Aboba, R. Hurst | Proposed Standard | March 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5247 | Extensible Authentication Protocol (EAP) Key Management FrameworkB. Aboba, D. Simon, P. Eronen | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5281 | Extensible Authentication Protocol Tunneled Transport Layer Security Authenticated Protocol Version 0 (EAP-TTLSv0)P. Funk, S. Blake-Wilson | Informational | August 2008 |
| 5705 | Keying Material Exporters for Transport Layer Security (TLS)E. Rescorla | Proposed Standard | March 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6960 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPS. Santesson, M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams | Proposed Standard | June 2013 |
| 7170 | Tunnel Extensible Authentication Protocol (TEAP) Version 1H. Zhou, N. Cam-Winget, J. Salowey, S. Hanna · obsoleted by RFC 9930 | Proposed Standard | May 2014 |
| 7406 | Extensions to the Emergency Services Architecture for Dealing With Unauthenticated and Unauthorized DevicesH. Schulzrinne, S. McCann, G. Bajko, H. Tschofenig, D. Kroeselberg | Informational | December 2014 |
| 7457 | Summarizing Known Attacks on Transport Layer Security (TLS) and Datagram TLS (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre | Informational | February 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7542 | The Network Access IdentifierA. DeKok | Proposed Standard | May 2015 |
| 7593 | The eduroam Architecture for Network RoamingK. Wierenga, S. Winter, T. Wolniewicz | Informational | September 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8447 | IANA Registry Updates for TLS and DTLSJ. Salowey, S. Turner | Proposed Standard | August 2018 |
| 8996 | Deprecating TLS 1.0 and TLS 1.1K. Moriarty, S. Farrell | Best Current Practice | March 2021 |
| 9155 | Deprecating MD5 and SHA-1 Signature Hashes in TLS 1.2 and DTLS 1.2L. Velvindron, K. Moriarty, A. Ghedini | Proposed Standard | December 2021 |
| 9191 | Handling Large Certificates and Long Certificate Chains in TLS-Based EAP MethodsM. Sethi, J. Preuß Mattsson, S. Turner | Informational | February 2022 |