| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2595 | Using TLS with IMAP, POP3 and ACAPC. Newman | Proposed Standard | June 1999 |
| 3552 | Guidelines for Writing RFC Text on Security ConsiderationsE. Rescorla, B. Korver | Best Current Practice | July 2003 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4511 | Lightweight Directory Access Protocol (LDAP): The ProtocolJ. Sermersheim, Ed. | Proposed Standard | June 2006 |
| 4838 | Delay-Tolerant Networking ArchitectureV. Cerf, S. Burleigh, A. Hooke, L. Torgerson, R. Durst, K. Scott, K. Fall, H. Weiss | Informational | April 2007 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5489 | ECDHE_PSK Cipher Suites for Transport Layer Security (TLS)M. Badra, I. Hajjeh | Informational | March 2009 |
| 5912 | New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)P. Hoffman, J. Schaad | Informational | June 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6960 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPS. Santesson, M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams | Proposed Standard | June 2013 |
| 7122 | Datagram Convergence Layers for the Delay- and Disruption-Tolerant Networking (DTN) Bundle Protocol and Licklider Transmission Protocol (LTP)H. Kruse, S. Jero, S. Ostermann | Experimental | March 2014 |
| 7242 | Delay-Tolerant Networking TCP Convergence-Layer ProtocolM. Demmer, J. Ott, S. Perreault | Experimental | June 2014 |
| 7250 | Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Wouters, Ed., H. Tschofenig, Ed., J. Gilmore, S. Weiler, T. Kivinen | Proposed Standard | June 2014 |
| 7435 | Opportunistic Security: Some Protection Most of the TimeV. Dukhovni | Informational | December 2014 |
| 7457 | Summarizing Known Attacks on Transport Layer Security (TLS) and Datagram TLS (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre | Informational | February 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8555 | Automatic Certificate Management Environment (ACME)R. Barnes, J. Hoffman-Andrews, D. McCarney, J. Kasten | Proposed Standard | March 2019 |
| 9171 | Bundle Protocol Version 7S. Burleigh, K. Fall, E. Birrane, III | Proposed Standard | January 2022 |
| 9172 | Bundle Protocol Security (BPSec)E. Birrane, III, K. McKeever | Proposed Standard | January 2022 |