| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1112 | Host extensions for IP multicastingS.E. Deering | Internet Standard | August 1989 |
| 1157 | Simple Network Management Protocol (SNMP)J.D. Case, M. Fedor, M.L. Schoffstall, J. Davin | Historic | May 1990 |
| 2113 | IP Router Alert OptionD. Katz | Proposed Standard | February 1997 |
| 2464 | Transmission of IPv6 Packets over Ethernet NetworksM. Crawford | Proposed Standard | December 1998 |
| 2711 | IPv6 Router Alert OptionC. Partridge, A. Jackson | Proposed Standard | October 1999 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3597 | Handling of Unknown DNS Resource Record (RR) TypesA. Gustafsson | Proposed Standard | September 2003 |
| 5218 | What Makes for a Successful Protocol?D. Thaler, B. Aboba | Informational | July 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5321 | Simple Mail Transfer ProtocolJ. Klensin | Draft Standard | October 2008 |
| 5704 | Uncoordinated Protocol Development Considered HarmfulS. Bryant, Ed., M. Morrow, Ed., IAB | Informational | November 2009 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6709 | Design Considerations for Protocol ExtensionsB. Carpenter, B. Aboba, Ed., S. Cheshire | Informational | September 2012 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6891 | Extension Mechanisms for DNS (EDNS(0))J. Damas, M. Graff, P. Vixie | Internet Standard | April 2013 |
| 7208 | Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1S. Kitterman | Proposed Standard | April 2014 |
| 7301 | Transport Layer Security (TLS) Application-Layer Protocol Negotiation ExtensionS. Friedl, A. Popov, A. Langley, E. Stephan | Proposed Standard | July 2014 |
| 7413 | TCP Fast OpenY. Cheng, J. Chu, S. Radhakrishnan, A. Jain | Experimental | December 2014 |
| 7489 | Domain-based Message Authentication, Reporting, and Conformance (DMARC)M. Kucherawy, Ed., E. Zwicky, Ed. · obsoleted by RFC 9989, RFC 9990, RFC 9991 | Informational | March 2015 |
| 7696 | Guidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement AlgorithmsR. Housley | Best Current Practice | November 2015 |
| 7838 | HTTP Alternative ServicesM. Nottingham, P. McManus, J. Reschke | Proposed Standard | April 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8170 | Planning for Protocol Adoption and Subsequent TransitionsD. Thaler, Ed. | Informational | May 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8460 | SMTP TLS ReportingD. Margolis, A. Brotman, B. Ramakrishnan, J. Jones, M. Risher | Proposed Standard | September 2018 |
| 8558 | Transport Protocol Path SignalsT. Hardie, Ed. | Informational | April 2019 |
| 8684 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure, C. Paasch | Proposed Standard | March 2020 |
| 8701 | Applying Generate Random Extensions And Sustain Extensibility (GREASE) to TLS ExtensibilityD. Benjamin | Informational | January 2020 |
| 8941 | Structured Field Values for HTTPM. Nottingham, P-H. Kamp · obsoleted by RFC 9651 | Proposed Standard | February 2021 |
| 8999 | Version-Independent Properties of QUICM. Thomson | Proposed Standard | May 2021 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |