rfc.dk

Cited in: RFC 9152

39 RFCs mentioned in the text of RFC 9152 (Secure Object Delivery Protocol (SODP) Server Interfaces: NSA's Profile for Delivery of Certificates, Certificate Revocation Lists (CRLs), and Symmetric Keys to Clients)

RFCTitleStatusDate
2046Multipurpose Internet Mail Extensions (MIME) Part Two: Media TypesN. Freed, N. BorensteinDraft StandardNovember 1996
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
2985PKCS #9: Selected Object Classes and Attribute Types Version 2.0M. Nystrom, B. KaliskiInformationalNovember 2000
2986PKCS #10: Certification Request Syntax Specification Version 1.7M. Nystrom, B. KaliskiInformationalNovember 2000
3739Internet X.509 Public Key Infrastructure: Qualified Certificates ProfileS. Santesson, M. Nystrom, T. PolkProposed StandardMarch 2004
4108Using Cryptographic Message Syntax (CMS) to Protect Firmware PackagesR. HousleyProposed StandardAugust 2005
5273Certificate Management over CMS (CMC): Transport ProtocolsJ. Schaad, M. Myers · obsoleted by RFC 10003Proposed StandardJune 2008
5274Certificate Management Messages over CMS (CMC): Compliance RequirementsJ. Schaad, M. Myers · obsoleted by RFC 10004Proposed StandardJune 2008
5280Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. PolkProposed StandardMay 2008
5652Cryptographic Message Syntax (CMS)R. HousleyInternet StandardSeptember 2009
5911New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIMEP. Hoffman, J. SchaadInformationalJune 2010
5912New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)P. Hoffman, J. SchaadInformationalJune 2010
5913Clearance Attribute and Authority Clearance Constraints Certificate ExtensionS. Turner, S. ChokhaniProposed StandardJune 2010
5915Elliptic Curve Private Key StructureS. Turner, D. BrownInformationalJune 2010
5916Device Owner AttributeS. TurnerInformationalJune 2010
5917Clearance Sponsor AttributeS. TurnerInformationalJune 2010
5958Asymmetric Key PackagesS. TurnerProposed StandardAugust 2010
5959Algorithms for Asymmetric Key Package Content TypeS. TurnerProposed StandardAugust 2010
6010Cryptographic Message Syntax (CMS) Content Constraints ExtensionR. Housley, S. Ashmore, C. WallaceProposed StandardSeptember 2010
6031Cryptographic Message Syntax (CMS) Symmetric Key Package Content TypeS. Turner, R. HousleyProposed StandardDecember 2010
6032Cryptographic Message Syntax (CMS) Encrypted Key Package Content TypeS. Turner, R. HousleyProposed StandardDecember 2010
6033Algorithms for Cryptographic Message Syntax (CMS) Encrypted Key Package Content TypeS. TurnerProposed StandardDecember 2010
6160Algorithms for Cryptographic Message Syntax (CMS) Protection of Symmetric Key Package Content TypesS. TurnerProposed StandardApril 2011
6161Elliptic Curve Algorithms for Cryptographic Message Syntax (CMS) Encrypted Key Package Content TypeS. TurnerProposed StandardApril 2011
6162Elliptic Curve Algorithms for Cryptographic Message Syntax (CMS) Asymmetric Key Package Content TypeS. TurnerProposed StandardApril 2011
6268Additional New ASN.1 Modules for the Cryptographic Message Syntax (CMS) and the Public Key Infrastructure Using X.509 (PKIX)J. Schaad, S. TurnerInformationalJuly 2011
6402Certificate Management over CMS (CMC) UpdatesJ. Schaad · obsoleted by RFC 10002, RFC 10003, RFC 10004Proposed StandardNovember 2011
7030Enrollment over Secure TransportM. Pritikin, Ed., P. Yee, Ed., D. Harkins, Ed.Proposed StandardOctober 2013
7191Cryptographic Message Syntax (CMS) Key Package Receipt and Error Content TypesR. HousleyProposed StandardApril 2014
7192Algorithms for Cryptographic Message Syntax (CMS) Key Package Receipt and Error Content TypesS. TurnerProposed StandardApril 2014
7292PKCS #12: Personal Information Exchange Syntax v1.1K. Moriarty, Ed., M. Nystrom, S. Parkinson, A. Rusch, M. ScottInformationalJuly 2014
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7906NSA's Cryptographic Message Syntax (CMS) Key Management AttributesP. Timmel, R. Housley, S. TurnerInformationalJune 2016
8174Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. LeibaBest Current PracticeMay 2017
8295EST (Enrollment over Secure Transport) ExtensionsS. TurnerProposed StandardJanuary 2018
8603Commercial National Security Algorithm (CNSA) Suite Certificate and Certificate Revocation List (CRL) ProfileM. Jenkins, L. ZieglarInformationalMay 2019
8755Using Commercial National Security Algorithm Suite Algorithms in Secure/Multipurpose Internet Mail ExtensionsM. JenkinsInformationalMarch 2020
8756Commercial National Security Algorithm (CNSA) Suite Profile of Certificate Management over CMSM. Jenkins, L. ZieglarInformationalMarch 2020
9151Commercial National Security Algorithm (CNSA) Suite Profile for TLS and DTLS 1.2 and 1.3D. CooleyInformationalApril 2022