rfc.dk

Cited in: RFC 9148

31 RFCs mentioned in the text of RFC 9148 (EST-coaps: Enrollment over Secure Transport with the Secure Constrained Application Protocol)

RFCTitleStatusDate
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
2585Internet X.509 Public Key Infrastructure Operational Protocols: FTP and HTTPR. Housley, P. HoffmanProposed StandardMay 1999
4919IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs): Overview, Assumptions, Problem Statement, and GoalsN. Kushalnagar, G. Montenegro, C. SchumacherInformationalAugust 2007
5246The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846Proposed StandardAugust 2008
5272Certificate Management over CMS (CMC)J. Schaad, M. Myers · obsoleted by RFC 10002Proposed StandardJune 2008
5929Channel Bindings for TLSJ. Altman, N. Williams, L. ZhuProposed StandardJuly 2010
5958Asymmetric Key PackagesS. TurnerProposed StandardAugust 2010
5967The application/pkcs10 Media TypeS. TurnerInformationalAugust 2010
6347Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147Proposed StandardJanuary 2012
6402Certificate Management over CMS (CMC) UpdatesJ. Schaad · obsoleted by RFC 10002, RFC 10003, RFC 10004Proposed StandardNovember 2011
6690Constrained RESTful Environments (CoRE) Link FormatZ. ShelbyProposed StandardAugust 2012
7030Enrollment over Secure TransportM. Pritikin, Ed., P. Yee, Ed., D. Harkins, Ed.Proposed StandardOctober 2013
7228Terminology for Constrained-Node NetworksC. Bormann, M. Ersue, A. KeranenInformationalMay 2014
7230Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112Proposed StandardJune 2014
7251AES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLSD. McGrew, D. Bailey, M. Campagna, R. DugalInformationalJune 2014
7252The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. BormannProposed StandardJune 2014
7299Object Identifier Registry for the PKIX Working GroupR. HousleyInformationalJuly 2014
7525Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325Best Current PracticeMay 2015
7627Transport Layer Security (TLS) Session Hash and Extended Master Secret ExtensionK. Bhargavan, Ed., A. Delignat-Lavaud, A. Pironti, A. Langley, M. Ray · obsoleted by RFC 9846Proposed StandardSeptember 2015
7748Elliptic Curves for SecurityA. Langley, M. Hamburg, S. TurnerInformationalJanuary 2016
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7925Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. FossatiProposed StandardJuly 2016
7959Block-Wise Transfers in the Constrained Application Protocol (CoAP)C. Bormann, Z. Shelby, Ed.Proposed StandardAugust 2016
8075Guidelines for Mapping Implementations: HTTP to the Constrained Application Protocol (CoAP)A. Castellani, S. Loreto, A. Rahman, T. Fossati, E. DijkProposed StandardFebruary 2017
8174Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. LeibaBest Current PracticeMay 2017
8422Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and EarlierY. Nir, S. Josefsson, M. Pegourie-Gonnard · obsoleted by RFC 9846Proposed StandardAugust 2018
8446The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846Proposed StandardAugust 2018
8551Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message SpecificationJ. Schaad, B. Ramsdell, S. TurnerProposed StandardApril 2019
8710Multipart Content-Format for the Constrained Application Protocol (CoAP)T. Fossati, K. Hartke, C. BormannProposed StandardFebruary 2020
9146Connection Identifier for DTLS 1.2E. Rescorla, Ed., H. Tschofenig, Ed., T. Fossati, A. KrausProposed StandardMarch 2022
9147The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. ModaduguProposed StandardApril 2022