| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 850 | Standard for interchange of USENET messagesM.R. Horton · obsoleted by RFC 1036 | Unknown | June 1983 |
| 1919 | Classical versus Transparent IP ProxiesM. Chatel | Informational | March 1996 |
| 1945 | Hypertext Transfer Protocol -- HTTP/1.0T. Berners-Lee, R. Fielding, H. Frystyk | Informational | May 1996 |
| 1950 | ZLIB Compressed Data Format Specification version 3.3P. Deutsch, J-L. Gailly | Informational | May 1996 |
| 1951 | DEFLATE Compressed Data Format Specification version 1.3P. Deutsch | Informational | May 1996 |
| 1952 | GZIP file format specification version 4.3P. Deutsch | Informational | May 1996 |
| 2046 | Multipurpose Internet Mail Extensions (MIME) Part Two: Media TypesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2047 | MIME (Multipurpose Internet Mail Extensions) Part Three: Message Header Extensions for Non-ASCII TextK. Moore | Draft Standard | November 1996 |
| 2068 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, T. Berners-Lee · obsoleted by RFC 2616 | Proposed Standard | January 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2145 | Use and Interpretation of HTTP Version NumbersJ. C. Mogul, R. Fielding, J. Gettys, H. Frystyk · obsoleted by RFC 7230 | Informational | May 1997 |
| 2295 | Transparent Content Negotiation in HTTPK. Holtman, A. Mutz | Experimental | March 1998 |
| 2324 | Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0)L. Masinter | Informational | 1 April 1998 |
| 2557 | MIME Encapsulation of Aggregate Documents, such as HTML (MHTML)J. Palme, A. Hopmann, N. Shelness | Proposed Standard | March 1999 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2617 | HTTP Authentication: Basic and Digest Access AuthenticationJ. Franks, P. Hallam-Baker, J. Hostetler, S. Lawrence, P. Leach, A. Luotonen, L. Stewart · obsoleted by RFC 7235, RFC 7615, RFC 7616, RFC 7617 | Draft Standard | June 1999 |
| 2774 | An HTTP Extension FrameworkH. Nielsen, P. Leach, S. Lawrence | Historic | February 2000 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 2978 | IANA Charset Registration ProceduresN. Freed, J. Postel | Best Current Practice | October 2000 |
| 3040 | Internet Web Replication and Caching TaxonomyI. Cooper, I. Melve, G. Tomlinson | Informational | January 2001 |
| 3864 | Registration Procedures for Message Header FieldsG. Klyne, M. Nottingham, J. Mogul | Best Current Practice | September 2004 |
| 3875 | The Common Gateway Interface (CGI) Version 1.1D. Robinson, K. Coar | Informational | October 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4289 | Multipurpose Internet Mail Extensions (MIME) Part Four: Registration ProceduresN. Freed, J. Klensin | Best Current Practice | December 2005 |
| 4559 | SPNEGO-based Kerberos and NTLM HTTP Authentication in Microsoft WindowsK. Jaganathan, L. Zhu, J. Brezak | Informational | June 2006 |
| 4647 | Matching of Language TagsA. Phillips, Ed., M. Davis, Ed. | Best Current Practice | September 2006 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 4918 | HTTP Extensions for Web Distributed Authoring and Versioning (WebDAV)L. Dusseault, Ed. | Proposed Standard | June 2007 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5322 | Internet Message FormatP. Resnick, Ed. | Draft Standard | October 2008 |
| 5646 | Tags for Identifying LanguagesA. Phillips, Ed., M. Davis, Ed. | Best Current Practice | September 2009 |
| 5789 | PATCH Method for HTTPL. Dusseault, J. Snell | Proposed Standard | March 2010 |
| 5905 | Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. Kasch | Proposed Standard | June 2010 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6265 | HTTP State Management MechanismA. Barth | Proposed Standard | April 2011 |
| 6365 | Terminology Used in Internationalization in the IETFP. Hoffman, J. Klensin | Best Current Practice | September 2011 |
| 6454 | The Web Origin ConceptA. Barth | Proposed Standard | December 2011 |
| 6585 | Additional HTTP Status CodesM. Nottingham, R. Fielding | Proposed Standard | April 2012 |
| 6648 | Deprecating the "X-" Prefix and Similar Constructs in Application ProtocolsP. Saint-Andre, D. Crocker, M. Nottingham | Best Current Practice | June 2012 |
| 6838 | Media Type Specifications and Registration ProceduresN. Freed, J. Klensin, T. Hansen | Best Current Practice | January 2013 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7232 | Hypertext Transfer Protocol (HTTP/1.1): Conditional RequestsR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7233 | Hypertext Transfer Protocol (HTTP/1.1): Range RequestsR. Fielding, Ed., Y. Lafon, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7234 | Hypertext Transfer Protocol (HTTP/1.1): CachingR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. · obsoleted by RFC 9111 | Proposed Standard | June 2014 |
| 7235 | Hypertext Transfer Protocol (HTTP/1.1): AuthenticationR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7405 | Case-Sensitive String Support in ABNFP. Kyzivat | Proposed Standard | December 2014 |
| 7538 | The Hypertext Transfer Protocol Status Code 308 (Permanent Redirect)J. Reschke · obsoleted by RFC 9110 | Proposed Standard | April 2015 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7541 | HPACK: Header Compression for HTTP/2R. Peon, H. Ruellan | Proposed Standard | May 2015 |
| 7578 | Returning Values from Forms: multipart/form-dataL. Masinter | Proposed Standard | July 2015 |
| 7595 | Guidelines and Registration Procedures for URI SchemesD. Thaler, Ed., T. Hansen, T. Hardie | Best Current Practice | June 2015 |
| 7615 | HTTP Authentication-Info and Proxy-Authentication-Info Response Header FieldsJ. Reschke · obsoleted by RFC 9110 | Proposed Standard | September 2015 |
| 7616 | HTTP Digest Access AuthenticationR. Shekh-Yusef, Ed., D. Ahrens, S. Bremer | Proposed Standard | September 2015 |
| 7617 | The 'Basic' HTTP Authentication SchemeJ. Reschke | Proposed Standard | September 2015 |
| 7694 | Hypertext Transfer Protocol (HTTP) Client-Initiated Content-EncodingJ. Reschke · obsoleted by RFC 9110 | Proposed Standard | November 2015 |
| 7838 | HTTP Alternative ServicesM. Nottingham, P. McManus, J. Reschke | Proposed Standard | April 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8187 | Indicating Character Encoding and Language for HTTP Header Field ParametersJ. Reschke | Proposed Standard | September 2017 |
| 8246 | HTTP Immutable ResponsesP. McManus | Proposed Standard | September 2017 |
| 8288 | Web LinkingM. Nottingham | Proposed Standard | October 2017 |
| 8336 | The ORIGIN HTTP/2 FrameM. Nottingham, E. Nygren | Proposed Standard | March 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8615 | Well-Known Uniform Resource Identifiers (URIs)M. Nottingham | Proposed Standard | May 2019 |
| 8941 | Structured Field Values for HTTPM. Nottingham, P-H. Kamp · obsoleted by RFC 9651 | Proposed Standard | February 2021 |
| 9111 | HTTP CachingR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9112 | HTTP/1.1R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9113 | HTTP/2M. Thomson, Ed., C. Benfield, Ed. | Proposed Standard | June 2022 |
| 9114 | HTTP/3M. Bishop, Ed. | Proposed Standard | June 2022 |