| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2529 | Transmission of IPv6 over IPv4 Domains without Explicit TunnelsB. Carpenter, C. Jung | Proposed Standard | March 1999 |
| 2663 | IP Network Address Translator (NAT) Terminology and ConsiderationsP. Srisuresh, M. Holdrege | Informational | August 1999 |
| 2784 | Generic Routing Encapsulation (GRE)D. Farinacci, T. Li, S. Hanks, D. Meyer, P. Traina | Proposed Standard | March 2000 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 2866 | RADIUS AccountingC. Rigney | Informational | June 2000 |
| 3056 | Connection of IPv6 Domains via IPv4 CloudsB. Carpenter, K. Moore | Proposed Standard | February 2001 |
| 3068 | An Anycast Prefix for 6to4 Relay RoutersC. Huitema · obsoleted by RFC 7526 | Historic | June 2001 |
| 3627 | Use of /127 Prefix Length Between Routers Considered HarmfulP. Savola · obsoleted by RFC 6547 | Historic | September 2003 |
| 3704 | Ingress Filtering for Multihomed NetworksF. Baker, P. Savola | Best Current Practice | March 2004 |
| 3756 | IPv6 Neighbor Discovery (ND) Trust Models and ThreatsP. Nikander, Ed., J. Kempf, E. Nordmark | Informational | May 2004 |
| 3964 | Security Considerations for 6to4P. Savola, C. Patel | Informational | December 2004 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |
| 3972 | Cryptographically Generated Addresses (CGA)T. Aura | Proposed Standard | March 2005 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4107 | Guidelines for Cryptographic Key ManagementS. Bellovin, R. Housley | Best Current Practice | June 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4293 | Management Information Base for the Internet Protocol (IP)S. Routhier, Ed. | Proposed Standard | April 2006 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4364 | BGP/MPLS IP Virtual Private Networks (VPNs)E. Rosen, Y. Rekhter | Proposed Standard | February 2006 |
| 4380 | Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)C. Huitema | Proposed Standard | February 2006 |
| 4381 | Analysis of the Security of BGP/MPLS IP Virtual Private Networks (VPNs)M. Behringer | Informational | February 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4552 | Authentication/Confidentiality for OSPFv3M. Gupta, N. Melam | Proposed Standard | June 2006 |
| 4649 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Relay Agent Remote-ID OptionB. Volz | Proposed Standard | August 2006 |
| 4659 | BGP-MPLS IP Virtual Private Network (VPN) Extension for IPv6 VPNJ. De Clercq, D. Ooms, M. Carugi, F. Le Faucheur | Proposed Standard | September 2006 |
| 4795 | Link-local Multicast Name Resolution (LLMNR)B. Aboba, D. Thaler, L. Esibov | Informational | January 2007 |
| 4798 | Connecting IPv6 Islands over IPv4 MPLS Using IPv6 Provider Edge Routers (6PE)J. De Clercq, D. Ooms, S. Prevost, F. Le Faucheur | Proposed Standard | February 2007 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4864 | Local Network Protection for IPv6G. Van de Velde, T. Hain, R. Droms, B. Carpenter, E. Klein | Informational | May 2007 |
| 4890 | Recommendations for Filtering ICMPv6 Messages in FirewallsE. Davies, J. Mohacsi | Informational | May 2007 |
| 4942 | IPv6 Transition/Co-existence Security ConsiderationsE. Davies, S. Krishnan, P. Savola | Informational | September 2007 |
| 5082 | The Generalized TTL Security Mechanism (GTSM)V. Gill, J. Heasley, D. Meyer, P. Savola, Ed., C. Pignataro | Proposed Standard | October 2007 |
| 5214 | Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)F. Templin, T. Gleeson, D. Thaler | Informational | March 2008 |
| 5340 | OSPF for IPv6R. Coltun, D. Ferguson, J. Moy, A. Lindem | Proposed Standard | July 2008 |
| 5635 | Remote Triggered Black Hole Filtering with Unicast Reverse Path Forwarding (uRPF)W. Kumari, D. McPherson | Informational | August 2009 |
| 5952 | A Recommendation for IPv6 Address Text RepresentationS. Kawamura, M. Kawashima | Proposed Standard | August 2010 |
| 5969 | IPv6 Rapid Deployment on IPv4 Infrastructures (6rd) -- Protocol SpecificationW. Townsley, O. Troan | Proposed Standard | August 2010 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6104 | Rogue IPv6 Router Advertisement Problem StatementT. Chown, S. Venaas | Informational | February 2011 |
| 6105 | IPv6 Router Advertisement GuardE. Levy-Abegnoli, G. Van de Velde, C. Popoviciu, J. Mohacsi | Informational | February 2011 |
| 6144 | Framework for IPv4/IPv6 TranslationF. Baker, X. Li, C. Bao, K. Yin | Informational | April 2011 |
| 6146 | Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6147 | DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, A. Sullivan, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6164 | Using 127-Bit IPv6 Prefixes on Inter-Router LinksM. Kohno, B. Nitzan, R. Bush, Y. Matsuzaki, L. Colitti, T. Narten | Proposed Standard | April 2011 |
| 6169 | Security Concerns with IP TunnelingS. Krishnan, D. Thaler, J. Hoagland | Informational | April 2011 |
| 6177 | IPv6 Address Assignment to End SitesT. Narten, G. Huston, L. Roberts | Best Current Practice | March 2011 |
| 6192 | Protecting the Router Control PlaneD. Dugal, C. Pignataro, R. Dunn | Informational | March 2011 |
| 6221 | Lightweight DHCPv6 Relay AgentD. Miles, Ed., S. Ooghe, W. Dec, S. Krishnan, A. Kavanagh | Proposed Standard | May 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6264 | An Incremental Carrier-Grade NAT (CGN) for IPv6 TransitionS. Jiang, D. Guo, B. Carpenter | Informational | June 2011 |
| 6269 | Issues with IP Address SharingM. Ford, Ed., M. Boucadair, A. Durand, P. Levis, P. Roberts | Informational | June 2011 |
| 6296 | IPv6-to-IPv6 Network Prefix TranslationM. Wasserman, F. Baker | Experimental | June 2011 |
| 6302 | Logging Recommendations for Internet-Facing ServersA. Durand, I. Gashinsky, D. Lee, S. Sheppard | Best Current Practice | June 2011 |
| 6324 | Routing Loop Attack Using IPv6 Automatic Tunnels: Problem Statement and Proposed MitigationsG. Nakibly, F. Templin | Informational | August 2011 |
| 6333 | Dual-Stack Lite Broadband Deployments Following IPv4 ExhaustionA. Durand, R. Droms, J. Woodyatt, Y. Lee | Proposed Standard | August 2011 |
| 6343 | Advisory Guidelines for 6to4 DeploymentB. Carpenter | Informational | August 2011 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |
| 6459 | IPv6 in 3rd Generation Partnership Project (3GPP) Evolved Packet System (EPS)J. Korhonen, Ed., J. Soininen, B. Patil, T. Savolainen, G. Bajko, K. Iisakkila | Informational | January 2012 |
| 6547 | RFC 3627 to Historic StatusW. George | Informational | February 2012 |
| 6564 | A Uniform Format for IPv6 Extension HeadersS. Krishnan, J. Woodyatt, E. Kline, J. Hoagland, M. Bhatia | Proposed Standard | April 2012 |
| 6583 | Operational Neighbor Discovery ProblemsI. Gashinsky, J. Jaeggli, W. Kumari | Informational | March 2012 |
| 6598 | IANA-Reserved IPv4 Prefix for Shared Address SpaceJ. Weil, V. Kuarsingh, C. Donley, C. Liljenstolpe, M. Azinger | Best Current Practice | April 2012 |
| 6620 | FCFS SAVI: First-Come, First-Served Source Address Validation Improvement for Locally Assigned IPv6 AddressesE. Nordmark, M. Bagnulo, E. Levy-Abegnoli | Proposed Standard | May 2012 |
| 6666 | A Discard Prefix for IPv6N. Hilliard, D. Freedman | Informational | August 2012 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6763 | DNS-Based Service DiscoveryS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6775 | Neighbor Discovery Optimization for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)Z. Shelby, Ed., S. Chakrabarti, E. Nordmark, C. Bormann | Proposed Standard | November 2012 |
| 6877 | 464XLAT: Combination of Stateful and Stateless TranslationM. Mawatari, M. Kawashima, C. Byrne | Informational | April 2013 |
| 6888 | Common Requirements for Carrier-Grade NATs (CGNs)S. Perreault, Ed., I. Yamagata, S. Miyakawa, A. Nakagawa, H. Ashida | Best Current Practice | April 2013 |
| 6939 | Client Link-Layer Address Option in DHCPv6G. Halwasia, S. Bhandari, W. Dec | Proposed Standard | May 2013 |
| 6964 | Operational Guidance for IPv6 Deployment in IPv4 Sites Using the Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)F. Templin | Informational | May 2013 |
| 6967 | Analysis of Potential Solutions for Revealing a Host Identifier (HOST_ID) in Shared Address DeploymentsM. Boucadair, J. Touch, P. Levis, R. Penno | Informational | June 2013 |
| 6980 | Security Implications of IPv6 Fragmentation with IPv6 Neighbor DiscoveryF. Gont | Proposed Standard | August 2013 |
| 7010 | IPv6 Site Renumbering Gap AnalysisB. Liu, S. Jiang, B. Carpenter, S. Venaas, W. George | Informational | September 2013 |
| 7011 | Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow InformationB. Claise, Ed., B. Trammell, Ed., P. Aitken | Internet Standard | September 2013 |
| 7012 | Information Model for IP Flow Information Export (IPFIX)B. Claise, Ed., B. Trammell, Ed. | Proposed Standard | September 2013 |
| 7039 | Source Address Validation Improvement (SAVI) FrameworkJ. Wu, J. Bi, M. Bagnulo, F. Baker, C. Vogt, Ed. | Informational | October 2013 |
| 7045 | Transmission and Processing of IPv6 Extension HeadersB. Carpenter, S. Jiang | Proposed Standard | December 2013 |
| 7084 | Basic Requirements for IPv6 Customer Edge RoutersH. Singh, W. Beebee, C. Donley, B. Stark | Informational | November 2013 |
| 7112 | Implications of Oversized IPv6 Header ChainsF. Gont, V. Manral, R. Bonica | Proposed Standard | January 2014 |
| 7113 | Implementation Advice for IPv6 Router Advertisement Guard (RA-Guard)F. Gont | Informational | February 2014 |
| 7123 | Security Implications of IPv6 on IPv4 NetworksF. Gont, W. Liu | Informational | February 2014 |
| 7166 | Supporting Authentication Trailer for OSPFv3M. Bhatia, V. Manral, A. Lindem | Proposed Standard | March 2014 |
| 7217 | A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC)F. Gont | Proposed Standard | April 2014 |
| 7359 | Layer 3 Virtual Private Network (VPN) Tunnel Traffic Leakages in Dual-Stack Hosts/NetworksF. Gont | Informational | August 2014 |
| 7381 | Enterprise IPv6 Deployment GuidelinesK. Chittimaneni, T. Chown, L. Howard, V. Kuarsingh, Y. Pouffary, E. Vyncke | Informational | October 2014 |
| 7404 | Using Only Link-Local Addressing inside an IPv6 NetworkM. Behringer, E. Vyncke | Informational | November 2014 |
| 7422 | Deterministic Address Mapping to Reduce Logging in Carrier-Grade NAT DeploymentsC. Donley, C. Grundemann, V. Sarawat, K. Sundaresan, O. Vautrin | Informational | December 2014 |
| 7454 | BGP Operations and SecurityJ. Durand, I. Pepelnjak, G. Doering | Best Current Practice | February 2015 |
| 7513 | Source Address Validation Improvement (SAVI) Solution for DHCPJ. Bi, J. Wu, G. Yao, F. Baker | Proposed Standard | May 2015 |
| 7526 | Deprecating the Anycast Prefix for 6to4 Relay RoutersO. Troan, B. Carpenter, Ed. | Best Current Practice | May 2015 |
| 7552 | Updates to LDP for IPv6R. Asati, C. Pignataro, K. Raza, V. Manral, R. Papneja | Proposed Standard | June 2015 |
| 7597 | Mapping of Address and Port with Encapsulation (MAP-E)O. Troan, Ed., W. Dec, X. Li, C. Bao, S. Matsushima, T. Murakami, T. Taylor, Ed. | Proposed Standard | July 2015 |
| 7599 | Mapping of Address and Port using Translation (MAP-T)X. Li, C. Bao, W. Dec, Ed., O. Troan, S. Matsushima, T. Murakami | Proposed Standard | July 2015 |
| 7610 | DHCPv6-Shield: Protecting against Rogue DHCPv6 ServersF. Gont, W. Liu, G. Van de Velde | Best Current Practice | August 2015 |
| 7707 | Network Reconnaissance in IPv6 NetworksF. Gont, T. Chown | Informational | March 2016 |
| 7721 | Security and Privacy Considerations for IPv6 Address Generation MechanismsA. Cooper, F. Gont, D. Thaler | Informational | March 2016 |
| 7772 | Reducing Energy Consumption of Router AdvertisementsA. Yourtchenko, L. Colitti | Best Current Practice | February 2016 |
| 7785 | Recommendations for Prefix Binding in the Context of Softwire Dual-Stack LiteS. Vinapamula, M. Boucadair | Informational | February 2016 |
| 7824 | Privacy Considerations for DHCPv6S. Krishnan, T. Mrugalski, S. Jiang | Informational | May 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7844 | Anonymity Profiles for DHCP ClientsC. Huitema, T. Mrugalski, S. Krishnan | Proposed Standard | May 2016 |
| 7857 | Updates to Network Address Translation (NAT) Behavioral RequirementsR. Penno, S. Perreault, M. Boucadair, Ed., S. Sivakumar, K. Naito | Best Current Practice | April 2016 |
| 7872 | Observations on the Dropping of Packets with IPv6 Extension Headers in the Real WorldF. Gont, J. Linkova, T. Chown, W. Liu | Informational | June 2016 |
| 7915 | IP/ICMP Translation AlgorithmC. Bao, X. Li, F. Baker, T. Anderson, F. Gont | Proposed Standard | June 2016 |
| 7934 | Host Address Availability RecommendationsL. Colitti, V. Cerf, S. Cheshire, D. Schinazi | Best Current Practice | July 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8064 | Recommendation on Stable IPv6 Interface IdentifiersF. Gont, A. Cooper, D. Thaler, W. Liu | Proposed Standard | February 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8177 | YANG Data Model for Key ChainsA. Lindem, Ed., Y. Qu, D. Yeung, I. Chen, J. Zhang | Proposed Standard | June 2017 |
| 8190 | Updates to the Special-Purpose IP Address RegistriesR. Bonica, M. Cotton, B. Haberman, L. Vegoda | Best Current Practice | June 2017 |
| 8200 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden | Internet Standard | July 2017 |
| 8210 | The Resource Public Key Infrastructure (RPKI) to Router Protocol, Version 1R. Bush, R. Austein | Proposed Standard | September 2017 |
| 8273 | Unique IPv6 Prefix per HostJ. Brzozowski, G. Van de Velde | Informational | December 2017 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8344 | A YANG Data Model for IP ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8415 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)T. Mrugalski, M. Siodelski, B. Volz, A. Yourtchenko, M. Richardson, S. Jiang, T. Lemon, T. Winters · obsoleted by RFC 9915 | Proposed Standard | November 2018 |
| 8504 | IPv6 Node RequirementsT. Chown, J. Loughney, T. Winters | Best Current Practice | January 2019 |
| 8520 | Manufacturer Usage Description SpecificationE. Lear, R. Droms, D. Romascanu | Proposed Standard | March 2019 |
| 8541 | Impact of Shortest Path First (SPF) Trigger and Delay Strategies on IGP Micro-loopsS. Litkowski, B. Decraene, M. Horneffer | Informational | March 2019 |
| 8981 | Temporary Address Extensions for Stateless Address Autoconfiguration in IPv6F. Gont, S. Krishnan, T. Narten, R. Draves | Proposed Standard | February 2021 |