| 792 | Internet Control Message ProtocolJ. Postel | Internet Standard | September 1981 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2663 | IP Network Address Translator (NAT) Terminology and ConsiderationsP. Srisuresh, M. Holdrege | Informational | August 1999 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4632 | Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation PlanV. Fuller, T. Li | Best Current Practice | August 2006 |
| 4732 | Internet Denial-of-Service ConsiderationsM. Handley, Ed., E. Rescorla, Ed., IAB | Informational | December 2006 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6052 | IPv6 Addressing of IPv4/IPv6 TranslatorsC. Bao, C. Huitema, M. Bagnulo, M. Boucadair, X. Li | Proposed Standard | October 2010 |
| 6146 | Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6398 | IP Router Alert Considerations and UsageF. Le Faucheur, Ed. | Best Current Practice | October 2011 |
| 6973 | Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. Smith | Informational | July 2013 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7011 | Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow InformationB. Claise, Ed., B. Trammell, Ed., P. Aitken | Internet Standard | September 2013 |
| 7596 | Lightweight 4over6: An Extension to the Dual-Stack Lite ArchitectureY. Cui, Q. Sun, M. Boucadair, T. Tsou, Y. Lee, I. Farrer | Proposed Standard | July 2015 |
| 7597 | Mapping of Address and Port with Encapsulation (MAP-E)O. Troan, Ed., W. Dec, X. Li, C. Bao, S. Matsushima, T. Murakami, T. Taylor, Ed. | Proposed Standard | July 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8071 | NETCONF Call Home and RESTCONF Call HomeK. Watsen | Proposed Standard | February 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8340 | YANG Tree DiagramsM. Bjorklund, L. Berger, Ed. | Best Current Practice | March 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8512 | A YANG Module for Network Address Translation (NAT) and Network Prefix Translation (NPT)M. Boucadair, Ed., S. Sivakumar, C. Jacquenet, S. Vinapamula, Q. Wu | Proposed Standard | January 2019 |
| 8513 | A YANG Data Model for Dual-Stack Lite (DS-Lite)M. Boucadair, C. Jacquenet, S. Sivakumar | Proposed Standard | January 2019 |
| 8517 | An Inventory of Transport-Centric Functions Provided by Middleboxes: An Operator PerspectiveD. Dolson, Ed., J. Snellman, M. Boucadair, Ed., C. Jacquenet | Informational | February 2019 |
| 8576 | Internet of Things (IoT) Security: State of the Art and ChallengesO. Garcia-Morchon, S. Kumar, M. Sethi | Informational | April 2019 |
| 8612 | DDoS Open Threat Signaling (DOTS) RequirementsA. Mortensen, T. Reddy, R. Moskowitz | Informational | May 2019 |
| 8791 | YANG Data Structure ExtensionsA. Bierman, M. Björklund, K. Watsen | Proposed Standard | June 2020 |
| 8811 | DDoS Open Threat Signaling (DOTS) ArchitectureA. Mortensen, Ed., T. Reddy.K, Ed., F. Andreasen, N. Teague, R. Compton | Informational | August 2020 |
| 8903 | Use Cases for DDoS Open Threat SignalingR. Dobbins, D. Migault, R. Moskowitz, N. Teague, L. Xia, K. Nishizuka | Informational | May 2021 |
| 8955 | Dissemination of Flow Specification RulesC. Loibl, S. Hares, R. Raszuk, D. McPherson, M. Bacher | Proposed Standard | December 2020 |
| 8956 | Dissemination of Flow Specification Rules for IPv6C. Loibl, Ed., R. Raszuk, Ed., S. Hares, Ed. | Proposed Standard | December 2020 |
| 8973 | DDoS Open Threat Signaling (DOTS) Agent DiscoveryM. Boucadair, T. Reddy.K | Proposed Standard | January 2021 |
| 9132 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationM. Boucadair, Ed., J. Shallow, T. Reddy.K | Proposed Standard | September 2021 |