| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 792 | Internet Control Message ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1016 | Something a Host Could Do with Source Quench: The Source Quench Introduced Delay (SQuID)W. Prue, J. Postel | Unknown | July 1987 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1190 | Experimental Internet Stream Protocol: Version 2 (ST-II)C. Topolcic · obsoleted by RFC 1819 | Experimental | October 1990 |
| 1633 | Integrated Services in the Internet Architecture: an OverviewR. Braden, D. Clark, S. Shenker | Informational | June 1994 |
| 1809 | Using the Flow Label Field in IPv6C. Partridge | Informational | June 1995 |
| 1819 | Internet Stream Protocol Version 2 (ST2) Protocol Specification - Version ST2+L. Delgrossi, Ed., L. Berger, Ed. | Historic | August 1995 |
| 1887 | An Architecture for IPv6 Unicast Address AllocationY. Rekhter, Ed., T. Li, Ed. | Informational | December 1995 |
| 2001 | TCP Slow Start, Congestion Avoidance, Fast Retransmit, and Fast Recovery AlgorithmsW. Stevens · obsoleted by RFC 2581 | Proposed Standard | January 1997 |
| 2205 | Resource ReSerVation Protocol (RSVP) -- Version 1 Functional SpecificationR. Braden, Ed., L. Zhang, S. Berson, S. Herzog, S. Jamin | Proposed Standard | September 1997 |
| 2210 | The Use of RSVP with IETF Integrated ServicesJ. Wroclawski | Proposed Standard | September 1997 |
| 2211 | Specification of the Controlled-Load Network Element ServiceJ. Wroclawski | Proposed Standard | September 1997 |
| 2212 | Specification of Guaranteed Quality of ServiceS. Shenker, C. Partridge, R. Guerin | Proposed Standard | September 1997 |
| 2215 | General Characterization Parameters for Integrated Service Network ElementsS. Shenker, J. Wroclawski | Proposed Standard | September 1997 |
| 2309 | Recommendations on Queue Management and Congestion Avoidance in the InternetB. Braden, D. Clark, J. Crowcroft, B. Davie, S. Deering, D. Estrin, S. Floyd, V. Jacobson, G. Minshall, C. Partridge, L. Peterson, K. Ramakrishnan, S. Shenker, J. Wroclawski, L. Zhang · obsoleted by RFC 7567 | Informational | April 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2475 | An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. Weiss | Informational | December 1998 |
| 2481 | A Proposal to add Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd · obsoleted by RFC 3168 | Experimental | January 1999 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3697 | IPv6 Flow Label SpecificationJ. Rajahalme, A. Conta, B. Carpenter, S. Deering · obsoleted by RFC 6437 | Proposed Standard | March 2004 |
| 4094 | Analysis of Existing Quality-of-Service Signaling ProtocolsJ. Manner, X. Fu | Informational | May 2005 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4782 | Quick-Start for TCP and IPS. Floyd, M. Allman, A. Jain, P. Sarolahti | Experimental | January 2007 |
| 5082 | The Generalized TTL Security Mechanism (GTSM)V. Gill, J. Heasley, D. Meyer, P. Savola, Ed., C. Pignataro | Proposed Standard | October 2007 |
| 5218 | What Makes for a Successful Protocol?D. Thaler, B. Aboba | Informational | July 2008 |
| 5533 | Shim6: Level 3 Multihoming Shim Protocol for IPv6E. Nordmark, M. Bagnulo | Proposed Standard | June 2009 |
| 5575 | Dissemination of Flow Specification RulesP. Marques, N. Sheth, R. Raszuk, B. Greene, J. Mauch, D. McPherson · obsoleted by RFC 8955 | Proposed Standard | August 2009 |
| 5681 | TCP Congestion ControlM. Allman, V. Paxson, E. Blanton | Draft Standard | September 2009 |
| 5971 | GIST: General Internet Signalling TransportH. Schulzrinne, R. Hancock | Experimental | October 2010 |
| 5973 | NAT/Firewall NSIS Signaling Layer Protocol (NSLP)M. Stiemerling, H. Tschofenig, C. Aoun, E. Davies | Experimental | October 2010 |
| 5974 | NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service SignalingJ. Manner, G. Karagiannis, A. McDonald | Experimental | October 2010 |
| 5981 | Authorization for NSIS Signaling Layer ProtocolsJ. Manner, M. Stiemerling, H. Tschofenig, R. Bless, Ed. | Experimental | February 2011 |
| 6294 | Survey of Proposed Use Cases for the IPv6 Flow LabelQ. Hu, B. Carpenter | Informational | June 2011 |
| 6398 | IP Router Alert Considerations and UsageF. Le Faucheur, Ed. | Best Current Practice | October 2011 |
| 6437 | IPv6 Flow Label SpecificationS. Amante, B. Carpenter, S. Jiang, J. Rajahalme | Proposed Standard | November 2011 |
| 6438 | Using the IPv6 Flow Label for Equal Cost Multipath Routing and Link Aggregation in TunnelsB. Carpenter, S. Amante | Proposed Standard | November 2011 |
| 6633 | Deprecation of ICMP Source Quench MessagesF. Gont | Proposed Standard | May 2012 |
| 6928 | Increasing TCP's Initial WindowJ. Chu, N. Dukkipati, Y. Cheng, M. Mathis | Experimental | April 2013 |
| 7305 | Report from the IAB Workshop on Internet Technology Adoption and Transition (ITAT)E. Lear, Ed. | Informational | July 2014 |
| 7418 | An IRTF Primer for IETF ParticipantsS. Dawkins, Ed. | Informational | December 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 8170 | Planning for Protocol Adoption and Subsequent TransitionsD. Thaler, Ed. | Informational | May 2017 |
| 8655 | Deterministic Networking ArchitectureN. Finn, P. Thubert, B. Varga, J. Farkas | Proposed Standard | October 2019 |
| 8793 | Information-Centric Networking (ICN): Content-Centric Networking (CCNx) and Named Data Networking (NDN) TerminologyB. Wissingh, C. Wood, A. Afanasyev, L. Zhang, D. Oran, C. Tschudin | Informational | June 2020 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |