rfc.dk

Cited in: RFC 9028

32 RFCs mentioned in the text of RFC 9028 (Native NAT Traversal Mode for the Host Identity Protocol)

RFCTitleStatusDate
1191Path MTU discoveryJ. Mogul, S. DeeringDraft StandardNovember 1990
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
2475An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. WeissInformationalDecember 1998
3264An Offer/Answer Model with Session Description Protocol (SDP)J. Rosenberg, H. SchulzrinneProposed StandardJuly 2002
3948UDP Encapsulation of IPsec ESP PacketsA. Huttunen, B. Swander, V. Volpe, L. DiBurro, M. StenbergProposed StandardJanuary 2005
4291IP Version 6 Addressing ArchitectureR. Hinden, S. DeeringDraft StandardFebruary 2006
5128State of Peer-to-Peer (P2P) Communication across Network Address Translators (NATs)P. Srisuresh, B. Ford, D. KegelInformationalMarch 2008
5207NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) CommunicationM. Stiemerling, J. Quittek, L. EggertInformationalApril 2008
5245Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer ProtocolsJ. Rosenberg · obsoleted by RFC 8445, RFC 8839Proposed StandardApril 2010
5770Basic Host Identity Protocol (HIP) Extensions for Traversal of Network Address TranslatorsM. Komu, T. Henderson, H. Tschofenig, J. Melen, A. Keranen, Ed.ExperimentalApril 2010
6146Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van BeijnumProposed StandardApril 2011
6147DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, A. Sullivan, P. Matthews, I. van BeijnumProposed StandardApril 2011
6538The Host Identity Protocol (HIP) Experiment ReportT. Henderson, A. GurtovInformationalMarch 2012
7050Discovery of the IPv6 Prefix Used for IPv6 Address SynthesisT. Savolainen, J. Korhonen, D. WingProposed StandardNovember 2013
7401Host Identity Protocol Version 2 (HIPv2)R. Moskowitz, Ed., T. Heer, P. Jokela, T. HendersonProposed StandardApril 2015
7402Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)P. Jokela, R. Moskowitz, J. MelenProposed StandardApril 2015
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
8003Host Identity Protocol (HIP) Registration ExtensionJ. Laganier, L. EggertProposed StandardOctober 2016
8004Host Identity Protocol (HIP) Rendezvous ExtensionJ. Laganier, L. EggertProposed StandardOctober 2016
8005Host Identity Protocol (HIP) Domain Name System (DNS) ExtensionJ. LaganierProposed StandardOctober 2016
8046Host Mobility with the Host Identity ProtocolT. Henderson, Ed., C. Vogt, J. ArkkoProposed StandardFebruary 2017
8047Host Multihoming with the Host Identity ProtocolT. Henderson, Ed., C. Vogt, J. ArkkoProposed StandardFebruary 2017
8126Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. NartenBest Current PracticeJune 2017
8174Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. LeibaBest Current PracticeMay 2017
8201Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul, R. Hinden, Ed.Internet StandardJuly 2017
8445Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) TraversalA. Keranen, C. Holmberg, J. RosenbergProposed StandardJuly 2018
8489Session Traversal Utilities for NAT (STUN)M. Petit-Huguenin, G. Salgueiro, J. Rosenberg, D. Wing, R. Mahy, P. MatthewsProposed StandardFebruary 2020
8656Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)T. Reddy, Ed., A. Johnston, Ed., P. Matthews, J. RosenbergProposed StandardFebruary 2020
8750Implicit Initialization Vector (IV) for Counter-Based Ciphers in Encapsulating Security Payload (ESP)D. Migault, T. Guggemos, Y. NirProposed StandardMarch 2020
8899Packetization Layer Path MTU Discovery for Datagram TransportsG. Fairhurst, T. Jones, M. Tüxen, I. Rüngeler, T. VölkerProposed StandardSeptember 2020
8961Requirements for Time-Based Loss DetectionM. AllmanBest Current PracticeNovember 2020
9063Host Identity Protocol ArchitectureR. Moskowitz, Ed., M. KomuInformationalJuly 2021