| 1321 | The MD5 Message-Digest AlgorithmR. Rivest | Informational | April 1992 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3041 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves · obsoleted by RFC 4941 | Proposed Standard | January 2001 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 5014 | IPv6 Socket API for Source Address SelectionE. Nordmark, S. Chakrabarti, J. Laganier | Informational | September 2007 |
| 5453 | Reserved IPv6 Interface IdentifiersS. Krishnan | Proposed Standard | February 2009 |
| 6059 | Simple Procedures for Detecting Network Attachment in IPv6S. Krishnan, G. Daley | Proposed Standard | November 2010 |
| 6151 | Updated Security Considerations for the MD5 Message-Digest and the HMAC-MD5 AlgorithmsS. Turner, L. Chen | Informational | March 2011 |
| 6265 | HTTP State Management MechanismA. Barth | Proposed Standard | April 2011 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 7039 | Source Address Validation Improvement (SAVI) FrameworkJ. Wu, J. Bi, M. Bagnulo, F. Baker, C. Vogt, Ed. | Informational | October 2013 |
| 7136 | Significance of IPv6 Interface IdentifiersB. Carpenter, S. Jiang | Proposed Standard | February 2014 |
| 7217 | A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC)F. Gont | Proposed Standard | April 2014 |
| 7258 | Pervasive Monitoring Is an AttackS. Farrell, H. Tschofenig | Best Current Practice | May 2014 |
| 7421 | Analysis of the 64-bit Boundary in IPv6 AddressingB. Carpenter, Ed., T. Chown, F. Gont, S. Jiang, A. Petrescu, A. Yourtchenko | Informational | January 2015 |
| 7707 | Network Reconnaissance in IPv6 NetworksF. Gont, T. Chown | Informational | March 2016 |
| 7721 | Security and Privacy Considerations for IPv6 Address Generation MechanismsA. Cooper, F. Gont, D. Thaler | Informational | March 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7934 | Host Address Availability RecommendationsL. Colitti, V. Cerf, S. Cheshire, D. Schinazi | Best Current Practice | July 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8190 | Updates to the Special-Purpose IP Address RegistriesR. Bonica, M. Cotton, B. Haberman, L. Vegoda | Best Current Practice | June 2017 |