| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1995 | Incremental Zone Transfer in DNSM. Ohta | Proposed Standard | August 1996 |
| 2065 | Domain Name System Security ExtensionsD. Eastlake 3rd, C. Kaufman · obsoleted by RFC 2535 | Proposed Standard | January 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)P. Vixie, Ed., S. Thomson, Y. Rekhter, J. Bound | Proposed Standard | April 1997 |
| 2535 | Domain Name System Security ExtensionsD. Eastlake 3rd · obsoleted by RFC 4033, RFC 4034, RFC 4035 | Proposed Standard | March 1999 |
| 2931 | DNS Request and Transaction Signatures ( SIG(0)s )D. Eastlake 3rd | Proposed Standard | September 2000 |
| 3258 | Distributing Authoritative Name Servers via Shared Unicast AddressesT. Hardie | Informational | April 2002 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4880 | OpenPGP Message FormatJ. Callas, L. Donnerhacke, H. Finney, D. Shaw, R. Thayer · obsoleted by RFC 9580 | Proposed Standard | November 2007 |
| 5155 | DNS Security (DNSSEC) Hashed Authenticated Denial of ExistenceB. Laurie, G. Sisson, R. Arends, D. Blacka | Proposed Standard | March 2008 |
| 5936 | DNS Zone Transfer Protocol (AXFR)E. Lewis, A. Hoenes, Ed. | Proposed Standard | June 2010 |
| 6234 | US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)D. Eastlake 3rd, T. Hansen | Informational | May 2011 |
| 7696 | Guidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement AlgorithmsR. Housley | Best Current Practice | November 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7942 | Improving Awareness of Running Code: The Implementation Status SectionY. Sheffer, A. Farrel | Best Current Practice | July 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8484 | DNS Queries over HTTPS (DoH)P. Hoffman, P. McManus | Proposed Standard | October 2018 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8551 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message SpecificationJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |
| 8806 | Running a Root Server Local to a ResolverW. Kumari, P. Hoffman | Informational | June 2020 |
| 8901 | Multi-Signer DNSSEC ModelsS. Huque, P. Aras, J. Dickinson, J. Vcelak, D. Blacka | Informational | September 2020 |
| 8945 | Secret Key Transaction Authentication for DNS (TSIG)F. Dupont, S. Morris, P. Vixie, D. Eastlake 3rd, O. Gudmundsson, B. Wellington | Internet Standard | November 2020 |