rfc.dk

Cited in: RFC 8932

37 RFCs mentioned in the text of RFC 8932 (Recommendations for DNS Privacy Service Operators)

RFCTitleStatusDate
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
4033DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. RoseProposed StandardMarch 2005
4034Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. RoseProposed StandardMarch 2005
4035Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. RoseProposed StandardMarch 2005
5077Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846Proposed StandardJanuary 2008
5280Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. PolkProposed StandardMay 2008
6147DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, A. Sullivan, P. Matthews, I. van BeijnumProposed StandardApril 2011
6235IP Flow Anonymization SupportE. Boschi, B. TrammellExperimentalMay 2011
6265HTTP State Management MechanismA. BarthProposed StandardApril 2011
6841A Framework for DNSSEC Policies and DNSSEC Practice StatementsF. Ljunggren, AM. Eklund Lowinder, T. OkuboInformationalJanuary 2013
6973Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. SmithInformationalJuly 2013
7457Summarizing Known Attacks on Transport Layer Security (TLS) and Datagram TLS (DTLS)Y. Sheffer, R. Holz, P. Saint-AndreInformationalFebruary 2015
7525Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325Best Current PracticeMay 2015
7626DNS Privacy ConsiderationsS. Bortzmeyer · obsoleted by RFC 9076InformationalAugust 2015
7766DNS Transport over TCP - Implementation RequirementsJ. Dickinson, S. Dickinson, R. Bellis, A. Mankin, D. WesselsProposed StandardMarch 2016
7816DNS Query Name Minimisation to Improve PrivacyS. Bortzmeyer · obsoleted by RFC 9156ExperimentalMarch 2016
7828The edns-tcp-keepalive EDNS0 OptionP. Wouters, J. Abley, S. Dickinson, R. BellisProposed StandardApril 2016
7830The EDNS(0) Padding OptionA. MayrhoferProposed StandardMay 2016
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7858Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. HoffmanProposed StandardMay 2016
7871Client Subnet in DNS QueriesC. Contavalli, W. van der Gaast, D. Lawrence, W. KumariInformationalMay 2016
7873Domain Name System (DNS) CookiesD. Eastlake 3rd, M. AndrewsProposed StandardMay 2016
8020NXDOMAIN: There Really Is Nothing UnderneathS. Bortzmeyer, S. HuqueProposed StandardNovember 2016
8027DNSSEC Roadblock AvoidanceW. Hardaker, O. Gudmundsson, S. KrishnaswamyBest Current PracticeNovember 2016
8094DNS over Datagram Transport Layer Security (DTLS)T. Reddy, D. Wing, P. PatilExperimentalFebruary 2017
8174Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. LeibaBest Current PracticeMay 2017
8198Aggressive Use of DNSSEC-Validated CacheK. Fujiwara, A. Kato, W. KumariProposed StandardJuly 2017
8310Usage Profiles for DNS over TLS and DNS over DTLSS. Dickinson, D. Gillmor, T. ReddyProposed StandardMarch 2018
8404Effects of Pervasive Encryption on OperatorsK. Moriarty, Ed., A. Morton, Ed.InformationalJuly 2018
8446The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846Proposed StandardAugust 2018
8467Padding Policies for Extension Mechanisms for DNS (EDNS(0))A. MayrhoferExperimentalOctober 2018
8484DNS Queries over HTTPS (DoH)P. Hoffman, P. McManusProposed StandardOctober 2018
8490DNS Stateful OperationsR. Bellis, S. Cheshire, J. Dickinson, S. Dickinson, T. Lemon, T. PusateriProposed StandardMarch 2019
8499DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499Best Current PracticeJanuary 2019
8555Automatic Certificate Management Environment (ACME)R. Barnes, J. Hoffman-Andrews, D. McCarney, J. KastenProposed StandardMarch 2019
8618Compacted-DNS (C-DNS): A Format for DNS Packet CaptureJ. Dickinson, J. Hague, S. Dickinson, T. Manderson, J. BondProposed StandardSeptember 2019
8806Running a Root Server Local to a ResolverW. Kumari, P. HoffmanInformationalJune 2020