rfc.dk

Cited in: RFC 8915

23 RFCs mentioned in the text of RFC 8915 (Network Time Security for the Network Time Protocol)

RFCTitleStatusDate
20ASCII format for network interchangeV.G. CerfInternet StandardOctober 1969
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
4086Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. CrockerBest Current PracticeJune 2005
4291IP Version 6 Addressing ArchitectureR. Hinden, S. DeeringDraft StandardFebruary 2006
5077Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846Proposed StandardJanuary 2008
5116An Interface and Algorithms for Authenticated EncryptionD. McGrewProposed StandardJanuary 2008
5280Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. PolkProposed StandardMay 2008
5297Synthetic Initialization Vector (SIV) Authenticated Encryption Using the Advanced Encryption Standard (AES)D. HarkinsInformationalOctober 2008
5705Keying Material Exporters for Transport Layer Security (TLS)E. RescorlaProposed StandardMarch 2010
5869HMAC-based Extract-and-Expand Key Derivation Function (HKDF)H. Krawczyk, P. EronenInformationalMay 2010
5890Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. KlensinProposed StandardAugust 2010
5905Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. KaschProposed StandardJune 2010
6125Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525Proposed StandardMarch 2011
6335Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number RegistryM. Cotton, L. Eggert, J. Touch, M. Westerlund, S. CheshireBest Current PracticeAugust 2011
6874Representing IPv6 Zone Identifiers in Address Literals and Uniform Resource IdentifiersB. Carpenter, S. Cheshire, R. Hinden · obsoleted by RFC 9844Proposed StandardFebruary 2013
7301Transport Layer Security (TLS) Application-Layer Protocol Negotiation ExtensionS. Friedl, A. Popov, A. Langley, E. StephanProposed StandardJuly 2014
7384Security Requirements of Time Protocols in Packet Switched NetworksT. MizrahiInformationalOctober 2014
7525Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325Best Current PracticeMay 2015
7822Network Time Protocol Version 4 (NTPv4) Extension FieldsT. Mizrahi, D. MayerProposed StandardMarch 2016
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
8174Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. LeibaBest Current PracticeMay 2017
8446The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846Proposed StandardAugust 2018
8573Message Authentication Code for the Network Time ProtocolA. Malhotra, S. GoldbergProposed StandardJune 2019