| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 2606 | Reserved Top Level DNS NamesD. Eastlake 3rd, A. Panitz | Best Current Practice | June 1999 |
| 3225 | Indicating Resolver Support of DNSSECD. Conrad | Proposed Standard | December 2001 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4880 | OpenPGP Message FormatJ. Callas, L. Donnerhacke, H. Finney, D. Shaw, R. Thayer · obsoleted by RFC 9580 | Proposed Standard | November 2007 |
| 5198 | Unicode Format for Network InterchangeJ. Klensin, M. Padlipsky | Proposed Standard | March 2008 |
| 5598 | Internet Mail ArchitectureD. Crocker | Informational | July 2009 |
| 5782 | DNS Blacklists and WhitelistsJ. Levine | Informational | February 2010 |
| 6376 | DomainKeys Identified Mail (DKIM) SignaturesD. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed. | Internet Standard | September 2011 |
| 6530 | Overview and Framework for Internationalized EmailJ. Klensin, Y. Ko | Proposed Standard | February 2012 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 7208 | Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1S. Kitterman | Proposed Standard | April 2014 |
| 7489 | Domain-based Message Authentication, Reporting, and Conformance (DMARC)M. Kucherawy, Ed., E. Zwicky, Ed. · obsoleted by RFC 9989, RFC 9990, RFC 9991 | Informational | March 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8460 | SMTP TLS ReportingD. Margolis, A. Brotman, B. Ramakrishnan, J. Jones, M. Risher | Proposed Standard | September 2018 |
| 8482 | Providing Minimal-Sized Responses to DNS Queries That Have QTYPE=ANYJ. Abley, O. Gudmundsson, M. Majkowski, E. Hunt | Proposed Standard | January 2019 |
| 8601 | Message Header Field for Indicating Message Authentication StatusM. Kucherawy | Proposed Standard | May 2019 |