{
  "number": 8891,
  "title": "GOST R 34.12-2015: Block Cipher \"Magma\"",
  "authors": [
    "V. Dolmatov, Ed.",
    "D. Baryshkov"
  ],
  "published": "2020-09",
  "status": "Informational",
  "stream": "INDEPENDENT",
  "pages": 13,
  "formats": [
    "HTML",
    "TXT",
    "PDF",
    "XML"
  ],
  "abstract": "In addition to a new cipher with a block length of n=128 bits (referred to as \"Kuznyechik\" and described in RFC 7801), Russian Federal standard GOST R 34.12-2015 includes an updated version of the block cipher with a block length of n=64 bits and key length of k=256 bits, which is also referred to as \"Magma\". The algorithm is an updated version of an older block cipher with a block length of n=64 bits described in GOST 28147-89 (RFC 5830). This document is intended to be a source of information about the updated version of the 64-bit cipher. It may facilitate the use of the block cipher in Internet applications by providing information for developers and users of the GOST 64-bit cipher with the revised version of the cipher for encryption and decryption.",
  "keywords": [
    "Magma",
    "Block Cipher"
  ],
  "draft": "draft-dolmatov-magma-06",
  "doi": "10.17487/RFC8891",
  "updates": [
    "RFC5830"
  ],
  "urls": {
    "html": "https://rfc.dk/rfc8891/",
    "text": "https://rfc.dk/rfc8891.txt",
    "rfc_editor": "https://www.rfc-editor.org/rfc/rfc8891",
    "datatracker": "https://datatracker.ietf.org/doc/rfc8891/"
  },
  "text_modified": "2020-09-15T05:28:27.644286897Z"
}
