| 9520 | Negative Caching of DNS Resolution FailuresD. Wessels, W. Carroll, M. Thomas | Proposed Standard | December 2023 |
| 9499 | DNS TerminologyP. Hoffman, K. Fujiwara | Best Current Practice | March 2024 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8324 | DNS Privacy, Authorization, Special Uses, Encoding, Characters, Matching, and Root Structure: Time for Another Look?J. Klensin | Informational | February 2018 |
| 8244 | Special-Use Domain Names Problem StatementT. Lemon, R. Droms, W. Kumari | Informational | October 2017 |
| 7719 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 8499 | Informational | December 2015 |
| 6950 | Architectural Considerations on Application Features in the DNSJ. Peterson, O. Kolkman, H. Tschofenig, B. Aboba | Informational | October 2013 |
| 3467 | Role of the Domain Name System (DNS)J. Klensin | Informational | March 2003 |
| 1175 | FYI on where to start: A bibliography of internetworking informationK.L. Bowers, T.L. LaQuey, J.K. Reynolds, K. Roubicek, M.K. Stahl, A. Yuan | Informational | August 1990 |
| 1123 | Requirements for Internet Hosts - Application and SupportR. Braden, Ed. | Internet Standard | October 1989 |
| 1101 | DNS encoding of network names and other typesP. Mockapetris | Unknown | April 1989 |
| 1099 | Request for Comments Summary: RFC Numbers 1000-1099J. Reynolds | Informational | December 1991 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1012 | Bibliography of Request For Comments 1 through 999J.K. Reynolds, J. Postel | Informational | June 1987 |
| 1011 | Official Internet protocolsJ.K. Reynolds, J. Postel | Unknown | May 1987 |
| 1001 | Protocol standard for a NetBIOS service on a TCP/UDP transport: Concepts and methodsNetBIOS Working Group in the Defense Advanced Research Projects Agency, Internet Activities Board, End-to-End Services Task Force | Internet Standard | March 1987 |
| 1000 | Request For Comments reference guideJ.K. Reynolds, J. Postel | Unknown | August 1987 |
| 999 | Requests For Comments summary notes: 900-999A. Westine, J. Postel · obsoleted by RFC 1000 | Unknown | April 1987 |
| 991 | Official ARPA-Internet protocolsJ.K. Reynolds, J. Postel · obsoleted by RFC 1011 | Unknown | November 1986 |
| 990 | Assigned numbersJ.K. Reynolds, J. Postel · obsoleted by RFC 1010 | Historic | November 1986 |
| 974 | Mail routing and the domain systemC. Partridge · obsoleted by RFC 2821 | Historic | January 1986 |
| 973 | Domain system changes and observationsP. Mockapetris · obsoleted by RFC 1034, RFC 1035 | Unknown | January 1986 |
| 960 | Assigned numbersJ.K. Reynolds, J. Postel · obsoleted by RFC 990 | Historic | December 1985 |
| 955 | Towards a transport service for transaction processing applicationsR.T. Braden | Unknown | September 1985 |
| 921 | Domain name system implementation schedule - revisedJ. Postel | Unknown | October 1984 |
| 920 | Domain requirementsJ. Postel, J.K. Reynolds | Unknown | October 1984 |
| 915 | Network mail path serviceM.A. Elvy, R. Nedved | Unknown | December 1984 |
| 897 | Domain name system implementation scheduleJ. Postel | Unknown | February 1984 |
| 883 | Domain names: Implementation specificationP. Mockapetris · obsoleted by RFC 1034, RFC 1035 | Unknown | November 1983 |
| 881 | Domain names plan and scheduleJ. Postel | Unknown | November 1983 |