| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1812 | Requirements for IP Version 4 RoutersF. Baker, Ed. | Proposed Standard | June 1995 |
| 1919 | Classical versus Transparent IP ProxiesM. Chatel | Informational | March 1996 |
| 1928 | SOCKS Protocol Version 5M. Leech, M. Ganis, Y. Lee, R. Kuris, D. Koblas, L. Jones | Proposed Standard | March 1996 |
| 2018 | TCP Selective Acknowledgment OptionsM. Mathis, J. Mahdavi, S. Floyd, A. Romanow | Proposed Standard | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 3135 | Performance Enhancing Proxies Intended to Mitigate Link-Related DegradationsJ. Border, M. Kojo, J. Griner, G. Montenegro, Z. Shelby | Informational | June 2001 |
| 4279 | Pre-Shared Key Ciphersuites for Transport Layer Security (TLS)P. Eronen, Ed., H. Tschofenig, Ed. | Proposed Standard | December 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4787 | Network Address Translation (NAT) Behavioral Requirements for Unicast UDPF. Audet, Ed., C. Jennings | Best Current Practice | January 2007 |
| 4987 | TCP SYN Flooding Attacks and Common MitigationsW. Eddy | Informational | August 2007 |
| 5461 | TCP's Reaction to Soft ErrorsF. Gont | Informational | February 2009 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 6269 | Issues with IP Address SharingM. Ford, Ed., M. Boucadair, A. Durand, P. Levis, P. Roberts | Informational | June 2011 |
| 6296 | IPv6-to-IPv6 Network Prefix TranslationM. Wasserman, F. Baker | Experimental | June 2011 |
| 6731 | Improved Recursive DNS Server Selection for Multi-Interfaced NodesT. Savolainen, J. Kato, T. Lemon | Proposed Standard | December 2012 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 6888 | Common Requirements for Carrier-Grade NATs (CGNs)S. Perreault, Ed., I. Yamagata, S. Miyakawa, A. Nakagawa, H. Ashida | Best Current Practice | April 2013 |
| 6890 | Special-Purpose IP Address RegistriesM. Cotton, L. Vegoda, R. Bonica, Ed., B. Haberman | Best Current Practice | April 2013 |
| 6928 | Increasing TCP's Initial WindowJ. Chu, N. Dukkipati, Y. Cheng, M. Mathis | Experimental | April 2013 |
| 6978 | A TCP Authentication Option Extension for NAT TraversalJ. Touch | Experimental | July 2013 |
| 7250 | Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Wouters, Ed., H. Tschofenig, Ed., J. Gilmore, S. Weiler, T. Kivinen | Proposed Standard | June 2014 |
| 7323 | TCP Extensions for High PerformanceD. Borman, B. Braden, V. Jacobson, R. Scheffenegger, Ed. | Proposed Standard | September 2014 |
| 7413 | TCP Fast OpenY. Cheng, J. Chu, S. Radhakrishnan, A. Jain | Experimental | December 2014 |
| 7414 | A Roadmap for Transmission Control Protocol (TCP) Specification DocumentsM. Duke, R. Braden, W. Eddy, E. Blanton, A. Zimmermann | Informational | February 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8041 | Use Cases and Operational Experience with Multipath TCPO. Bonaventure, C. Paasch, G. Detal | Informational | January 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8305 | Happy Eyeballs Version 2: Better Connectivity Using ConcurrencyD. Schinazi, T. Pauly | Proposed Standard | December 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8548 | Cryptographic Protection of TCP Streams (tcpcrypt)A. Bittau, D. Giffin, M. Handley, D. Mazieres, Q. Slack, E. Smith | Experimental | May 2019 |
| 8684 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure, C. Paasch | Proposed Standard | March 2020 |