| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2702 | Requirements for Traffic Engineering Over MPLSD. Awduche, J. Malcolm, J. Agogbua, M. O'Dell, J. McManus | Informational | September 1999 |
| 3209 | RSVP-TE: Extensions to RSVP for LSP TunnelsD. Awduche, L. Berger, D. Gan, T. Li, V. Srinivasan, G. Swallow | Proposed Standard | December 2001 |
| 3272 | Overview and Principles of Internet Traffic EngineeringD. Awduche, A. Chiu, A. Elwalid, I. Widjaja, X. Xiao · obsoleted by RFC 9522 | Informational | May 2002 |
| 3471 | Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional DescriptionL. Berger, Ed. | Proposed Standard | February 2003 |
| 3477 | Signalling Unnumbered Links in Resource ReSerVation Protocol - Traffic Engineering (RSVP-TE)K. Kompella, Y. Rekhter | Proposed Standard | February 2003 |
| 3630 | Traffic Engineering (TE) Extensions to OSPF Version 2D. Katz, K. Kompella, D. Yeung | Proposed Standard | October 2003 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 3785 | Use of Interior Gateway Protocol (IGP) Metric as a second MPLS Traffic Engineering (TE) MetricF. Le Faucheur, R. Uppili, A. Vedrenne, P. Merckx, T. Telkamp | Best Current Practice | May 2004 |
| 4090 | Fast Reroute Extensions to RSVP-TE for LSP TunnelsP. Pan, Ed., G. Swallow, Ed., A. Atlas, Ed. | Proposed Standard | May 2005 |
| 4124 | Protocol Extensions for Support of Diffserv-aware MPLS Traffic EngineeringF. Le Faucheur, Ed. | Proposed Standard | June 2005 |
| 4125 | Maximum Allocation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic EngineeringF. Le Faucheur, W. Lai | Experimental | June 2005 |
| 4126 | Max Allocation with Reservation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering & Performance ComparisonsJ. Ash | Experimental | June 2005 |
| 4127 | Russian Dolls Bandwidth Constraints Model for Diffserv-aware MPLS Traffic EngineeringF. Le Faucheur, Ed. | Experimental | June 2005 |
| 4202 | Routing Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4203 | OSPF Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4328 | Generalized Multi-Protocol Label Switching (GMPLS) Signaling Extensions for G.709 Optical Transport Networks ControlD. Papadimitriou, Ed. | Proposed Standard | January 2006 |
| 4427 | Recovery (Protection and Restoration) Terminology for Generalized Multi-Protocol Label Switching (GMPLS)E. Mannie, Ed., D. Papadimitriou, Ed. | Informational | March 2006 |
| 4561 | Definition of a Record Route Object (RRO) Node-Id Sub-ObjectJ.-P. Vasseur, Ed., Z. Ali, S. Sivabalan | Proposed Standard | June 2006 |
| 4657 | Path Computation Element (PCE) Communication Protocol Generic RequirementsJ. Ash, Ed., J.L. Le Roux, Ed. | Informational | September 2006 |
| 4736 | Reoptimization of Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Loosely Routed Label Switched Path (LSP)JP. Vasseur, Ed., Y. Ikejiri, R. Zhang | Informational | November 2006 |
| 4872 | RSVP-TE Extensions in Support of End-to-End Generalized Multi-Protocol Label Switching (GMPLS) RecoveryJ.P. Lang, Ed., Y. Rekhter, Ed., D. Papadimitriou, Ed. | Proposed Standard | May 2007 |
| 4873 | GMPLS Segment RecoveryL. Berger, I. Bryskin, D. Papadimitriou, A. Farrel | Proposed Standard | May 2007 |
| 4874 | Exclude Routes - Extension to Resource ReserVation Protocol-Traffic Engineering (RSVP-TE)CY. Lee, A. Farrel, S. De Cnodder | Proposed Standard | April 2007 |
| 4875 | Extensions to Resource Reservation Protocol - Traffic Engineering (RSVP-TE) for Point-to-Multipoint TE Label Switched Paths (LSPs)R. Aggarwal, Ed., D. Papadimitriou, Ed., S. Yasukawa, Ed. | Proposed Standard | May 2007 |
| 4920 | Crankback Signaling Extensions for MPLS and GMPLS RSVP-TEA. Farrel, Ed., A. Satyanarayana, A. Iwata, N. Fujita, G. Ash | Proposed Standard | July 2007 |
| 5003 | Attachment Individual Identifier (AII) Types for AggregationC. Metz, L. Martini, F. Balus, J. Sugimoto | Proposed Standard | September 2007 |
| 5150 | Label Switched Path Stitching with Generalized Multiprotocol Label Switching Traffic Engineering (GMPLS TE)A. Ayyangar, K. Kompella, JP. Vasseur, A. Farrel | Proposed Standard | February 2008 |
| 5151 | Inter-Domain MPLS and GMPLS Traffic Engineering -- Resource Reservation Protocol-Traffic Engineering (RSVP-TE) ExtensionsA. Farrel, Ed., A. Ayyangar, JP. Vasseur | Proposed Standard | February 2008 |
| 5305 | IS-IS Extensions for Traffic EngineeringT. Li, H. Smit | Proposed Standard | October 2008 |
| 5307 | IS-IS Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2008 |
| 5420 | Encoding of Attributes for MPLS LSP Establishment Using Resource Reservation Protocol Traffic Engineering (RSVP-TE)A. Farrel, Ed., D. Papadimitriou, JP. Vasseur, A. Ayyangar | Proposed Standard | February 2009 |
| 5481 | Packet Delay Variation Applicability StatementA. Morton, B. Claise | Informational | March 2009 |
| 5541 | Encoding of Objective Functions in the Path Computation Element Communication Protocol (PCEP)JL. Le Roux, JP. Vasseur, Y. Lee | Proposed Standard | June 2009 |
| 5712 | MPLS Traffic Engineering Soft PreemptionM. Meyer, Ed., JP. Vasseur, Ed. | Proposed Standard | January 2010 |
| 5817 | Graceful Shutdown in MPLS and Generalized MPLS Traffic Engineering NetworksZ. Ali, JP. Vasseur, A. Zamfir, J. Newton | Informational | April 2010 |
| 6001 | Generalized MPLS (GMPLS) Protocol Extensions for Multi-Layer and Multi-Region Networks (MLN/MRN)D. Papadimitriou, M. Vigoureux, K. Shiomoto, D. Brungard, JL. Le Roux | Proposed Standard | October 2010 |
| 6002 | Generalized MPLS (GMPLS) Data Channel Switching Capable (DCSC) and Channel Set Label ExtensionsL. Berger, D. Fedyk | Proposed Standard | October 2010 |
| 6004 | Generalized MPLS (GMPLS) Support for Metro Ethernet Forum and G.8011 Ethernet Service SwitchingL. Berger, D. Fedyk | Proposed Standard | October 2010 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6119 | IPv6 Traffic Engineering in IS-ISJ. Harrison, J. Berger, M. Bartlett | Proposed Standard | February 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6370 | MPLS Transport Profile (MPLS-TP) IdentifiersM. Bocci, G. Swallow, E. Gray | Proposed Standard | September 2011 |
| 6374 | Packet Loss and Delay Measurement for MPLS NetworksD. Frost, S. Bryant | Proposed Standard | September 2011 |
| 6378 | MPLS Transport Profile (MPLS-TP) Linear ProtectionY. Weingarten, Ed., S. Bryant, E. Osborne, N. Sprecher, A. Fulignoli, Ed. | Proposed Standard | October 2011 |
| 6511 | Non-Penultimate Hop Popping Behavior and Out-of-Band Mapping for RSVP-TE Label Switched PathsZ. Ali, G. Swallow, R. Aggarwal | Proposed Standard | February 2012 |
| 6780 | RSVP ASSOCIATION Object ExtensionsL. Berger, F. Le Faucheur, A. Narayanan | Proposed Standard | October 2012 |
| 6790 | The Use of Entropy Labels in MPLS ForwardingK. Kompella, J. Drake, S. Amante, W. Henderickx, L. Yong | Proposed Standard | November 2012 |
| 6827 | Automatically Switched Optical Network (ASON) Routing for OSPFv2 ProtocolsA. Malis, Ed., A. Lindem, Ed., D. Papadimitriou, Ed. | Proposed Standard | January 2013 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7138 | Traffic Engineering Extensions to OSPF for GMPLS Control of Evolving G.709 Optical Transport NetworksD. Ceccarelli, Ed., F. Zhang, S. Belotti, R. Rao, J. Drake | Proposed Standard | March 2014 |
| 7139 | GMPLS Signaling Extensions for Control of Evolving G.709 Optical Transport NetworksF. Zhang, Ed., G. Zhang, S. Belotti, D. Ceccarelli, K. Pithewan | Proposed Standard | March 2014 |
| 7260 | GMPLS RSVP-TE Extensions for Operations, Administration, and Maintenance (OAM) ConfigurationA. Takacs, D. Fedyk, J. He | Proposed Standard | June 2014 |
| 7308 | Extended Administrative Groups in MPLS Traffic Engineering (MPLS-TE)E. Osborne | Proposed Standard | July 2014 |
| 7471 | OSPF Traffic Engineering (TE) Metric ExtensionsS. Giacalone, D. Ward, J. Drake, A. Atlas, S. Previdi | Proposed Standard | March 2015 |
| 7551 | RSVP-TE Extensions for Associated Bidirectional Label Switched Paths (LSPs)F. Zhang, Ed., R. Jing, R. Gandhi, Ed. | Proposed Standard | May 2015 |
| 7570 | Label Switched Path (LSP) Attribute in the Explicit Route Object (ERO)C. Margaria, Ed., G. Martinelli, S. Balls, B. Wright | Proposed Standard | July 2015 |
| 7571 | GMPLS RSVP-TE Extensions for Lock Instruct and LoopbackJ. Dong, M. Chen, Z. Li, D. Ceccarelli | Proposed Standard | July 2015 |
| 7579 | General Network Element Constraint Encoding for GMPLS-Controlled NetworksG. Bernstein, Ed., Y. Lee, Ed., D. Li, W. Imajuku, J. Han | Proposed Standard | June 2015 |
| 7823 | Performance-Based Path Selection for Explicitly Routed Label Switched Paths (LSPs) Using TE Metric ExtensionsA. Atlas, J. Drake, S. Giacalone, S. Previdi | Informational | May 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8001 | RSVP-TE Extensions for Collecting Shared Risk Link Group (SRLG) InformationF. Zhang, Ed., O. Gonzalez de Dios, Ed., C. Margaria, M. Hartley, Z. Ali | Proposed Standard | January 2017 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8149 | RSVP Extensions for Reoptimization of Loosely Routed Point-to-Multipoint Traffic Engineering Label Switched Paths (LSPs)T. Saad, Ed., R. Gandhi, Ed., Z. Ali, R. Venator, Y. Kamite | Proposed Standard | April 2017 |
| 8169 | Residence Time Measurement in MPLS NetworksG. Mirsky, S. Ruffini, E. Gray, J. Drake, S. Bryant, A. Vainshtein | Proposed Standard | May 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8294 | Common YANG Data Types for the Routing AreaX. Liu, Y. Qu, A. Lindem, C. Hopps, L. Berger | Proposed Standard | December 2017 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8345 | A YANG Data Model for Network TopologiesA. Clemm, J. Medved, R. Varga, N. Bahadur, H. Ananthakrishnan, X. Liu | Proposed Standard | March 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8570 | IS-IS Traffic Engineering (TE) Metric ExtensionsL. Ginsberg, Ed., S. Previdi, Ed., S. Giacalone, D. Ward, J. Drake, Q. Wu | Proposed Standard | March 2019 |