| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 4514 | Lightweight Directory Access Protocol (LDAP): String Representation of Distinguished NamesK. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4517 | Lightweight Directory Access Protocol (LDAP): Syntaxes and Matching RulesS. Legg, Ed. | Proposed Standard | June 2006 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5952 | A Recommendation for IPv6 Address Text RepresentationS. Kawamura, M. Kawashima | Proposed Standard | August 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6749 | The OAuth 2.0 Authorization FrameworkD. Hardt, Ed. | Proposed Standard | October 2012 |
| 6750 | The OAuth 2.0 Authorization Framework: Bearer Token UsageM. Jones, D. Hardt | Proposed Standard | October 2012 |
| 7009 | OAuth 2.0 Token RevocationT. Lodderstedt, Ed., S. Dronia, M. Scurtescu | Proposed Standard | August 2013 |
| 7517 | JSON Web Key (JWK)M. Jones | Proposed Standard | May 2015 |
| 7518 | JSON Web Algorithms (JWA)M. Jones | Proposed Standard | May 2015 |
| 7519 | JSON Web Token (JWT)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7591 | OAuth 2.0 Dynamic Client Registration ProtocolJ. Richer, Ed., M. Jones, J. Bradley, M. Machulak, P. Hunt | Proposed Standard | July 2015 |
| 7662 | OAuth 2.0 Token IntrospectionJ. Richer, Ed. | Proposed Standard | October 2015 |
| 7800 | Proof-of-Possession Key Semantics for JSON Web Tokens (JWTs)M. Jones, J. Bradley, H. Tschofenig | Proposed Standard | April 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8414 | OAuth 2.0 Authorization Server MetadataM. Jones, N. Sakimura, J. Bradley | Proposed Standard | June 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |