| 1724 | RIP Version 2 MIB ExtensionG. Malkin, F. Baker | Draft Standard | November 1994 |
| 2080 | RIPng for IPv6G. Malkin, R. Minnear | Proposed Standard | January 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2453 | RIP Version 2G. Malkin | Internet Standard | November 1998 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 7951 | JSON Encoding of Data Modeled with YANGL. Lhotka | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8177 | YANG Data Model for Key ChainsA. Lindem, Ed., Y. Qu, D. Yeung, I. Chen, J. Zhang | Proposed Standard | June 2017 |
| 8340 | YANG Tree DiagramsM. Bjorklund, L. Berger, Ed. | Best Current Practice | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8342 | Network Management Datastore Architecture (NMDA)M. Bjorklund, J. Schoenwaelder, P. Shafer, K. Watsen, R. Wilton | Proposed Standard | March 2018 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8344 | A YANG Data Model for IP ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8349 | A YANG Data Model for Routing Management (NMDA Version)L. Lhotka, A. Lindem, Y. Qu | Proposed Standard | March 2018 |
| 8407 | Guidelines for Authors and Reviewers of Documents Containing YANG Data ModelsA. Bierman · obsoleted by RFC 9907 | Best Current Practice | October 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8639 | Subscription to YANG NotificationsE. Voit, A. Clemm, A. Gonzalez Prieto, E. Nilsen-Nygaard, A. Tripathy | Proposed Standard | September 2019 |
| 8641 | Subscription to YANG Notifications for Datastore UpdatesA. Clemm, E. Voit | Proposed Standard | September 2019 |