| 1939 | Post Office Protocol - Version 3J. Myers, M. Rose | Internet Standard | May 1996 |
| 2033 | Local Mail Transfer ProtocolJ. Myers | Informational | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3207 | SMTP Service Extension for Secure SMTP over Transport Layer SecurityP. Hoffman | Proposed Standard | February 2002 |
| 3461 | Simple Mail Transfer Protocol (SMTP) Service Extension for Delivery Status Notifications (DSNs)K. Moore | Draft Standard | January 2003 |
| 3501 | INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1M. Crispin · obsoleted by RFC 9051 | Proposed Standard | March 2003 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4880 | OpenPGP Message FormatJ. Callas, L. Donnerhacke, H. Finney, D. Shaw, R. Thayer · obsoleted by RFC 9580 | Proposed Standard | November 2007 |
| 5228 | Sieve: An Email Filtering LanguageP. Guenther, Ed., T. Showalter, Ed. | Proposed Standard | January 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5248 | A Registry for SMTP Enhanced Mail System Status CodesT. Hansen, J. Klensin | Best Current Practice | June 2008 |
| 5321 | Simple Mail Transfer ProtocolJ. Klensin | Draft Standard | October 2008 |
| 5322 | Internet Message FormatP. Resnick, Ed. | Draft Standard | October 2008 |
| 5598 | Internet Mail ArchitectureD. Crocker | Informational | July 2009 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6409 | Message Submission for MailR. Gellens, J. Klensin | Internet Standard | November 2011 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7672 | SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)V. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8314 | Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and AccessK. Moore, C. Newman | Proposed Standard | January 2018 |
| 8461 | SMTP MTA Strict Transport Security (MTA-STS)D. Margolis, M. Risher, B. Ramakrishnan, A. Brotman, J. Jones | Proposed Standard | September 2018 |
| 8551 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message SpecificationJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |