| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 4105 | Requirements for Inter-Area MPLS Traffic EngineeringJ.-L. Le Roux, Ed., J.-P. Vasseur, Ed., J. Boyle, Ed. | Informational | June 2005 |
| 4216 | MPLS Inter-Autonomous System (AS) Traffic Engineering (TE) RequirementsR. Zhang, Ed., J.-P. Vasseur, Ed. | Informational | November 2005 |
| 4655 | A Path Computation Element (PCE)-Based ArchitectureA. Farrel, J.-P. Vasseur, J. Ash | Informational | August 2006 |
| 4726 | A Framework for Inter-Domain Multiprotocol Label Switching Traffic EngineeringA. Farrel, J.-P. Vasseur, A. Ayyangar | Informational | November 2006 |
| 5152 | A Per-Domain Path Computation Method for Establishing Inter-Domain Traffic Engineering (TE) Label Switched Paths (LSPs)JP. Vasseur, Ed., A. Ayyangar, Ed., R. Zhang | Proposed Standard | February 2008 |
| 5376 | Inter-AS Requirements for the Path Computation Element Communication Protocol (PCECP)N. Bitar, R. Zhang, K. Kumaki | Informational | November 2008 |
| 5394 | Policy-Enabled Path Computation FrameworkI. Bryskin, D. Papadimitriou, L. Berger, J. Ash | Informational | December 2008 |
| 5440 | Path Computation Element (PCE) Communication Protocol (PCEP)JP. Vasseur, Ed., JL. Le Roux, Ed. | Proposed Standard | March 2009 |
| 5441 | A Backward-Recursive PCE-Based Computation (BRPC) Procedure to Compute Shortest Constrained Inter-Domain Traffic Engineering Label Switched PathsJP. Vasseur, Ed., R. Zhang, N. Bitar, JL. Le Roux | Proposed Standard | April 2009 |
| 5520 | Preserving Topology Confidentiality in Inter-Domain Path Computation Using a Path-Key-Based MechanismR. Bradford, Ed., JP. Vasseur, A. Farrel | Proposed Standard | April 2009 |
| 5541 | Encoding of Objective Functions in the Path Computation Element Communication Protocol (PCEP)JL. Le Roux, JP. Vasseur, Y. Lee | Proposed Standard | June 2009 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 6805 | The Application of the Path Computation Element Architecture to the Determination of a Sequence of Domains in MPLS and GMPLSD. King, Ed., A. Farrel, Ed. | Informational | November 2012 |
| 7399 | Unanswered Questions in the Path Computation Element ArchitectureA. Farrel, D. King | Informational | October 2014 |
| 7420 | Path Computation Element Communication Protocol (PCEP) Management Information Base (MIB) ModuleA. Koushik, E. Stephan, Q. Zhao, D. King, J. Hardwick | Proposed Standard | December 2014 |
| 7752 | North-Bound Distribution of Link-State and Traffic Engineering (TE) Information Using BGPH. Gredler, Ed., J. Medved, S. Previdi, A. Farrel, S. Ray · obsoleted by RFC 9552 | Proposed Standard | March 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7897 | Domain Subobjects for the Path Computation Element Communication Protocol (PCEP)D. Dhody, U. Palle, R. Casellas | Experimental | June 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8253 | PCEPS: Usage of TLS to Provide a Secure Transport for the Path Computation Element Communication Protocol (PCEP)D. Lopez, O. Gonzalez de Dios, Q. Wu, D. Dhody | Proposed Standard | October 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |