| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 5389 | Session Traversal Utilities for NAT (STUN)J. Rosenberg, R. Mahy, P. Matthews, D. Wing · obsoleted by RFC 8489 | Proposed Standard | October 2008 |
| 5625 | DNS Proxy Implementation GuidelinesR. Bellis | Best Current Practice | August 2009 |
| 5766 | Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)R. Mahy, P. Matthews, J. Rosenberg · obsoleted by RFC 8656 | Proposed Standard | April 2010 |
| 6052 | IPv6 Addressing of IPv4/IPv6 TranslatorsC. Bao, C. Huitema, M. Bagnulo, M. Boucadair, X. Li | Proposed Standard | October 2010 |
| 6144 | Framework for IPv4/IPv6 TranslationF. Baker, X. Li, C. Bao, K. Yin | Informational | April 2011 |
| 6146 | Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6147 | DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, A. Sullivan, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6535 | Dual-Stack Hosts Using "Bump-in-the-Host" (BIH)B. Huang, H. Deng, T. Savolainen | Proposed Standard | February 2012 |
| 6877 | 464XLAT: Combination of Stateful and Stateless TranslationM. Mawatari, M. Kawashima, C. Byrne | Informational | April 2013 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 6889 | Analysis of Stateful 64 TranslationR. Penno, T. Saxena, M. Boucadair, S. Sivakumar | Informational | April 2013 |
| 6950 | Architectural Considerations on Application Features in the DNSJ. Peterson, O. Kolkman, H. Tschofenig, B. Aboba | Informational | October 2013 |
| 7050 | Discovery of the IPv6 Prefix Used for IPv6 Address SynthesisT. Savolainen, J. Korhonen, D. Wing | Proposed Standard | November 2013 |
| 7051 | Analysis of Solution Proposals for Hosts to Learn NAT64 PrefixJ. Korhonen, Ed., T. Savolainen, Ed. | Informational | November 2013 |
| 7225 | Discovering NAT64 IPv6 Prefixes Using the Port Control Protocol (PCP)M. Boucadair | Proposed Standard | May 2014 |
| 7269 | NAT64 Deployment Options and ExperienceG. Chen, Z. Cao, C. Xie, D. Binet | Informational | June 2014 |
| 7755 | SIIT-DC: Stateless IP/ICMP Translation for IPv6 Data Center EnvironmentsT. Anderson | Proposed Standard | February 2016 |
| 7756 | Stateless IP/ICMP Translation for IPv6 Internet Data Center Environments (SIIT-DC): Dual Translation ModeT. Anderson, S. Steffann | Proposed Standard | February 2016 |
| 7757 | Explicit Address Mappings for Stateless IP/ICMP TranslationT. Anderson, A. Leiva Popper | Internet Standard | February 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7849 | An IPv6 Profile for 3GPP Mobile DevicesD. Binet, M. Boucadair, A. Vizdal, G. Chen, N. Heatley, R. Chandler, D. Michaud, D. Lopez, W. Haeffner | Informational | May 2016 |
| 7858 | Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. Hoffman | Proposed Standard | May 2016 |
| 7915 | IP/ICMP Translation AlgorithmC. Bao, X. Li, F. Baker, T. Anderson, F. Gont | Proposed Standard | June 2016 |
| 8094 | DNS over Datagram Transport Layer Security (DTLS)T. Reddy, D. Wing, P. Patil | Experimental | February 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8219 | Benchmarking Methodology for IPv6 Transition TechnologiesM. Georgescu, L. Pislaru, G. Lencse | Informational | August 2017 |
| 8273 | Unique IPv6 Prefix per HostJ. Brzozowski, G. Van de Velde | Informational | December 2017 |
| 8305 | Happy Eyeballs Version 2: Better Connectivity Using ConcurrencyD. Schinazi, T. Pauly | Proposed Standard | December 2017 |
| 8375 | Special-Use Domain 'home.arpa.'P. Pfister, T. Lemon | Proposed Standard | May 2018 |
| 8415 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)T. Mrugalski, M. Siodelski, B. Volz, A. Yourtchenko, M. Richardson, S. Jiang, T. Lemon, T. Winters · obsoleted by RFC 9915 | Proposed Standard | November 2018 |
| 8445 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) TraversalA. Keranen, C. Holmberg, J. Rosenberg | Proposed Standard | July 2018 |
| 8484 | DNS Queries over HTTPS (DoH)P. Hoffman, P. McManus | Proposed Standard | October 2018 |
| 8585 | Requirements for IPv6 Customer Edge Routers to Support IPv4-as-a-ServiceJ. Palet Martinez, H. M.-H. Liu, M. Kawashima | Informational | May 2019 |