| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2663 | IP Network Address Translator (NAT) Terminology and ConsiderationsP. Srisuresh, M. Holdrege | Informational | August 1999 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 3704 | Ingress Filtering for Multihomed NetworksF. Baker, P. Savola | Best Current Practice | March 2004 |
| 4191 | Default Router Preferences and More-Specific RoutesR. Draves, D. Thaler | Proposed Standard | November 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 5082 | The Generalized TTL Security Mechanism (GTSM)V. Gill, J. Heasley, D. Meyer, P. Savola, Ed., C. Pignataro | Proposed Standard | October 2007 |
| 5533 | Shim6: Level 3 Multihoming Shim Protocol for IPv6E. Nordmark, M. Bagnulo | Proposed Standard | June 2009 |
| 5534 | Failure Detection and Locator Pair Exploration Protocol for IPv6 MultihomingJ. Arkko, I. van Beijnum | Proposed Standard | June 2009 |
| 6106 | IPv6 Router Advertisement Options for DNS ConfigurationJ. Jeong, S. Park, L. Beloeil, S. Madanapalli · obsoleted by RFC 8106 | Proposed Standard | November 2010 |
| 6296 | IPv6-to-IPv6 Network Prefix TranslationM. Wasserman, F. Baker | Experimental | June 2011 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 6824 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure · obsoleted by RFC 8684 | Experimental | January 2013 |
| 7078 | Distributing Address Selection Policy Using DHCPv6A. Matsumoto, T. Fujisaki, T. Chown | Proposed Standard | January 2014 |
| 7556 | Multiple Provisioning Domain ArchitectureD. Anipko, Ed. | Informational | June 2015 |
| 7676 | IPv6 Support for Generic Routing Encapsulation (GRE)C. Pignataro, R. Bonica, S. Krishnan | Proposed Standard | October 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8028 | First-Hop Router Selection by Hosts in a Multi-Prefix NetworkF. Baker, B. Carpenter | Proposed Standard | November 2016 |
| 8106 | IPv6 Router Advertisement Options for DNS ConfigurationJ. Jeong, S. Park, L. Beloeil, S. Madanapalli | Proposed Standard | March 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8415 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)T. Mrugalski, M. Siodelski, B. Volz, A. Yourtchenko, M. Richardson, S. Jiang, T. Lemon, T. Winters · obsoleted by RFC 9915 | Proposed Standard | November 2018 |
| 8425 | IANA Considerations for IPv6 Neighbor Discovery Prefix Information Option FlagsO. Troan | Proposed Standard | July 2018 |
| 8504 | IPv6 Node RequirementsT. Chown, J. Loughney, T. Winters | Best Current Practice | January 2019 |