{
  "number": 8664,
  "title": "Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing",
  "authors": [
    "S. Sivabalan",
    "C. Filsfils",
    "J. Tantsura",
    "W. Henderickx",
    "J. Hardwick"
  ],
  "published": "2019-12",
  "status": "Proposed Standard",
  "stream": "IETF",
  "area": "rtg",
  "working_group": "pce",
  "pages": 29,
  "formats": [
    "HTML",
    "TXT",
    "PDF",
    "XML"
  ],
  "abstract": "Segment Routing (SR) enables any head-end node to select any path without relying on a hop-by-hop signaling technique (e.g., LDP or RSVP-TE). It depends only on \"segments\" that are advertised by link-state Interior Gateway Protocols (IGPs). An SR path can be derived from a variety of mechanisms, including an IGP Shortest Path Tree (SPT), an explicit configuration, or a Path Computation Element (PCE). This document specifies extensions to the Path Computation Element Communication Protocol (PCEP) that allow a stateful PCE to compute and initiate Traffic-Engineering (TE) paths, as well as a Path Computation Client (PCC) to request a path subject to certain constraints and optimization criteria in SR networks.\n\nThis document updates RFC 8408.",
  "keywords": [
    "SR",
    "Traffic-Engineering",
    "PCE"
  ],
  "draft": "draft-ietf-pce-segment-routing-16",
  "doi": "10.17487/RFC8664",
  "errata_url": "https://www.rfc-editor.org/errata/rfc8664",
  "updates": [
    "RFC8408"
  ],
  "updated_by": [
    "RFC9756",
    "RFC9933"
  ],
  "urls": {
    "html": "https://rfc.dk/rfc8664/",
    "text": "https://rfc.dk/rfc8664.txt",
    "rfc_editor": "https://www.rfc-editor.org/rfc/rfc8664",
    "datatracker": "https://datatracker.ietf.org/doc/rfc8664/"
  },
  "text_modified": "2019-12-06T21:35:59.26651216Z"
}
